Risultati da 1 a 10 di 10

Discussione: Somma con criterio parziale



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Smile Somma con criterio parziale

    Ciao a tutti

    In F2 ho bisogno di una formula che mi somma i totali di tutti gli oggetti contenenti la stringa "REJ"
    Buon divertimento


    A
    B
    C
    D
    E
    F
    1
    DATA BASE SOMME Criterio RISULTATO
    2
    Rejected
    30
    Rej
    35
    3
    Rej
    25
    4
    Rej-ddd
    50
    5
    Layover
    20
    6
    Reroute
    10
    7
    Unload
    5
    Ultima modifica fatta da:Gerardo Zuccalà; 30/06/15 alle 23:22

  2. #2
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    scusa, non capisco il risultato di 35

  3. #3
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15
    anchio infatti come fa a tornare 35

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Oppsss! scusate come al solito la stanchezza e il caldo mi tradiscono
    infatti per 35 si intende tutto ciò che non contiene "REJ"

    ciao e buon lavoro!
    Ultima modifica fatta da:Gerardo Zuccalà; 30/06/15 alle 23:22

  5. #5
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    esagero
    =MATR.SOMMA.PRODOTTO(--(STRINGA.ESTRAI(A2:A7;1;3)="rej");B2:B7)

    =MATR.SOMMA.PRODOTTO(--(SINISTRA(A2:A7;3)="rej");B2:B7)

  6. #6
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    infatti avevo capito male :-)

  7. #7

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7164
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1304
    Se non ho capito male anch'io, l'inverso del conteggio fatto da Stefano

    =MATR.SOMMA.PRODOTTO(--(STRINGA.ESTRAI(A2:A7;1;3)<>A3);B2:B7)

  8. #8
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    =SOMMA(B2:B7)-MATR.SOMMA.PRODOTTO(--(STRINGA.ESTRAI(A2:A7;1;3)="rej");B2:B7)

    =SOMMA(B2:B7)-MATR.SOMMA.PRODOTTO(--(SINISTRA(A2:A7;3)="rej");B2:B7)
    Ultima modifica fatta da:Gerardo Zuccalà; 01/07/15 alle 08:42

  9. #9
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao,

    un modo potrebbe essere

    Codice: 
    =SOMMA.SE(A2:A100;"<>"&"*"&D2&"*";B2:B100)
    Saluti

  10. #10
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Woow! canapone
    Grazie ges e Stefano....
    La risposta più completa è di Canapone perchè se cambia la posizione della stringa "Rej" come potete vedere in A:A la formula trova sempre "rej"
    in questo caso la risposta è 5 perchè è l'unico dato non contenente "REJ"

    =SOMMA.SE(A2:A100;"<>"&"*"&D2&"*";B2:B100)

    ciao a tutti


    A
    B
    C
    D
    E
    F
    1
    DATA BASE SOMME Criterio RISULTATO
    2
    Rejected
    30
    Rej
    5
    3
    Rej
    25
    4
    Rej-ddd
    50
    5
    Lrejver
    20
    6
    Rerorej
    10
    7
    Unload
    5
    Ultima modifica fatta da:Gerardo Zuccalà; 01/07/15 alle 09:06

Discussioni Simili

  1. Conteggio parziale
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 26/03/16, 07:29
  2. Somma con singolo criterio su fogli multipli
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 09/09/15, 08:17
  3. Somma con ricerca parziale del testo
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 12/07/15, 23:34
  4. Somma con doppio Criterio
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 15
    Ultimo Messaggio: 11/07/15, 23:58
  5. Valore minimo con criterio parziale
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 08/07/15, 13:52

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •