Risultati da 1 a 12 di 12

Discussione: Cerca Vert



  1. #1
    L'avatar di smanimania
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    roma
    Messaggi
    4
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    0

    Cerca Vert

    Buongiorno, relativamente ad un'analisi SEO devo applicare il cerca vert su un file excel e utilizzarlo con Gephi, seguendo il tutorial di lowlel:


    Il file è cosi strutturato:
    • 2 tab
    • nella prima ci sono 4 colonne
    • nella seconda ci sono 2 colonne

    devo fare un cerca vert delle 2 colonne della seconda tab in 2 colonne della prima tab, in allegato il file excel con le colonne di interesse evidenziate. Non so come iniziare

    Grazie anticipatamente,
    Smanimania
    File Allegati File Allegati

  2. #2
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2078
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117
    Ciao

    comincia con mettere dei dati e dire che valore vuoi cercare

    cerco cosa? dati in che colonna

    cerca-valore X- nel range A1.......C200.......posizione Y

    dov'è il valore da cercare?

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di smanimania
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    roma
    Messaggi
    4
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    0
    Grazie per la risposta, allora spiego nel dettaglio:

    La prima tab è composta dalle seguenti colonne:
    • Source
    • Source Canonical (è vuota)
    • Destination
    • Destination Canonical (è vuota)

    La prima e la terza colonna contengono un elenco di link

    La seconda tab è composta dalle seguenti colonne:

    • Address
    • Canonical Link

    Ciascuna colonna contiene un elenco di link

    Nella prima tab, nel primo campo della colonna Source ho impostato la funzione in questo modo: =CERCA.VERT(B4;'secondatab'!A:B;2;FALSO)

    e mi restituisce il valore corretto, il problema è che essendo 10.000 link voglio automatizzare il processo, come posso risolvere
    Grazie per la disponibilità

  5. #4
    L'avatar di Bolz1
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Padova
    Età
    41
    Messaggi
    117
    Versione Office
    '11 e 16 MAC
    Likes ricevuti
    7
    Likes dati
    1
    Cosa significa "automatizzare il processo"? Se carichi un file con alcuni esempi senza dati sensibili forse sarebbe meglio...:269:
    "Se tu segui tua stella non puoi fallire a glorioso porto" (Dante, Inferno - XV)

  6. #5
    L'avatar di smanimania
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    roma
    Messaggi
    4
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    0
    il lavoro che devo fare è:
    controllare se i link presenti all'interno della colonna "source" della prima tab,sono presenti nella colonna "Address" della seconda tab, se sono presenti vanno inseriti nella colonna "source canonical" della prima tab.

    Cosa ho fatto:
    nel prima campo della colonna "source canonical" ho inserito questa funzione : =CERCA.VERT(B2;'due'!A:B;2;FALSO)
    vorrei impostare il foglio in modo tale che automaticamente mi controlla tutti i link della colonna "Source" e me li inserisca nella colonna "source canonical" tramite la funzione cerca.vert

    In allegato il file excel

    Grazie :58:
    File Allegati File Allegati

  7. #6
    L'avatar di Bolz1
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Padova
    Età
    41
    Messaggi
    117
    Versione Office
    '11 e 16 MAC
    Likes ricevuti
    7
    Likes dati
    1
    ...non riesco ad eliminare il post...Gerardo, non si possono eliminare i propri post?
    "Se tu segui tua stella non puoi fallire a glorioso porto" (Dante, Inferno - XV)

  8. #7
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2078
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117
    Ciao
    non so se ho capito bene
    ma la risposta te la sei data da solo

    Inserisci in C3

    Codice: 
    =SE.ERRORE(CERCA.VERT(B3;due!$A$3:$B$357;2);"")
    e tira in giù fino alla cella che ti serve.

    quello in rosso è il dato da cambiare al bisogno.

  9. #8

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4028
    Versione Office
    2013
    Likes ricevuti
    1232
    Likes dati
    925
    Ciao a tutti,

    @smanismania
    come ti ha risposto Gianfranco (un saluto), la formula che stai usando va bene, al massimo potresti aggiungere un SE.ERRORE per evitare di farti restituire un errore quando non trova alcun riscontro...

    quindi in cella B3 del foglio "uno" metterai:

    =SE.ERRORE(CERCA.VERT(B4;due!A:B;2;FALSO);"")

    al momento ti restituirà sempre errore (o meglio....una cella vuota) per il semplice fatto che non c'è nemmeno un indirizzo uguale ma la formula è corretta.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  10. #9
    L'avatar di Bolz1
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Padova
    Età
    41
    Messaggi
    117
    Versione Office
    '11 e 16 MAC
    Likes ricevuti
    7
    Likes dati
    1
    Nel messaggio che avevo tentato di cancellare sopra avevo fatto lo stesso ragionamento ma poi, visto che la formula di smanimania andava bene (a parte il se.errore), avevo paura di aver capito male...io non vorrei che intendesse averli consecutivi e non solo sulla stessa riga (stile colonna di riepilogo di tutti i "veri")...ma credo che senza vba non sia possibile...
    "Se tu segui tua stella non puoi fallire a glorioso porto" (Dante, Inferno - XV)

  11. #10

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4028
    Versione Office
    2013
    Likes ricevuti
    1232
    Likes dati
    925
    Citazione Originariamente Scritto da Bolz1 Visualizza Messaggio
    Nel messaggio che avevo tentato di cancellare sopra avevo fatto lo stesso ragionamento ma poi, visto che la formula di smanimania andava bene (a parte il se.errore), avevo paura di aver capito male...io non vorrei che intendesse averli consecutivi e non solo sulla stessa riga (stile colonna di riepilogo di tutti i "veri")...ma credo che senza vba non sia possibile...

    Ciao Bolz1,
    per fare quello che intendi (supponendo che gli indirizzi siano univoci) si potrebbe usare questa formula matriciale nella cella B3 del foglio "uno" e dopo copiare in basso:

    =SE.ERRORE(INDICE(due!$B$3:$B$50;PICCOLO(SE.ERRORE(CONFRONTA($B$3:$B$17;due!$A$3:$A$22;0);"");RIF.RIGA(A1)));"")

    P.S.
    Nel file allegato ho copiato due indirizzi dal foglio "due" per avere almeno un paio di corrispondenze per poter provare la formula.
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  12. #11

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4028
    Versione Office
    2013
    Likes ricevuti
    1232
    Likes dati
    925
    [EDIT]
    questa invece dovrebbe andare bene anche se nella colonna A del foglio "due" ci dovesse essere più di una corrispondenza con uno stesso indirizzo nella colonna A del foglio "uno".

    Da mettere nella cella B3 del foglio "uno" e copiare in basso (matriciale):

    =SE.ERRORE(INDICE(due!$B$1:$B$50;PICCOLO(SE.ERRORE(RIF.RIGA(due!$B$3:$B$22)*(1/CONTA.SE(uno!$B$3:$B$17;due!$A$3:$A$22));"");RIF.RIGA(A1)));"")

    P.S.
    per l'utilizzo del CONTA.SE in questa maniera devo ringraziare le formule proposte da Canapone :246:

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  13. #12
    L'avatar di smanimania
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    roma
    Messaggi
    4
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    0
    Ciao ragazzi grazie a tutti per le risposte e per la disponibilità :286:

    ho risolto semplicemente utilizzando questa formula =CERCA.VERT(B4;'secondatab'!A:B;2;FALSO) e con doppio click in basso a destra della cella per applicarla a tutta la colonna.
    Complimenti per il forum, a presto

Discussioni Simili

  1. cerca.vert
    Di antonio64 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 05/03/17, 22:54
  2. [Risolto] Cerca valori che si ripetono in tabella. Formula per arrivare dove il cerca.vert non può
    Di Gatt88 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 02/12/16, 11:45
  3. [Risolto] Cerca.vert
    Di replay66 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 17/09/16, 15:52
  4. Cerca.Vert con Se
    Di jigen nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 02/08/16, 12:31
  5. Cerca.vert
    Di Snoopy nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 09/06/16, 17:01

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •