Risultati da 1 a 6 di 6

Discussione: Ricerca testo all'interno di una tabella



  1. #1
    L'avatar di Tomelc64
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Età
    53
    Messaggi
    4
    Likes ricevuti
    0
    Likes dati
    0

    Ricerca testo all'interno di una tabella

    Si lo so dal titolo sembra essere cosa facile, ma in realtà la domanda è molto più complessa.
    Ho necessità di trovare un codice ( es.11-00-00-210-801) all'interno di una tabella dove è molto probabile trovare sia lo stesso codice, sia il codice riportato nel esempio con aggiunto alla fine un' altra breve serie di numeri o lettere (es.11-00-00-210-801-01 (s)).

    Io utilizzo EXCEL2007
    Ultima modifica fatta da:Canapone; 30/06/17 alle 15:51

    Tomelc64

    Excel 2007
    Windows 7

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da Tomelc64 Visualizza Messaggio
    Si lo so dal titolo sembra essere cosa facile, ma in realtà la domanda è molto più complessa.
    Ho necessità di trovare un codice ( es.11-00-00-210-801) all'interno di una tabella dove è molto probabile trovare sia lo stesso codice, sia il codice riportato nel esempio con aggiunto alla fine un' altra breve serie di numeri o lettere (es.11-00-00-210-801-01 (s)).

    Io utilizzo EXCEL2007

    Ciao TOM
    benvenuto e grazie per la domanda!:tanks:
    Potresti postare un esempio con il risultato finale scritto a mano, cosi evitiamo 1000aia di parole e andiamo dritti al sodo
    per inserire un esempio potresti aggiungere un allegato di Excel e se non sai come fare guarda questo VIDEO


    Citazione Originariamente Scritto da Tomelc64 Visualizza Messaggio

    Io utilizzo EXCEL2007
    Tom ti consiglio di scrivere la versione di excel che hai nella firma cosi non dovrai ripeterla (esempio guarda la mia firma!
    Ciao Tom e grazie ancora
    Ultima modifica fatta da:Gerardo Zuccalà; 01/07/15 alle 11:40

  3. #3
    L'avatar di Tomelc64
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Età
    53
    Messaggi
    4
    Likes ricevuti
    0
    Likes dati
    0
    vedi allegato

    Tomelc64

    Excel 2007
    Windows 7

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    faccio un primo tentativo usando anch'io RICERCA

    In C3 da copiare in basso

    Codice: 
    =SE.ERRORE(INDICE(Foglio1!$C$3:$C$100;CONFRONTA(1;INDICE(RICERCA("*"&$B3&"*";Foglio1!$B$3:$B$100););0));"")
    in E3

    Codice: 
    =SE.ERRORE(INDICE(Foglio1!$D$3:$D$100;CONFRONTA(1;INDICE(RICERCA("*"&$B3&"*";Foglio1!$B$3:$B$100););0));"")
    Saluti

  5. #5
    L'avatar di Tomelc64
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Età
    53
    Messaggi
    4
    Likes ricevuti
    0
    Likes dati
    0
    applicandolo all'esempio funziona, ora traspongo la funzione ai fogli che utilizzo e ti/vi faccio sapere. Per ora assolutamente grazie :)

    Tomelc64

    Excel 2007
    Windows 7

  6. #6
    L'avatar di Tomelc64
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Età
    53
    Messaggi
    4
    Likes ricevuti
    0
    Likes dati
    0
    perfetto funziona egregiamente. Grazie ancora

    Tomelc64

    Excel 2007
    Windows 7

Discussioni Simili

  1. Testo con dati in percentuale al suo interno
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 06/03/16, 23:22
  2. Ricerca valore all'interno di matrice sotto specifiche condizioni
    Di Zakkino nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 12/02/16, 18:08
  3. Ricerca all'interno dei campi
    Di BaldoGiovane nel forum Domande su Excel VBA e MACRO
    Risposte: 31
    Ultimo Messaggio: 24/12/15, 18:51
  4. ricerca all'interno di un database_2
    Di John nel forum Domande su Excel VBA e MACRO
    Risposte: 2
    Ultimo Messaggio: 08/10/15, 15:20
  5. Ricerca all'interno di un database
    Di John nel forum Domande su Excel VBA e MACRO
    Risposte: 6
    Ultimo Messaggio: 07/10/15, 14:49

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •