Risultati da 1 a 9 di 9

Discussione: Somma di valori unici senza la virgola



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5385
    Versione Office
    office 365/2016
    Likes ricevuti
    1272
    Likes dati
    1338

    Somma di valori unici senza la virgola

    Ciao a tutti visto il gran caldo il livello si alza sempre più
    nella cella C2 vorrei sapere la somma di valori unici/univoci che sono nella coonna A:A
    il totale è 4 perchè valori unici (non duplicati) e tolta la virgola sono il numero 1,2,6,7
    buon divertimento!


    A
    B
    C
    1
    dataset Risultato
    2
    2,3
    4
    3
    1
    4
    6
    5
    2,3
    6
    6
    7
    6
    8
    6
    9
    7,1
    10
    7,3
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  2. #2
    L'avatar di Andre81
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Parma
    Età
    37
    Messaggi
    65
    Versione Office
    2013
    Likes ricevuti
    2
    Likes dati
    9
    Ciao Gerardo,

    la mia soluzione è questa (da attivare premendo ctrl+alt+invio):

    =SOMMA(--(FREQUENZA(ARROTONDA(A2:A10;0);ARROTONDA(A2:A10;0))>0))




    Andrea
    Ultima modifica fatta da:Andre81; 02/07/15 alle 19:14

  3. #3
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1123
    Versione Office
    2010 su Win
    Likes ricevuti
    642
    Likes dati
    224
    Ciao a tutti

    ci provo anch'io:

    Codice: 
    =SOMMA(SE(FREQUENZA(CONFRONTA(INT(A2:A100)&"";INT(A2:A100)&"";0);RIF.RIGA(A1:A500));INT(A2:A100)))
    Da confermare con control+maiusc+invio

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1123
    Versione Office
    2010 su Win
    Likes ricevuti
    642
    Likes dati
    224
    Meglio così

    Codice: 
    =SOMMA(SE(FREQUENZA(INT(A2:A100);INT(A2:A100));INT(A2:A100)))
    sempre matriciale

    Saluti


    Row\Col
    A
    B
    C
    D
    E
    1
    1,1
    =SUM(IF(FREQUENCY(MATCH(INT(A2:A100)&"",INT(A2:A100)&"",0),ROW(A1:A500)),INT(A2:A100)))
    2
    2
    =SUM(IF(FREQUENCY(INT(A2:A100),INT(A2:A100)),INT(A2:A100)))
    3
    3
    4
    1,1
    5
    1,1
    6
    3
    7
    8
    7,4
    9
    7,411
    10
    4,1
    11
    4
    12
    Ultima modifica fatta da:Canapone; 02/07/15 alle 19:32

  5. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5385
    Versione Office
    office 365/2016
    Likes ricevuti
    1272
    Likes dati
    1338
    Ciao tutti,
    ottima la soluzione di Andrea81 molto Smart!!

    Ma anche la seconda soluzione di canapone che a differenza della prima non ha usato il CONFRONTA perchè il FREQUENZA lavora con i numeri e non ha la necessita di trasformare i numeri in numeri perchè sono già numeri
    comuque qui la mia formula

    ovviamente questa formula per essere attivata bisogna fare CTRL+SHIFT+ENTER
    =SOMMA(SE(FREQUENZA(SE(A2:A100<>"";CONFRONTA(TRONCA(A2:A100);TRONCA(A2:A100);0));RIF.RIGA(A2:A100)-RIF.RIGA($A$1)+1);1))

    ciao ragazzi e se non avete altre soluzioni alternative considero questa discussione risolta
    ciao
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5385
    Versione Office
    office 365/2016
    Likes ricevuti
    1272
    Likes dati
    1338
    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    Meglio così

    Codice: 
    =SOMMA(SE(FREQUENZA(INT(A2:A100);INT(A2:A100));INT(A2:A100)))
    sempre matriciale

    Saluti
    Ciao Canapone
    le tue formule mi fanno collassare!!!:252:
    Canapone Mi piace la scheda BBCode che hai inserito peccato che ha la formula è in inglese grrrr
    Canapone io ho una nuova versione di BBCode da Istallare solo che dovresti prima disinstallare la vecchia versione (senò va in conflitto) e poi istalla la nuova versione che si presenta con le intestazioni rosse come questa:
    B
    C
    1
    SQUARA
    PUNTI
    2
    Roma
    23
    3
    Inter
    27
    4
    Juventus
    27
    5
    Catania
    31
    6
    Reggina
    33
    7
    Napoli
    29


    se vuoi istallarla devi guarda il video nella mia firma!
    ciao
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  7. #7
    L'avatar di Andre81
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Parma
    Età
    37
    Messaggi
    65
    Versione Office
    2013
    Likes ricevuti
    2
    Likes dati
    9
    Ciao a tutti,

    ho anche estratto i valori univoci mettendoli in ordine crescente

    Excel 2013
    Row\Col
    A
    B
    C
    D
    E
    1
    dataset Risultato valori univoci
    2
    2,3
    4
    1
    3
    1
    2
    4
    6
    6
    5
    2,3
    7
    6
    6
    7
    6
    8
    6
    9
    7,1
    10
    7,3
    Sheet: Foglio3

    La formula che ho creato (selezionando le celle da E2 a E10, e confermando con ctrl+maiusc+invio) è questa:

    =SE.ERRORE(PICCOLO(SE(FREQUENZA(ARROTONDA(A2:A10;0);ARROTONDA(A2:A10;0))>0;ARROTONDA(A2:A10;0));RIF.RIGA(A1:A10));"")

  8. #8
    L'avatar di Andrea
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Levico Terme
    Età
    60
    Messaggi
    38
    Versione Office
    2016
    Likes ricevuti
    5
    Likes dati
    13
    Ciao Gerardo.
    Queste due formule vanno bene ?
    La prima somma i valori unici interi =MATR.SOMMA.PRODOTTO(INT(D10:D18);--(FREQUENZA(INT(D10:D18);D10:D17)>0))
    La seconda conta i valori unici interi =SOMMA(--(FREQUENZA(INT(D10:D18);D10:D17)>0))


    ps: ok arrivo sempre con l'ultimo treno... ma prima o poi arrivo :)
    Ultima modifica fatta da:Andrea; 10/08/15 alle 20:43

  9. #9
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    2139
    Versione Office
    2010 PC
    Likes ricevuti
    1180
    Likes dati
    238
    Visto adesso. Sono con il tel ma provo a scrivere una mia formula semplificata=matr.somma.prodotto(--(confronta(int(a1:a:10);int(a1:a10);0)=rif.riga(1:10)))
    Ultima modifica fatta da:ninai; 12/08/15 alle 12:34

Discussioni Simili

  1. Da tabella a colonna con valori unici
    Di Gianfranco55 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 05/03/17, 19:00
  2. [Risolto] Contare gli unici valori contrassegnati
    Di Francesca77 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 11/02/17, 22:07
  3. Conta Valori unici
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 26/08/16, 12:12
  4. Conteggio valori unici
    Di delusan nel forum Domande su Excel in generale
    Risposte: 18
    Ultimo Messaggio: 04/03/16, 10:31
  5. Conteggio valori unici
    Di delusan nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 09/11/15, 12:44

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •