Risultati da 1 a 8 di 8

Discussione: estrarre stringhe alfanumeriche da excel



  1. #1
    L'avatar di zaqsedc
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    bologna
    Età
    33
    Messaggi
    5
    Versione Office
    2007
    Mi Piace ricevuti
    0
    Mi Piace dati
    0

    estrarre stringhe alfanumeriche da excel

    Ciao a tutti avrei bisogno di sapere anche solo la teoria da studiarmi se fattibile tale cosa. Scusate ma sono un utilizzatore scarso di excel.

    uova farina sale
    2 struzzo 20g segale 2 g marino
    3 gallina 30g avena 3 g rosa
    4 papera 10 orzo 1 g zucchero
    foglio1 foglio2 foglio3

    vorrei creare un foglio che scrivendo un codice alphanumerico tipo AB1mi vada a pescare dai fogli i valori collegati a quel codice.

    tipo

    3 gallina
    30 g avena
    3 g rosa

    grazie mille per l'aiuto

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    52
    Messaggi
    3650
    Versione Office
    2011/2016MAC
    Mi Piace ricevuti
    1087
    Mi Piace dati
    638
    Ciao zaq ....,
    allega per favore un piccolo file dell'esempio di ciò che vuoi ottenere così possiamo essere più precisi.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di zaqsedc
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    bologna
    Età
    33
    Messaggi
    5
    Versione Office
    2007
    Mi Piace ricevuti
    0
    Mi Piace dati
    0
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao zaq ....,
    allega per favore un piccolo file dell'esempio di ciò che vuoi ottenere così possiamo essere più precisi.
    Grazie per la risposta e allego il file.
    Vorrei imparare ad usare Excel se avete anche una guida che spieghi come indicizzare celle e leggere e scrivere valori ne sarei veramente contento.
    File Allegati File Allegati

  4. #4
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    57
    Messaggi
    524
    Versione Office
    Office 2013
    Mi Piace ricevuti
    495
    Mi Piace dati
    1066
    Ciao zaqsedc, se ho capito bene, dovrebbero andar bene le seguenti:

    In B7:
    =SE(GRANDE(--('ingredienti 1'!$A$3:$A$5=ricetta!$D$2);1)>0;INDICE('ingredienti 1'!B$3:B$5;GRANDE(SE(--('ingredienti 1'!$A$3:$A$5=ricetta!$D$2);(RIF.RIGA('ingredienti 1'!$A$3:$A$5)-RIF.RIGA('ingredienti 1'!$A$3)+1));1));"")

    In B8:
    =SE(GRANDE(--('ingredienti 2'!$A$3:$A$5=ricetta!$D$2);1)>0;INDICE('ingredienti 2'!B$3:B$5;GRANDE(SE(--('ingredienti 2'!$A$3:$A$5=ricetta!$D$2);(RIF.RIGA('ingredienti 2'!$A$3:$A$5)-RIF.RIGA('ingredienti 2'!$A$3)+1));1));"")

    Tieni presente che ho aggiunto in "ingredienti1" ed in "ingredienti2" una colonna aggiuntiva definita "CODICI".
    Le formule in B7 e in B8, vanno confermate con CTRL+MAIUSCOLO+INVIO e poi trascinati verso destra ed infine tirate giù.
    Allego il file di prova.
    Fa sapere.
    File Allegati File Allegati

  5. I seguenti utenti hanno dato un "Mi Piace"

    ges

  6. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    52
    Messaggi
    3650
    Versione Office
    2011/2016MAC
    Mi Piace ricevuti
    1087
    Mi Piace dati
    638
    Ciao pkrome,
    la tua formula funziona benissimo ma io ho inteso che il codice da inserire in D1 debba essere uguale a quello presente nei due fogli, e quindi basterebbe INDICE/CONFRONTA, cioè così:

    =INDICE('ingredienti 1'!C$3:C$5;CONFRONTA(ricetta!$D$2;'ingredienti 1'!$A$3:$A$5;0))
    =INDICE('ingredienti 2'!B$3:B$5;CONFRONTA(ricetta!$D$2;'ingredienti 2'!$A$3:$A$5;0))

    Comunque aspettiamo il riscontro del richiedente!
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  7. #6
    L'avatar di zaqsedc
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    bologna
    Età
    33
    Messaggi
    5
    Versione Office
    2007
    Mi Piace ricevuti
    0
    Mi Piace dati
    0

    Re: estrarre stringhe alfanumeriche da excel

    Innanzi tutto grazie è perfetto. Allora ho fatto i compitini ma riesco a capire penso il 60% Provo a chiedere spezzettando la formula

    SE(GRANDE(--('ingredienti 1'!$A$3:$A$5=ricetta!$D$2);1)>0 questo è il test della IF e dice che se la D2 è uguale ad un valore della colonna che va da A3 ad A5 del foglio "ingredienti 1" restituire valore 1 e quindi se tutta la parentesi è >1 entriamo nella condizione di vero della IF.

    Di tutto questo non capisco la funzione (GRANDE(-- ho letto dalla guida che questa funzione restituisce il valore piu grande di una matrice o vettore che sia ma i due meno per cosa stanno?e poi perchè si vuole il valore più grande di una IF in questo caso che restituisce un 1?

    Per ora scrivo questo poi le altre altrimenti appesantisco tutto grazie mille

    Comunque aspettiamo il riscontro del richiedente![/QUOTE]

  8. #7
    L'avatar di zaqsedc
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    bologna
    Età
    33
    Messaggi
    5
    Versione Office
    2007
    Mi Piace ricevuti
    0
    Mi Piace dati
    0

    Re: estrarre stringhe alfanumeriche da excel

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao pkrome,
    la tua formula funziona benissimo ma io ho inteso che il codice da inserire in D1 debba essere uguale a quello presente nei due fogli, e quindi basterebbe INDICE/CONFRONTA, cioè così:

    =INDICE('ingredienti 1'!C$3:C$5;CONFRONTA(ricetta!$D$2;'ingredienti 1'!$A$3:$A$5;0))
    =INDICE('ingredienti 2'!B$3:B$5;CONFRONTA(ricetta!$D$2;'ingredienti 2'!$A$3:$A$5;0))

    Comunque aspettiamo il riscontro del richiedente!
    In verità i campi da compilare sono uno per ogni foglio tipo in D2 ci può andare una scelta del foglio "ingredienti 1" e nella cella D3 ci può andare una scelta del foglio "ingredienti 2" Ma questo lo riesco a fare perchè praticamente uso le formule scritte ma dandogli il confronto con un altra cella tipo la D3. Così in D2 posso scrivere AB2 e in C2 posso scrivere AC3 ottenendo:

    AB3 4 gallina intere
    AC2 200 tipo 00 non setacciare

  9. #8
    L'avatar di Dillina
    Clicca e Apri
    Data Registrazione
    Aug 2016
    Località
    Tenerife
    Messaggi
    976
    Versione Office
    2013
    Mi Piace ricevuti
    126
    Mi Piace dati
    512

    Re: estrarre stringhe alfanumeriche da excel

    Wow zacsedc!!!
    8 mesi per i compitini!!! Hai preparato per lo meno gallina o è ancora lì che aspetta? Scherzo!
    Bentornato!!! I ragazzi ti risponderanno appena potranno.
    Ho notato che prima di postare non sei neppure passato dal VIA

    Appena hai due minuti...ti aspetto!!!
    Sii gentile quando possibile. È sempre possibile
    (Dalai Lama)

Discussioni Simili

  1. Estrarre stringhe testo o numeri da una cella
    Di robynud nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 17/03/16, 11:07
  2. Estrarre Testo da Stringhe non regolari e matching
    Di tmac720 nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 10/02/16, 17:44
  3. excel estrarre
    Di Alessandro68 nel forum Domande su Excel in generale
    Risposte: 18
    Ultimo Messaggio: 17/01/16, 11:32
  4. Estrarre numeri da stringhe -quiz
    Di ges nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 28/08/15, 23:02
  5. Quiz #5 Estrarre nomi da Stringhe
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 23/06/15, 05:03

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •