Risultati da 1 a 14 di 14

Discussione: somma se



  1. #1
    L'avatar di giesa15
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    milano
    Messaggi
    35
    Versione Office
    2011 MAC
    Likes ricevuti
    1

    somma se

    ciao a tutti. ho un'elenco di codici alfanumerici (alcuni uguali che si ripetono nell'elenco) a cui sono associati dei valori. Vorrei ottenere in un'altra cella la somma automatica di tutti i valori che corrispondono ad uno stesso codice.

    codici valore
    A 50
    A 7
    B 10
    B 21
    B 55
    C 22
    D 109
    D 4

    esiste una formula che permetta questo calcolo? chi mi aiuta? grazie

    :167:

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1339
    ciao e benvenutoa in forumexcel.it
    credo che nel titolo della tua domanda c'è già la risposta

    se i dati sono nella colonna A e B
    metti i criteri nella colonna E
    e poi questa formula
    =SOMMA.SE($A$2:$A$9;E2;$B$2:$B$9)

    ​Fammi sapere!
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    54
    Messaggi
    9992
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2574
    Likes dati
    1547
    Se invece i dati sono nella stessa colonna (es. A1:A8) e vuoi per esempio sommare i numeri abbinati alla A:

    =MATR.SOMMA.PRODOTTO((ANNULLA.SPAZI(SINISTRA(A1:A8;2))=ANNULLA.SPAZI(SINISTRA($A$1;2)))*(ANNULLA.SPAZI(STRINGA.ESTRAI(A1:A8;TROVA(" ";A1:A8);3))))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4
    L'avatar di giesa15
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    milano
    Messaggi
    35
    Versione Office
    2011 MAC
    Likes ricevuti
    1
    grazie Gerardo della celere risposta!! ti allego file prova perché non ho capito bene come applicare la formula. Nel file allegato vorrei automaticamente nella colonna C far comparire le somme che ho indicato in giallo che corrispondono alla somma dei valori degli stessi codici.
    File Allegati File Allegati

  5. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1339
    ok allora prova questa formula in C2 e copiala verso il basso

    =SE(A2=A3;"";SOMMA.SE($A$2:$A$9;A2;$B$2:$B$9))

    fammi sapere!!
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  6. #6
    L'avatar di giesa15
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    milano
    Messaggi
    35
    Versione Office
    2011 MAC
    Likes ricevuti
    1
    Ges grazie x la risposta! nel mio allegato forse ti è più chiaro cò che mi serve

  7. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1339
    Citazione Originariamente Scritto da giesa15 Visualizza Messaggio
    Ges grazie x la risposta! nel mio allegato forse ti è più chiaro cò che mi serve
    infatti la formula che ho fatto dovrebbe soddisfare la tua richiesta
    ad ogni modo ti allego il file
    File Allegati File Allegati
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  8. #8
    L'avatar di giesa15
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    milano
    Messaggi
    35
    Versione Office
    2011 MAC
    Likes ricevuti
    1
    la formula è corretta, funziona! avrei un'altra formula da chiederti ma con il cerca verticale. magari domani

  9. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    54
    Messaggi
    9992
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2574
    Likes dati
    1547
    Citazione Originariamente Scritto da giesa15 Visualizza Messaggio
    Ges grazie x la risposta! nel mio allegato forse ti è più chiaro cò che mi serve
    Va bene la formula di Gerardo,
    ti posto solo qualche alternativa:

    =MATR.SOMMA.PRODOTTO((A2:A9=A2)*(B2:B9))
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  10. #10
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1339
    Citazione Originariamente Scritto da giesa15 Visualizza Messaggio
    la formula è corretta, funziona! avrei un'altra formula da chiederti ma con il cerca verticale. magari domani
    ok grazie per il tuo riscontro e se hai risolto questa discussione metti RISOLTO vai in "strumenti discussione" in alto in questa pagina e metti "segna questa discussione come risolto"

    giesa15 se hai un'altra domanda è meglio iniziare una discussione nuova
    ciao buona notte!!
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  11. #11
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1339
    @ges
    Forse ho capito male la domanda di gheisa15 ma la formula che hai postato nel post #9 è un po diversa dalla mia
    non è questa:
    =SOMMA.PIÙ.SE(B2:B9;A2:A9;A2)

    ma questa:
    =SE(A2=A3;"";SOMMA.SE($A$2:$A$9;A2;$B$2:$B$9))
    che ovviamente fa una bella differenza senza la necessità di cancellare le corrispondenti celle che non servono perchè sarà excel a non metterli
    ciao Ges
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  12. #12

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    54
    Messaggi
    9992
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2574
    Likes dati
    1547
    Ciao Gerardo, ho capito cosa intendi, allora propongo un'alternativa alla tua soluzione in C2 da trascinare in basso:

    =SE(CONTA.SE($A$2:A2;A2)=1;MATR.SOMMA.PRODOTTO((A2:A9=A2)*(B2:B9));"")

    o in quest'altra versione:

    =SE(CONTA.SE($A$2:A2;A2)=1;SOMMA.PIÙ.SE($B$2:$B$9;$A$2:$A$9;A2);"")

    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  13. I seguenti 3 utenti hanno dato un "Like" a ges per questo post:


  14. #13
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1339
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao Gerardo, ho capito cosa intendi, allora propongo un'alternativa alla tua soluzione in C2 da trascinare in basso:

    =SE(CONTA.SE($A$2:A2;A2)=1;MATR.SOMMA.PRODOTTO((A2:A9=A2)*(B2:B9));"")

    o in quest'altra versione:

    =SE(CONTA.SE($A$2:A2;A2)=1;SOMMA.PIÙ.SE($B$2:$B$9;$A$2:$A$9;A2);"")


    Ottima!!:285:
    sicuramente è meglio della mia formula perchè mantiene la somma parziale in corrispondenza della cella più i alto.

    =SE(CONTA.SE($A$2:A2;A2)=1;MATR.SOMMA.PRODOTTO(($A$2:$A$9=A2)*($B$2:$B$9));"")
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  15. #14
    L'avatar di giesa15
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    milano
    Messaggi
    35
    Versione Office
    2011 MAC
    Likes ricevuti
    1
    Grazie ges!, questa è proprio quella che intendevo con la somma in corrispondenza della cella più in alto. Grazie ciao

Discussioni Simili

  1. MACRO: una somma "dinamica" in una cella che mi salvi tale somma ogni 24 ore
    Di armandino nel forum Domande su Excel VBA e MACRO
    Risposte: 7
    Ultimo Messaggio: 15/10/15, 21:36

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •