Risultati da 1 a 6 di 6

Discussione: Creazione classifica top 5



  1. #1
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    LocalitÓ
    Milano
    EtÓ
    51
    Messaggi
    871
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Creazione classifica top 5

    Ciao a tutti,
    ho bisogno di voi per ( https://www.dropbox.com/s/7t5mx923h2...orum.xlsx?dl=0 ):
    1) riportare nel foglio "dashboard" a partire da C13 i valori presenti nel foglio Helper tenendo conto della data in F1
    2) ottenuto quanto sopra creare in E5 e J5 una top 5

    Anticipo che le richieste di cui sopra sono molto simili ad altri thread dello scrivente ma vuoi per la stanchezza o per incapacitÓ non riesco ad arrivarci :292:

    Nel caso serva un elenco "d'appoggio" l'ho creato in Legenda R2

    Grazie in anticipo
    Gene

  2. #2
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao GBobe
    la formula si annuncia un po lunga ed io francamente preferisco fin che si pu˛ accorciarla un pochettino, e mi riferisco su come sono disposti i dati
    se per te non Ŕ un problema va bene se li dispongo cosi tutti in solo database anzichŔ 2?

    B
    C
    D
    E
    F
    12

    Numero

    Durata
    13
    A-C1
    285
    66
    14
    B-C2
    280
    134
    15
    C-C3
    110
    27
    16
    D-C4
    71
    14
    17
    E-C5
    82
    62
    18
    G-C7
    68
    15
    19
    H-C8
    162
    43
    20
    L-C9
    0
    0
    21
    M-C10
    179
    30
    22
    N-C11
    101
    18
    23
    P-C12
    92
    14
    24
    J-C13
    83
    29
    25
    K-C14
    182
    27
    26
    Q-C15
    98
    66
    27
    R-C16
    121
    37
    28
    U-C18
    111
    70
    29
    X-C19
    103
    28
    30
    S-C20
    162
    47
    31
    T-C21
    283
    54
    32
    Z-C22
    256
    51

  3. #3
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da G.Bove Visualizza Messaggio
    Ciao a tutti,
    ho bisogno di voi per ( https://www.dropbox.com/s/7t5mx923h2...orum.xlsx?dl=0 ):
    1) riportare nel foglio "dashboard" a partire da C13 i valori presenti nel foglio Helper tenendo conto della data in F1
    2) ottenuto quanto sopra creare in E5 e J5 una top 5

    Anticipo che le richieste di cui sopra sono molto simili ad altri thread dello scrivente ma vuoi per la stanchezza o per incapacitÓ non riesco ad arrivarci :292:

    Nel caso serva un elenco "d'appoggio" l'ho creato in Legenda R2

    Grazie in anticipo
    Gene

    Eccoci qui!!

    Ho fatto delle piccole modifiche:

    -primo ho messo il data base tutto insieme
    -secondo ho tolto qualche unione di cella perchŔ le formule matrici vedono le celle unite come fumo negli occhi
    -terzo ho fatto delle colone di appoggio (in giallo) che ovviamente le puoi nascondere e spostare

    ci sono anche altre soluzioni ma questa secondo me Ŕ la pi¨ semplice leggera e veloce

    colonna aggiuntiva per il numero
    =GRANDE($D$13:$D$32;RIGHE($D$5:D5))

    e poi formula per estrarre i top 5 NUMERO (da confermare matriciale)
    =INDICE($B$13:$B$32;PICCOLO(SE($D$13:$D$32=D5;RIF.RIGA($B$13:$B$32)-RIF.RIGA($B$13)+1);CONTA.SE($D$5:D5;D5)))

    colonna aggiuntiva per la durata
    =GRANDE($F$13:$F$32;RIGHE($D$5:D5))

    e poi formula per estrarre i top 5 DURATA (da confermare matriciale)
    =INDICE($B$13:$B$32;PICCOLO(SE($F$13:$F$32=H5;RIF.RIGA($B$13:$B$32)-RIF.RIGA($B$13)+1);CONTA.SE($H$5:H5;H5)))

    se tu avessi avuto la funzione AGGREGA avremmo potuto evitare formule matriciali
    File Allegati File Allegati

  4. I seguenti utenti hanno dato un "Like"


  5. #4
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    LocalitÓ
    Milano
    EtÓ
    51
    Messaggi
    871
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186
    Ciao,
    in successione:
    a) Per riportare i dati come da punto 1 del mio post #1 ci sono suggerimenti?
    b) il database separato era solo per una ragione estetica quindi No problem.
    c) per evitare le colonne d'appoggio (anche nascoste) nella dashboard posso "traslare" le formule in legenda o helper e poi da li pescarle per estrarre la top 5?

    Grazie per la risposta
    Gene

  6. #5
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    1687
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185
    ciao
    per come sto capendo io, per riportare i numeri e le durate dei vari codici (messi tutti in unica colonna come suggerito da Gerardo)
    in D13:
    =INDICE(Helper!$B$3:$U$368;CONFRONTA($F$1;Helper!$A$3:$A$368;0);RIGHE($D$13:D13))
    e trascini in basso
    in F13:
    =INDICE(Helper!$W$3:$AP$368;CONFRONTA($F$1;Helper!$A$3:$A$368;0);RIGHE($D$13:D13))

    per l'estrazione dei primi 5 , puoi usare le formule di Gerardo, anche se a questo punto eviterei la colonna di appoggio, integrando le due formule
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed Ŕ un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  7. I seguenti utenti hanno dato un "Like"


  8. #6
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    LocalitÓ
    Milano
    EtÓ
    51
    Messaggi
    871
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186
    Ciao
    Confermo che l'unione Ninai & Gerardo ha dato i suoi frutti :274:.

    La giusta conclusione prevede:
    1) L'enunciazione della formula per l'estrazione della top 5 senza colonna d'appoggio ma integrando gli input di Gerardo:
    Codice: 
    =SE.ERRORE(INDICE(Dashboard!$B$15:$B$34;CONFRONTA(1;INDICE((Dashboard!C$15:C$34=GRANDE(Dashboard!C$15:C$34;RIGHE(Dashboard!A$5:A5)))*(Dashboard!C$15:C$34<>0););0));"")
    2) Lo scontato ma doveroso ringraziamento a Gerardo e Ninai per l'aiuto.

    Alla prossima
    Gene

Discussioni Simili

  1. Creazione classifica Excel
    Di Whipper nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 01/02/17, 16:06
  2. Estrapolare una classifica di categoria da una classifica generale
    Di Albyspace nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 29/09/16, 00:54
  3. classifica a categorie
    Di redheart67 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 05/06/16, 12:27
  4. Classifica
    Di Manu nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 22/10/15, 14:37
  5. Classifica
    Di Jackmeda nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 18/09/15, 17:35

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •