Risultati da 1 a 4 di 4

Discussione: Assegnare un codice in base al comune di residenza e una data



  1. #1
    L'avatar di Luigi Paravan
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Arquata Scrivia
    Età
    62
    Messaggi
    46
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    0

    Assegnare un codice in base al comune di residenza e una data

    Ciao a tutti, un aiuto per trovare una funzione più "elegante" di questa
    Codice "1" per iscritti residenti in Comune1 e Comune2 con data iscrizione <=20/4/14
    Codice "2" per iscritti residenti in tutti gli altri comuni con data iscrizione <=20/4/14
    Codice "3" per iscritti qualsiasi comune con data iscrizione >20/4/14

    =SE(B2="";"";SE(E(O(B2="Comune1";B2="Comune2");C2<=DATA.VALORE("20/4/14"));1;SE(E(O(B2<>"Comune1";B2<>"Comune2");C2<=DATA.VALORE("20/4/14"));2;3)))

    Excel 2007
    Row\Col
    A
    B
    C
    D
    1
    Nominativo Comune di residenza Data iscrizione Cod.
    2
    Luigi Comune1
    18/04/2014
    1
    3
    Mario Comune2
    20/04/2014
    1
    4
    Elena Comune3
    19/04/2014
    2
    5
    Giulia Comune4
    21/04/2014
    3
    6
    Anna Comune1
    21/04/2014
    3
    Sheet: Foglio1

    grazie
    Ultima modifica fatta da:Gerardo Zuccalà; 05/07/15 alle 08:31

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Gigi grazie per la domanda
    Prova questa formula in D2

    Codice: 
    =SE(A2="";"";SE(E(O(B2=$F$2;B2=$G$2);C2<=$H$2);1;SE(C2<=$H$2;2;3)))


    Gigi la tua formula non aveva bisogno della funzine DATA.VALORE perchè erano già dei numeri seriali, la funzione DATA.VALORE serve per trasformare un data scritta come testo in data numero seriale.
    Gigi in F2, G2 e H2 ho usato i criteri come riferimento esterno anzichè all'interno della formula in questo caso il vantaggio è che lapuoi cambiare i criteri





    A
    B
    C
    D
    E
    F
    G
    H
    1
    Nominativo Comune Data iscrizione Codice Criterio1 Criterio2 Criterio3
    2
    Luigi Comune1
    18/04/14
    1
    comune1 comune2
    20/04/2014
    3
    Mario Comune2
    20/04/14
    1
    4
    Elena Comune3
    19/04/14
    2
    5
    Giulia Comune4
    21/04/14
    3
    6
    Anna Comune1
    21/04/14
    3


    PS. Gigi la tua formula no so per quale motivo ma ha degli spazi vuoti, sicuramente è un problema del sofwear per cui ti suggerisco di metterla tra CODE cosi non si perdono i dati
    ciao e fammi sapere!

  3. #3
    L'avatar di Luigi Paravan
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Arquata Scrivia
    Età
    62
    Messaggi
    46
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    0
    Funziona benissimo grazie
    Ps Excel in pillole continuerà?

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da Luigi Paravan Visualizza Messaggio
    Funziona benissimo grazie
    Ps Excel in pillole continuerà?
    Ciao Luigi,
    mi fa piacere che la mia formula funziona, non'era cosi semplice
    comunque per quanto riguarda i video Excel in Pillole e Excel Magico spero di riuscire a continuare
    il mio sogno è di farne almeno un centinaio ma il tempo è proprio risicato
    Ciao Continua cosi

    PS. Hai mai pensato di mettere un foto nel tuo Box dell'avatar?
    ed è semplicissimo però devi sapere che ci sono 2 impostazioni diverse, la prima riguarda la foto che compare sul tuo profilo personale, e la seconda riguarda la foto dell’avatar cioè quella che compare alla sinistra del box di ogni post
    Comunque procedi in questo modo in alto a destra clicca su Impostazioni (in inglese settings) adesso sulla sinistra vedrai “Le Mie Impostazioni” (in inglese My settings), a quel punto puoi mettere una foto del profilo, una foto dell’avatar, e puoi mettere anche una firma o comunque modificare tutto quello che ritieni opportuno…

Discussioni Simili

  1. Assegnare un testo in base a determinato valore
    Di Nic1907 nel forum Domande su Excel in generale
    Risposte: 15
    Ultimo Messaggio: 18/02/17, 17:15
  2. [Risolto] estraendo da un data base la data non viene riconosciuta
    Di vitangelo nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 11/02/17, 17:46
  3. Eseguire codice in base all'utente che apre il file
    Di Giuspy82 nel forum Domande su Excel VBA e MACRO
    Risposte: 3
    Ultimo Messaggio: 07/09/16, 12:28
  4. Assegnare nome a file PDF in base al contenuto di una cella
    Di FRADES nel forum Domande su Excel VBA e MACRO
    Risposte: 21
    Ultimo Messaggio: 11/07/16, 01:08
  5. Risposte: 15
    Ultimo Messaggio: 14/05/16, 22:11

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •