Risultati da 1 a 12 di 12

Discussione: Formattazione Condizionale Testo



  1. #1
    L'avatar di Andix87
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Solaro
    Messaggi
    6
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Formattazione Condizionale Testo

    Ciao a tutti,

    Vi sottopongo questo quesito, sperando ci sia la possibilità di mettere in atto in Excel quanto richiesto.

    Foglio 1: Clienti ---> Colonna A: Nomi. Ogni giorno se ne aggiungono di nuovi.
    Foglio 2: Blacklist ---> Colonna A: Nomi. Ogni giorno se ne aggiungono o tolgono alcuni.

    Voglio applicare una formattazione condizionale di modo che:
    - Ogni volta che si Aggiunge un Nome nella Colonna A del foglio "Clienti" già presente nel foglio "Blacklist", la cella sul foglio "Clienti" appaia con riempimento rosso e scritta rossa.

    Premetto che i nomi del Foglio "Blacklist" sono un centinaio e possono diminuire o crescere ogni giorno e che quelli del foglio "Clienti" sono oltre 3000 ed in continua crescita.

    Sostanzialmente volevo effettuare una formattazione condizionale di una intera colonna Excel (testo) sulla base di Valori presenti in un'altra colonna o tabella (testo).

    Vi ringrazio in anticipo e un saluto a tutti! :23:
    Ultima modifica fatta da:Canapone; 30/06/17 alle 15:34

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7115
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1296
    Selezioni l'intera colonna A1 del foglio Clienti e come formattazione condizionale scrivi questa formula:

    =CONTA.SE(Blacklist!$A:$A;Clienti!$A1)>0

    e imposti il colore.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di Andix87
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Solaro
    Messaggi
    6
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Intanto ti ringrazio tantissimo per la risposta.

    Ho fatto come mi hai detto, seleziono la colonna de foglio Clienti, vado su formattazione condizionale-->Nuova Regola-->Formatta solo celle che contengono-->Testo Specifico-->Contiene e metto la tua formula ma non mi evidenzia in rosso le celle della Colonna A del foglio Clienti....sbaglio qualcosa?

    Grazie ancora!
    Ultima modifica fatta da:Canapone; 30/06/17 alle 15:34

  4. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Ciao a tutti,

    @Andix87
    allega il file che stai usando altrimenti non è semplice capire cosa sbagli.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  5. #5

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2807
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    978
    Citazione Originariamente Scritto da Andix87 Visualizza Messaggio
    Ho fatto come mi hai detto, seleziono la colonna de foglio Clienti, vado su formattazione condizionale-->Nuova Regola-->
    non
    Formatta solo celle che contengono-->
    ma
    Utilizza una formula per determinare le celle da formattare--> e incolli la formula

    P.S. Ricorda di cambiare il formato desiderato

  6. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7115
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1296
    Come dice giustamente Rubik, che saluto, non vedi inserire la formula in formattazione condizionale-->Nuova Regola--> ma in Utilizza una formula per determinare le celle da formattare-->
    Allego file

    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  7. #7
    L'avatar di Andix87
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Solaro
    Messaggi
    6
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Vi ringrazio moltissimo tutti quanti, ora funziona tutto perfettamente ;)

    Grazie ancora e a presto! :274:

  8. #8
    L'avatar di Andix87
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Solaro
    Messaggi
    6
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Eccomi di nuovo, ho un piccolo problema, nel foglio "Clienti". Essi infatti possono essere ripetuti più volte. Di conseguenza la prima volta che la funzione li trova, mi applica la formattazione condizionale, la seconda volta non più! C'è un modo per sistemare questa cosa?

    Vi ringrazio in anticipo e se volete altre info chiedete pure! Grazie mille!

  9. #9
    L'avatar di Andix87
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Solaro
    Messaggi
    6
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    In realtà mi formatta quasi tutti i nomi, anche se ripetuti più volte, il problema è che alcuni non me li formatta proprio e altri, da una riga in poi, decide di non formattarli più...
    Se qualcuno sa aiutarmi gliene sarei molto grato.

    Grazie ancora!
    Ultima modifica fatta da:Canapone; 30/06/17 alle 15:34

  10. #10

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Ciao,
    dovresti allegare il tuo file (quello dove riscontri i problemi) perchè prendendo come esempio il file allegato da "ges" (un saluto), non sembra esserci alcun errore.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  11. #11
    L'avatar di Andix87
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Solaro
    Messaggi
    6
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Non posso allegare il file per motivi di Privacy...vi allego un esempio:



    Filtrando per cognome mi succede questa cosa...la formula che uso è: =CONTA.SE(Blacklist!$A:$A;$D1)>0

    Grazie!
    Ultima modifica fatta da:Canapone; 30/06/17 alle 15:35

  12. #12

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Citazione Originariamente Scritto da Andix87 Visualizza Messaggio
    Non posso allegare il file per motivi di Privacy...vi allego un esempio:



    Filtrando per cognome mi succede questa cosa...la formula che uso è: =CONTA.SE(Blacklist!$A:$A;$D1)>0

    Grazie!
    Non devi allegare il file originale ma uno con la stessa struttura e dati fittizi per capire dove sia l'errore.
    Vedendo l'immagine posso solo pensare che la formattazione condizionale non è applicata a tutta la colonna D (o comunque fino alla cella D10).

    Senza file si possono fare solo supposizioni.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

Discussioni Simili

  1. [Risolto] Formattazione condizionale per cambiare colore testo
    Di sowhatt nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 07/03/17, 00:11
  2. [Risolto] Formattazione condizionale singole parole secondo un criterio in una stringa di testo
    Di Nando79 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 09/01/17, 19:37
  3. [Risolto] Formattazione condizionale su numero+testo
    Di parcot nel forum Domande su Excel in generale
    Risposte: 22
    Ultimo Messaggio: 27/10/16, 13:52
  4. Formattazione condizionale con aggiunta di testo?!?
    Di corfurio nel forum Domande su Excel VBA e MACRO
    Risposte: 6
    Ultimo Messaggio: 07/10/16, 20:19
  5. [Risolto] formattazione condizionale
    Di FB17 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 03/03/16, 22:47

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •