Risultati da 1 a 16 di 16

Discussione: problema con formula



  1. #1
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1

    problema con formula

    ho un problema con questa formula
    =SOMMA.PIÙ.SE(PREZZO_ORI;DATA_RESO;">="&$B$2;DATA_RESO;"<="&$B$3;COD_CAT;$A35)
    la colonna DATA_RESO la legge come testo, senza dover intervenire sul database come si puo' risolvere? b2 e b3 sono formato data

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao Stefano se sicuro che B2 e B3 sono dei numeri seriali?
    perchè non metti un piccolo allegato cosi ci si lavora direttamente, quando rispondi clicca su modalità avanzata e inserisci un allegato!
    ciao aspetto

  3. #3
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao Stefano,

    faccio un tentativo


    Codice: 
    =MATR.SOMMA.PRODOTTO(PREZZO_ORI;(DATA_RESO+0>=$G$1)*(DATA_RESO+0<=$G$2)*(COD_CAT=$F$10))

  5. #5
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao Stefano,

    formula equivalente

    =SOMMA(INDICE(PREZZO_ORI*(DATA_RESO+0>=$G$1)*(DATA_RESO+0<=$G$2)*(COD_CAT=$F$10) ; ))

    Leva gli spazi dalla formula: mi comparivano le faccine con ; )

    Spero sia d'aiuto
    Ultima modifica fatta da:Canapone; 02/06/15 alle 12:47

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    =MATR.SOMMA.PRODOTTO(--(DATA_RESO+0>=G1);--(DATA_RESO+0<=G2);--(COD_CAT=F10);PREZZO_ORI)

    prova questa

  7. #7
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    ecco, proprio quello che ci voleva, grazie mille
    una curiosità come mai importa la data in formato testo? ho 5 colonne importate come data e solo questa non la prende come data, il file è un "dbf"

  8. #8
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    intendevo questa
    =MATR.SOMMA.PRODOTTO(PREZZO_ORI;(DATA_RESO+0>=$G$1)*(DATA_RESO+0<=$G$2)*(COD_CAT=$F$10))
    Ultima modifica fatta da:Stefano; 02/06/15 alle 12:56

  9. #9
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    non saprei risponderti: dipende come vengono scaricati i dati. Mi succede spesso con As400, il +0 rimette le cose a posto.

  10. #10
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    Ho provato anche la tua Gerardo e non mi crederai ma funziona anche la tua :eek: scherzo naturalmente, non avevo dubbi, ci ho perso una sera, avevo capito il problema ma non riuscivo a risolverlo, grazie, sulle tabelle pivot però sono piu' preparato

  11. #11
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao Stefano probabilmente, è una cosa normalissima ogni qualvolta che si scarica qualcosa da internet o da un database è in formato .csv o .txt percui dovrai essere a sistemare il data se, conque avresti potuto creare una colonna aggiuntiva e trasformare la cella in formato testo in numero seriale es. A1+0 ( il +0 significa che trasformi un testo in numero) e copi in basso a quel punto potevi usare la tua formula con il SOMMA.PIÙ.SE(PREZZO_ORI;DATA_RESO;">="&$B$2;DATA_RESO;"<="&$B$3;COD_CAT;$A35) perchè lavora direttamente su degli intervalli e non su delle matrici
    ciao Stefano

  12. #12
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    infatti avevo fatto così, però sapevo che si poteva fare senza aggiungere una colonna

  13. #13
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Stefano, sto settando il forum mi puoi dire se hai ricevuto le notifiche per email di questa discussione, perchè ho problemi con le notifiche
    grazie

  14. #14
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    non ho ricevuto nulla

  15. #15
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    immaginavo, grazie!

  16. #16
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao Canapone, ho risolto il problema delle faccine adesso quando farai ;) :) ;( come puoi notare non ti da più la faccina.
    praticamente sono andato nelle impostazioni del forum ed ho assegnato ad ogni faccina dei caratteri diversi...
    Ciao
    Ultima modifica fatta da:Canapone; 01/07/17 alle 17:50

Discussioni Simili

  1. problema con formula SOMMA PIU' SE
    Di danfil nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 06/01/17, 17:35
  2. Problema formula
    Di ama1990 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 16/12/16, 22:34
  3. [Risolto] problema formula percentuale
    Di -ADG- nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 07/07/16, 18:45
  4. Problema con formula matriciale
    Di Raffaele_53 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 01/07/16, 17:58
  5. Formula excel problema
    Di ale87 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 16/06/16, 16:06

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •