Risultati da 1 a 10 di 10

Discussione: estrarre dati



  1. #1
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    estrarre dati

    Ciao di nuovo a tutti gli amici del forum

    Ho una formula con la funzione aggrega che mi lavora bene solo nella prima riga ovvero:

    inserisco nella cella G22 la squadra nella cella H22 la data e estrae correttamente categoria e orario

    trascino la formula in basso e non funziona bene, non capisco dove sbaglio

    Grazie in anticipo
    File Allegati File Allegati
    windows 10
    Excel 2016

  2. #2
    L'avatar di TuttoExcel
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Milano
    Età
    43
    Messaggi
    82
    Versione Office
    Excel 2013
    Likes ricevuti
    19
    Likes dati
    3
    Ciao, devi bloccare anche l'ultima cella della formula

    Codice: 
    =SE.ERRORE(INDICE($E$22:$E$30;AGGREGA(15;6;(RIF.RIGA($E$22:$E$30)-RIF.RIGA($E$22)+1)/(($D$22:$D$30=H22)*($C$22:$C$30=G22));RIGHE(I$22:I$22)));"")
    Vedrai che funziona :-)
    Condividi la tua conoscenza. E’ un modo per raggiungere l’immortalità. (Dalai Lama)
    Amministratore di www.tuttoexcel.it

  3. #3
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15
    Grazie......... sono un popone era una mattinata che non ne venivo a capo

    Grazie :28:

    N.B.
    si poteva fare anche con Matr.somma.prodotto, forse veniva una formula piu snella
    sai come posso fare in alternativa a questa???
    windows 10
    Excel 2016

  4. #4
    L'avatar di TuttoExcel
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Milano
    Età
    43
    Messaggi
    82
    Versione Office
    Excel 2013
    Likes ricevuti
    19
    Likes dati
    3
    Ciao, non è che cambi molto, anzi, diventa anche più complessa a parer mio. Comunque le 2 formule da usare sono:

    Codice: 
    =INDICE($A$22:$E$30;MATR.SOMMA.PRODOTTO(($C$22:$C$30=$G22)*($D$22:$D$30=$H22)*RIF.RIGA($A$22:$A$30))-21;1)
    e

    Codice: 
    =INDICE($A$22:$E$30;MATR.SOMMA.PRODOTTO(($C$22:$C$30=$G22)*($D$22:$D$30=$H22)*RIF.RIGA($A$22:$A$30))-21;5)
    Il -21 va cambiato a seconda della riga da cui parti (ovvero dalla riga che contiene il titolo della tabella)

    e non ho incluso il SE.ERRORE
    Condividi la tua conoscenza. E’ un modo per raggiungere l’immortalità. (Dalai Lama)
    Amministratore di www.tuttoexcel.it

  5. #5
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15
    Grazie Ancora....
    per aiuto
    windows 10
    Excel 2016

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao a tutti e ben ritrovati,


    Anche se la discussione è già stata segnata come RISOLTA, vorrei mettere una formula alternativa, perchè si sa con excel non c'è mai una sola soluzione.

    Ovviamente posso usare questa soluzione perchè sono sicuro che non ci sono duplicati (Avversario e data) epoi perchè ho letto che Nick voleva qualcosa di snello
    ho usato la tanto odiata e amata funzione CERCA

    in I22 copia e trascina in basso

    =SE.ERRORE(CERCA(2;1/($D$22:$D$30=$H22)*($C$22:$C$30=$G22);$A$22:$A$30);"")

    in J22 copia e incolla in basso

    =SE.ERRORE(CERCA(2;1/($D$22:$D$30=$H22)*($C$22:$C$30=$G22);$E$22:$E$30);"")

    sono sicuro che ci sono altre soluzioni
    @Nick come al solito fai sapere se va bene
    grazie
    Ciao

  7. #7
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15
    ciao Gerardo grazie per un ulteriore suggerimento

    però questa alternativa non funziona correttamente propio per i duplicati perche
    invece e possibile trovare ti riallego il file con le tre formule in azione

    Grazie ancora
    File Allegati File Allegati
    windows 10
    Excel 2016

  8. #8
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Opppss! mancava una parentesi che non mi chiudeva il vettore

    prova cosi:

    =SE.ERRORE(CERCA(2;1/(($D$22:$D$30=$H22)*($C$22:$C$30=$G22));$A$22:$A$30);"")

  9. #9
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15
    Come al solito Gerardo alla grande

    Mille grazie ora funziona bene..............
    windows 10
    Excel 2016

  10. #10
    L'avatar di TuttoExcel
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Milano
    Età
    43
    Messaggi
    82
    Versione Office
    Excel 2013
    Likes ricevuti
    19
    Likes dati
    3
    Bella Gerardo, la trovo meno "leggibile" ma bella, io preferisco utilizzare formule che siano un po' più facile da comprendere :269:

    Ma come dicevi tu Excel è bello proprio perché ci sono molti modi per arrivare al medesimo risultato ehehe
    Condividi la tua conoscenza. E’ un modo per raggiungere l’immortalità. (Dalai Lama)
    Amministratore di www.tuttoexcel.it

Discussioni Simili

  1. estrarre dati con più condizioni
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 13/04/16, 15:01
  2. Come Estrarre dei Dati
    Di Andrea Mollo nel forum Domande su Excel in generale
    Risposte: 17
    Ultimo Messaggio: 06/01/16, 14:25
  3. Estrarre dati
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 26
    Ultimo Messaggio: 20/06/15, 08:06
  4. [Risolto] estrarre dati
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 18/06/15, 08:38
  5. estrarre dati
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 18/06/15, 02:08

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •