Risultati da 1 a 7 di 7

Discussione: Unire formula SE con E



  1. #1
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2266
    Versione Office
    Excel 2010
    Likes ricevuti
    903
    Likes dati
    450

    Unire formula SE con E

    Buonasera a tutti
    vorrei un vostro aiuto per unificare due formule che non riesco a mettere insieme.
    Codice: 
    =SE(C8="MAR";"";"OK")
    Codice: 
    =SE(SE(VAL.ERRORE(SINISTRA(C2;1)+0);"lettere";"numeri")="numeri";"";"OK")
    In pratica se il valore di C2 inizia con numero E C8 =MAR lascia in bianco.
    Allego il file per prova.
    Grazie
    File Allegati File Allegati

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Citazione Originariamente Scritto da Berna11 Visualizza Messaggio
    ...
    In pratica se il valore di C2 inizia con numero E C8 =MAR lascia in bianco.
    ....
    .
    [EDIT]
    Ma la formula l'hai scritta tu

    =SE(SE(VAL.ERRORE(SINISTRA(C2;1)+0);"lettere";"numeri")="numeri";"";"OK")

    Forse non ho capito cosa chiedi....:256:
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. I seguenti utenti hanno dato un "Like"


  4. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Forse ora ci sono arrivato, guardavo solo l'allegato e non le istruzioni che avevi messo sopra, puoi usare questa formula per unificare le due sopra:

    =SE(E(C8="MAR";VAL.NUMERO(SINISTRA(C2;1)+0)=VERO);"";"OK")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. I seguenti utenti hanno dato un "Like"


  6. #4
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2266
    Versione Office
    Excel 2010
    Likes ricevuti
    903
    Likes dati
    450
    Ciao ges grazie per la risposta ma, ancora qualcosa non funziona correttamente.
    Esempio:
    C2 inizia con lettera C8=MAR va bene
    C2 inizia con numero C8=22 deve restare vuota invece da OK
    C2 inizio con numero C8=MAR deve stare vuota e qui credo nasce altro problema.
    Nel file allegato rimane vuota nel file originale no da OK.
    Forse è dovuto al fatto che nel file allegato ho messo un menu a tendina per ottenere i due valori mentre nel file originale il risultato esce fuori da una formula di cerca vert.

  7. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Citazione Originariamente Scritto da Berna11 Visualizza Messaggio
    ....
    C2 inizia con numero C8=22 deve restare vuota invece da OK
    .....
    Ma questa è una cosa diversa da quanto avevi chiesto prima

    Citazione Originariamente Scritto da Berna11 Visualizza Messaggio
    ....
    In pratica se il valore di C2 inizia con numero E C8 =MAR lascia in bianco.
    ...
    .
    Bisogna capirsi bene su quali devono essere le condizioni:

    Se sono SOLO queste due:

    1) C2 inizia con numero E C8 =MAR ---- > vuota
    2) C2 inizia con numero E C8=22 ----> vuota

    la formula diventa così:

    =SE(E(VAL.NUMERO(SINISTRA(C2;1)+0)=VERO;O(C8="MAR";C8=22));"";"OK")

    Se invece ci sono altre condizioni ovviamente questa formula non funzionerà.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  8. #6
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2266
    Versione Office
    Excel 2010
    Likes ricevuti
    903
    Likes dati
    450
    Ciao ges con il tuo spunto credo di aver risolto in questo modo:

    Codice: 
    =SE(E(C8<>"MAR";SE(VAL.ERRORE(SINISTRA(C2;1)+0);"lettere";"numeri")="lettere");"OK'";SE(E(C8="MAR";SE(VAL.ERRORE(SINISTRA(C2;1)+0);"lettere";"numeri")="lettere");"OK'";""))
    Grazie ancora alla prossima.

  9. #7

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Bene!
    L'importante è che ci sei riuscito :28:
    Se hai risolto segna questa discussione come [RISOLTO] nel menu in alto alla stessa.
    Alla prossima.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  10. I seguenti utenti hanno dato un "Like"


Discussioni Simili

  1. [Risolto] unire le celle in automatico
    Di givi79 nel forum Domande su Excel in generale
    Risposte: 26
    Ultimo Messaggio: 19/01/17, 00:43
  2. unire con la formattazione
    Di givi79 nel forum Domande su Excel in generale
    Risposte: 21
    Ultimo Messaggio: 18/01/17, 22:23
  3. [Risolto] Unire dati da più celle
    Di sergiogranero nel forum Domande su Microsoft Access
    Risposte: 1
    Ultimo Messaggio: 30/09/16, 07:36
  4. [Risolto] unire 4 tabelle
    Di epaminonda27 nel forum Domande su Microsoft Access
    Risposte: 10
    Ultimo Messaggio: 21/08/16, 13:15
  5. Unire fogli di lavoro
    Di andrea.t nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 15/06/16, 14:57

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •