Risultati da 1 a 9 di 9

Discussione: Orario



  1. #1
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    45
    Messaggi
    1171
    Versione Office
    Excel 2010
    Likes ricevuti
    511
    Likes dati
    572

    Orario

    Buonasera a tutti nel file che allego con cui calcolo delle ore di lavoro nella colonna I uso una formula con SE mentre nella colonna K uso una formula con RESTO ora il risultato della differenza ore corrisponde con entrambe le formule......però quando faccio il totale quella con SE mi da un risultato sbagliato..nell'esempio (104,50 ore) mentre quella con funzione resto il risultato della somma è corretto (80,50) entrambe le celle della somma delle ore sono formattate [h]:mm....la domanda solo per cultura personale è : perché c'è questa differenza nel risultato???.....grazie Danilo
    File Allegati File Allegati

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Ciao Danilo
    La formula con il SE è sbagliata, infatti se dai il formato generale vedrai che una formula avrà 1, (uno virgola) mentre tutti i numeri dovrebbero essere 0, (zero virgola) perchè 1 (uno) vale 24 ore
    ti consiglio di usare la funzione con RESTO ma attenzione però io la cambierei anche quella

    Cosi:
    =SOMMA(RESTO(H4-G4;1);RESTO(F4-E4;1))

    fammi sapere!

  3. #3
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    45
    Messaggi
    1171
    Versione Office
    Excel 2010
    Likes ricevuti
    511
    Likes dati
    572
    ciao Gerardo in M ho messo la tua formula e funziona correttamente come le altre due i risultati delle ore coincidono in tutti e tre i casi......ma la somma totale coincide soltanto nelle formule con RESTO.....motivo????

  4. #4
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    45
    Messaggi
    1171
    Versione Office
    Excel 2010
    Likes ricevuti
    511
    Likes dati
    572
    rimetto il file.......
    P.S. complimenti per i tutorial.......Danilo
    File Allegati File Allegati

  5. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da Danilo Fiorini Visualizza Messaggio
    ciao Gerardo in M ho messo la tua formula e funziona correttamente come le altre due i risultati delle ore coincidono in tutti e tre i casi......ma la somma totale coincide soltanto nelle formule con RESTO.....motivo????
    perchè come ti ho scritto sopra le tue formule con il SE sfondano le 24 ore infatti nella cella I13 il risultato e di 30 ore e 34 minuti anzichè 4 ore e 34 minuti
    prova a dare il fomato generale e noterai che cella I13 ha davanti 1,.....anzichè 0, e quell'uno (1) vale 24ore che tu non vedevi ma excel lo calcolava




  6. #6
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    45
    Messaggi
    1171
    Versione Office
    Excel 2010
    Likes ricevuti
    511
    Likes dati
    572
    vero.....e credo di avere capito la formula con se torna valida se l out è precedente alla mezzanotte la devo mettere nelle prime due celle cosi torna anche la somma totale....grazie a presto
    File Allegati File Allegati

  7. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Se vuoi usare il SE (da me sconsigliato) potresti fare una formula cosi:
    metti questa formula in I4 e trascinala in basso

    =SOMMA(SE(F4<E4;F4+1;F4)-E4;SE(H4<G4;H4+1;H4)-G4)

    fammi sapere!

  8. #8
    L'avatar di D@nilo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Età
    45
    Messaggi
    1171
    Versione Office
    Excel 2010
    Likes ricevuti
    511
    Likes dati
    572
    no assolutamente prima usavo questo tipo di formula per calcolare orari poi ho visto i tuoi video sul calcolo ore e ho cominciato a usare la funzione resto...

  9. #9
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da Danilo Fiorini Visualizza Messaggio
    no assolutamente prima usavo questo tipo di formula per calcolare orari poi ho visto i tuoi video sul calcolo ore e ho cominciato a usare la funzione resto...
    ok perfetto meglio cosi oltretutto con la funzione RESTO hai una formula molto più corta...
    Ho visto che hai messo RISOLTO e quindi ti aspettimao la tua prossima domanda

    Ciao

Discussioni Simili

  1. Orario scritto in numero ma con formato orario e relativa somma
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 17
    Ultimo Messaggio: 27/02/17, 13:08
  2. [Risolto] Suddivisione orario
    Di KIKKA nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 15/02/17, 14:10
  3. Orario
    Di sebgi nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 18/01/17, 00:16
  4. divisione di 24h tra orario normale e fuori orario
    Di sebyspadaro nel forum Domande su Excel VBA e MACRO
    Risposte: 20
    Ultimo Messaggio: 25/05/16, 15:05
  5. Orario dei post
    Di maxhrc nel forum Problemi, suggerimenti e Novità del forum
    Risposte: 2
    Ultimo Messaggio: 04/05/16, 21:31

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •