Risultati da 1 a 9 di 9

Discussione: matrice somma prodotto che esclude le celle uguali



  1. #1
    L'avatar di ALESSANDRADS
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    roseto degli abruzzi
    Età
    35
    Messaggi
    4
    Versione Office
    excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    matrice somma prodotto che esclude le celle uguali

    Salve a tutti,

    sono Alessandra e sono nuovissima ed inesperta nei forum, quindi spero mi perdoniate se commetto errori.
    Vi presento il mio problema:
    Sulla colonna frequenza io ho inserito nel mio file una formula MATR.SOMMA.PRODOTTO che mi calcolo la frequenza d'arrivo dei lotti con stesso fornitore e stesso nome "MATERIALE", quindi nel caso specifico io ottengo 3 come frequenza.
    Ciò di cui ho bisogno è una formula che mi escludesse dal calcolo i lotti che si ripetono più volte, quindi vorrei che la risultante della mia formula sia:
    2
    1
    2

    FREQUENZA MATERIALE LOTTO FORNITORE
    A 1 B
    A 2 B
    A 1 B

    Spero di essere stata abbastanza chiara.
    E grazie in anticipo a tutti coloro che proveranno a darmi una mano
    Buona serata

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Ciao Alessandra,
    potresti allegare un file d'esempio con più casistiche in modo da capire bene cosa vorresti ottenere?

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Se ho ben capito:

    =MATR.SOMMA.PRODOTTO(($B$2:$B$4="A")*($D$2:$D$4="B")*($C$2:$C$4=C2))
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4
    L'avatar di ALESSANDRADS
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    roseto degli abruzzi
    Età
    35
    Messaggi
    4
    Versione Office
    excel 2007
    Likes ricevuti
    0
    Likes dati
    0
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Se ho ben capito:

    =MATR.SOMMA.PRODOTTO(($B$2:$B$4="A")*($D$2:$D$4="B")*($C$2:$C$4=C2))
    Grazie a Ges e a Cromagno per la celere risposta, ma forse ho semplificato troppo. Vi allego un file tipo.

    Per tutte e tre le colonne posso avere un numero X di voci, io vorrei che mi contasse quante volte la stessa materia prima con lo stesso fornitore con lo stesso lotto si ripete, senza però contarmi i casi in cui lo stesso lotto si ripeta due volte.
    Spero di essere stata più chiara stavolta.

    Grazie ancora
    File Allegati File Allegati

  5. #5

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Ciao a tutti,

    sempre se ho capito bene....prova a mettere questa formula nella cella A3 del tuo file e dopo copiala in basso:

    =MATR.SOMMA.PRODOTTO(($C$3:$C$15=C3)*($E$3:$E$15=E3))-(MATR.SOMMA.PRODOTTO(($C$3:$C$15=C3)*($E$3:$E$15=E3)*($D$3:$D$15=D3))-1)

    ti riallego il file...

    se è quello che volevi si può cercare di accorciarla (fai un bel pò di prove prima).
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  6. #6
    L'avatar di ALESSANDRADS
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    roseto degli abruzzi
    Età
    35
    Messaggi
    4
    Versione Office
    excel 2007
    Likes ricevuti
    0
    Likes dati
    0
    Citazione Originariamente Scritto da cromagno Visualizza Messaggio
    Ciao a tutti,

    sempre se ho capito bene....prova a mettere questa formula nella cella A3 del tuo file e dopo copiala in basso:

    =MATR.SOMMA.PRODOTTO(($C$3:$C$15=C3)*($E$3:$E$15=E3))-(MATR.SOMMA.PRODOTTO(($C$3:$C$15=C3)*($E$3:$E$15=E3)*($D$3:$D$15=D3))-1)

    ti riallego il file...

    se è quello che volevi si può cercare di accorciarla (fai un bel pò di prove prima).
    Grazie infinite Cromagno!!!!

    Funziona correttamente!
    Buona giornata a tutti
    PS. certo proverò a renderla più fluida!!!!

  7. #7

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Per evidenziare le doppie uguali:

    =SE(MATR.SOMMA.PRODOTTO(($C$3:$C$15&$E$3:$E$15=C3&E3)*1)>1;1;"")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  8. #8
    L'avatar di ALESSANDRADS
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    roseto degli abruzzi
    Età
    35
    Messaggi
    4
    Versione Office
    excel 2007
    Likes ricevuti
    0
    Likes dati
    0
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Per evidenziare le doppie uguali:

    =SE(MATR.SOMMA.PRODOTTO(($C$3:$C$15&$E$3:$E$15=C3&E3)*1)>1;1;"")

    Graize Ges, anche questa formula mi sarà utilissima!!
    Bye

  9. #9

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Ciao a tutti,

    @Alessandra
    Se hai risolto il problema, segna questa discussione come "RISOLTO".
    Vai sul menù "Strumenti Discussione" (all'inizio del thread) e scegli la voce ""Segna questo thread come risolto...".

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

Discussioni Simili

  1. [Risolto] Ottenere il primo valore "vero" di una matrice somma prodotto
    Di Maurantz nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 08/02/17, 23:51
  2. Matr. Somma Prodotto - Stessa matrice per matrici diverse
    Di danyk125 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 18/07/16, 01:01
  3. Matrice somma prodotto
    Di Lucagiuseppe nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 18/04/16, 19:10
  4. =matr.somma.prodotto()
    Di marigenny nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 11/11/15, 12:59
  5. matr.somma.prodotto
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 19/10/15, 17:52

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •