Risultati da 1 a 10 di 10

Discussione: Tabella ore Presenze



  1. #1
    L'avatar di antosime
    Clicca e Apri
    Data Registrazione
    Mar 2016
    LocalitÓ
    VICENZA
    EtÓ
    45
    Messaggi
    5
    Versione Office
    EXCEL 2010
    Likes ricevuti
    0
    Likes dati
    0

    Lightbulb Tabella ore Presenze

    Ciao a tutti,
    premetto subito che sono un autodidatta, le mie nozione su Excel le ho grazie ai video di Gerardo (che sono strepitosi), e qualche altra chicca trovata su internet.
    Premesso questo, ho preparato un foglio dove memorizzo le ore lavorative.
    Il Problema sorge quando in una giornata lavorativa di 8 ore devo calcolare per esempio 2 ore lavorato, 2 di rol, 4 di cassa integrazione, oppure 2 lavorato e 6 di cassa integrazione.
    Potete dirmi come posso fare? allego file in questione.
    Grazie a tutti in anticipo.
    File Allegati File Allegati
    Ultima modifica fatta da:Canapone; 06/02/17 alle 15:10

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Como
    EtÓ
    53
    Messaggi
    7165
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1304
    Ciao,
    intanto ti suggerirei di cambiare quel lungo codice assegnato dal registratore di macro con questo che fa la stessa cosa:

    Codice: 
    Sub RESET_SCHEDE()
      With ThisWorkbook.Worksheets
        Range("C6:H36") = ""
      End With
        Range("Q4").Select
    End Sub
    Mi dici meglio in quale cella va fatto quel calcolo che chiedi, forse nella colonna I "Lavorate"?
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se pu˛ sembrare improbabile, non pu˛ che essere quella giusta!

  3. #3
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    1687
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185
    Ciao a tutti
    non sono certo di aver capito ma se tu vuoi poter dividere l'orario di lavoro in pi¨ tipi, secondo me dovresti impostare diversamente il database.
    Come campi potresti usare :
    data
    tipo (scegli fra le varie tipologie)
    ora inizio
    ora fine
    durata (calcolo di ora fine-ora inizio)

    da questi dati, in vario modo (pivot, formule, vba) puoi estrarre tutti i vari report e calcoli vari.

    addirittura potresti usare un solo foglio e poi crearti dei report mensili.
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed Ŕ un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  4. #4
    L'avatar di antosime
    Clicca e Apri
    Data Registrazione
    Mar 2016
    LocalitÓ
    VICENZA
    EtÓ
    45
    Messaggi
    5
    Versione Office
    EXCEL 2010
    Likes ricevuti
    0
    Likes dati
    0
    Ciao ges,
    grazie per l'aiuto, devo gestire le 8 ore nella casella lavorato, cig, erol ,per dire.
    Esempio: una giornta tipo di 8 ore, lavoro 2 ore, 2 sono rol e 4 sono cig, quindi le colonne, quindi le colonne "LAVORATO", "CIG", "ROL" devono darmi 2, 4, 2.
    Non so se sono riuscito a spiegarmi bene.
    Grazie ancora.

  5. #5
    L'avatar di antosime
    Clicca e Apri
    Data Registrazione
    Mar 2016
    LocalitÓ
    VICENZA
    EtÓ
    45
    Messaggi
    5
    Versione Office
    EXCEL 2010
    Likes ricevuti
    0
    Likes dati
    0
    ciao ninai,
    grazie anche a te per l'aiuto, e per il consiglio, il discorso mi viene complicato quando in una giornata di lavoro devo gestire tre tipologie, tipo, lavorato, cig , rol per dire.

  6. #6
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao antosine benvenuto in forumexcel.it,
    Per essere pi¨ esaustivo possibile prova a pubblicare un file (poche righe e poche colonne) con il risultato scritto a mano (senza le tue formule), con tutte le casistiche possibili, scrivi in che cella vuoi il risultato e una piccola descrizione del problema, perchÚ io mi sono perso tra i fogli
    Grazie

  7. #7
    L'avatar di antosime
    Clicca e Apri
    Data Registrazione
    Mar 2016
    LocalitÓ
    VICENZA
    EtÓ
    45
    Messaggi
    5
    Versione Office
    EXCEL 2010
    Likes ricevuti
    0
    Likes dati
    0
    Ciao Gerardo,
    Grazie per l'aiuto e scusa per la confusione, dentro l'allegato spero di spiegare tutto in maniera semplice.
    Grazie ancora per avermi accettato in questo Forum.
    File Allegati File Allegati

  8. #8
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Rieccoci...
    Antosime adesso che Ŕ tutto pi¨ chiaro ti posso dire che qui il problema non sono le formule, ma di come hai strutturato la tabella, perchŔ nella tua tabella hai dato la possibilitÓ di inserire solo due casistiche Giornata1 ed Giornata2, per˛ le casistiche in un giorno potrebbero essere anche pi¨ di due magari 3 magari 4 (quest'ultima molto rara)

    esempio mattina lavora 8:30/12:30 pomeriggio ROL 13:30/14:30 e poi ancora CIG 14:30/17:30
    come puoi notare ci sono 3 "entrate" e tre "uscite"

    per cui alla tua tabella dovresti inserire almeno 3 colone ancora (giornata3, Entrata3, uscita3



    Tutto questo perchŔ excel ha bisogno di capire attraverso un Criterio di cosa si tratta, altrimenti come farebbe a sapere se sono ROL se c'Ŕ scritto CIG, o meglio come farebbe ad estrapolare "ROL" all'interno della fascia di CIG se non c'Ŕ scritto Rol ma CIG?

    le formule sono abbastanza semplici (con questa struttura)

    LAVORATO:
    =SOMMA(SE(B2="L";D2-C2;0);SE(E2="L";G2-F2;0);SE(H2="L";J2-I2;0))

    CIG:
    =SOMMA(SE(B2="C";D2-C2;0);SE(E2="C";G2-F2;0);SE(H2="C";J2-I2;0))

    ORE IN PIU:
    =SE(K2>8/24;K2-8/24;0)

    ROL
    =SOMMA(SE(B2="r";D2-C2;0);SE(E2="R";G2-F2;0);SE(H2="R";J2-I2;0))

    FERIE
    =SOMMA(SE(B2="F";D2-C2;0);SE(E2="F";G2-F2;0);SE(H2="F";J2-I2;0))

    MALATTIA
    =SOMMA(SE(B2="M";D2-C2;0);SE(E2="M";G2-F2;0);SE(H2="M";J2-I2;0))

    FESTIVO
    =SOMMA(SE(B2="Fs";D2-C2;0);SE(E2="Fs";G2-F2;0);SE(H2="Fs";J2-I2;0))

    PS ci sono orari notturni a cavallo della mezzanotte? altrimenti bisogna cambiare le formule...
    File Allegati File Allegati
    Ultima modifica fatta da:Gerardo ZuccalÓ; 18/03/16 alle 11:37 Motivo: ortografico

  9. #9
    L'avatar di antosime
    Clicca e Apri
    Data Registrazione
    Mar 2016
    LocalitÓ
    VICENZA
    EtÓ
    45
    Messaggi
    5
    Versione Office
    EXCEL 2010
    Likes ricevuti
    0
    Likes dati
    0
    Grazie Gerardo, sei un Grande!!
    avevo il sospetto che il problema fosse anche la struttura, ma non essendo un'esperto, pensavo che ci fosse una formula che potesse sistemare il tutto.:166::166:

  10. #10
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Antosime, grazie per il riscontro e se la tua domanda Ŕ risolta segna questa discussione come risolta, vai in alto in strumenti di discussione e clicca su "segna come risolto"
    Ciao alla prossima

Discussioni Simili

  1. [Risolto] Ore presenze dipendente
    Di luigiflo nel forum Domande su Excel in generale
    Risposte: 40
    Ultimo Messaggio: 22/07/17, 14:32
  2. Presenze, orari, str, ore lavorate
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 12/12/16, 15:09
  3. Conta presenze effettive da elenco
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 23/05/16, 22:00
  4. Foglio presenze con check box e pulsante
    Di Cavier80 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 18/05/16, 23:42
  5. 2007-forum-tabella ore-conta presenze-filtro
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 10/05/16, 14:31

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •