Risultati da 1 a 8 di 8

Discussione: Calcolo consumi silo caricato e scaricato più volte



  1. #1
    L'avatar di Lopez_
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    carbonia
    Età
    31
    Messaggi
    2
    Versione Office
    excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Calcolo consumi silo caricato e scaricato più volte

    Salve ragazzi,

    il mio problema, come da titolo, è quello di calcolare il consumo di materiale (nell'arco della giornata che va dalle 00.00 alle 23.59) all'interno di un silo che viene caricato e scaricato più volte. Io ho un dato ogni 5 secondi. Se facessi semplicemente la differenza (molto stupidamente) tra il primo dato alla mezzanotte, per esempio 10kg, e l'ultimo alle 23:59, per esempio 22 kg, avrei una differenza falsa poiché non terrebbe conto delle volte che il solo viene nuovamente riempito. Qualcuno riesce a darmi una mano? Ve ne sarei decisamente grato :) Qui di sotto una piccola tabellina esempio.

    Grazie

    Carlo

    Time Weight
    00:00 10
    01:03 9
    02:50 8
    04:00 7
    05:00 15
    07:00 14
    10:00 13
    11:00 11
    12:00 19
    13:00 17
    17:00 15
    21:00 14
    22:00 11
    23:59 22
    Ultima modifica fatta da:Canapone; 06/02/17 alle 15:05

  2. #2
    L'avatar di ggratis
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Lecce - Pisa
    Età
    45
    Messaggi
    737
    Versione Office
    Excel 2010
    Likes ricevuti
    257
    Likes dati
    215
    Le informazioni che hai fornito non sono sufficienti, il problema potrebbe essere complesso...cerca in rete "equazioni del serbatoio".
    ...banalmente, invece, se le fasi di carico e scarico non avvengono contemporaneamente e tutte le fasi sono lette, dovresti calcolare la differenza in peso tra la lettura i+1 e la lettura i, la somma di tutte le differenze di peso positive, sono un carico, quelle di segno negativo sono degli scarichi, che puoi calcolare con un somma.se positivo o somma.se negativo
    saluti

  3. #3
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao,

    faccio un tentativo.

    Gli scarichi in C2

    =MATR.SOMMA.PRODOTTO((B3:B15-B2:B14)*((B3:B15-B2:B14)<0))

    i carichi

    =SOMMA(B2:B15)-C2

    ------------------------

    Oppure i carichi


    =MATR.SOMMA.PRODOTTO((B3:B15-B2:B14)*((B3:B15-B2:B14)>0))+B2

    gli scarichi per differenza.

    Saluto ggratis con la risposta del quale mi sono involontariamente sovrapposto

  4. #4
    L'avatar di Marius44
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    73
    Messaggi
    3200
    Versione Office
    Excel2010
    Likes ricevuti
    624
    Likes dati
    154
    Ammesso che i tuoi dati siano in A1:B15 (comprese le intestazioni) molto semplicemente metterei:
    Codice: 
    in C3    =B2-B3 da copiare in basso fino a C15
    in D3    =SOMMA.SE(C3:C15;"<"&0;C3:C15)      il totale dei carichi
    in E3    =SOMMA.SE(C3:C15;">"&0;C3:C15)      il totale degli scarichi
    in F3    =B2-D3-E3    mi dà la rimanenza alle 23.59
    Ovvio che le formule si potrebbero "tecnicizzare" (ridurre, comporre, mischiare) ma così ci si rende conto e si hanno i totali dei movimenti di carico e scarico.

    Prova e fai sapere.
    Ciao,
    Mario

  5. #5
    L'avatar di ggratis
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Lecce - Pisa
    Età
    45
    Messaggi
    737
    Versione Office
    Excel 2010
    Likes ricevuti
    257
    Likes dati
    215
    @ Canapone
    Ciao, nessun problema per la sovrapposizione...
    @ Marius44
    Ciao Mario, credo tu abbia invertito il carico del silos con lo scarico ;-)

    Inviato dal mio GT-I9105P utilizzando Tapatalk

  6. #6
    L'avatar di Lopez_
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    carbonia
    Età
    31
    Messaggi
    2
    Versione Office
    excel 2007
    Likes ricevuti
    0
    Likes dati
    0
    Grazie a tutti.

    Ho risolto con il somma_se anche se ho riscontrato qualche problema per via del fatto che i sensori di peso ogni tanto prendono qualche abbaglio, mandandomi la misura fuori range e quindi restituendomi valori anomali che poi entrano a far parte dei conteggi. Comunque ho risolto. Ancora grazie e alla prox. :)


    Lopez_

  7. #7
    L'avatar di ggratis
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Lecce - Pisa
    Età
    45
    Messaggi
    737
    Versione Office
    Excel 2010
    Likes ricevuti
    257
    Likes dati
    215
    Se gli errori dei sensori sono di tipo grossolano puoi aggiungere ulteriori condizioni che escudono il dato dalla somma

    Inviato dal mio GT-I9105P utilizzando Tapatalk

  8. #8

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Ciao a tutti,

    @Lopez_
    se hai risolto il problema, segna questa discussione come "RISOLTO".
    Vai sul menù "Strumenti Discussione" (all'inizio del thread) e scegli la voce "Segna questo thread come risolto...".

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

Discussioni Simili

  1. [Risolto] Pulsante Carica Documento e Pulsante Apri Documento Caricato
    Di xeienl nel forum Domande su Microsoft Access
    Risposte: 20
    Ultimo Messaggio: 08/02/17, 07:51
  2. [Risolto] Creare una macro che preme il tasto F9 più volte
    Di Andre81 nel forum Domande su Excel VBA e MACRO
    Risposte: 6
    Ultimo Messaggio: 09/12/16, 21:24
  3. Come far ripetere dei valori in base ad un numero di volte
    Di Giancarlo_evo nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 23/05/16, 18:49
  4. Copiare una casella n. volte in orizzontale e verticale
    Di Sergio8903 nel forum Domande su Excel VBA e MACRO
    Risposte: 13
    Ultimo Messaggio: 23/11/15, 19:13
  5. Valore numerico ripetuto 3 volte
    Di Pollosud nel forum Domande su Excel in generale
    Risposte: 18
    Ultimo Messaggio: 27/10/15, 00:27

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •