Risultati da 1 a 21 di 21

Discussione: Tabelle sommare o contare determinate celle e riportare determinati nomi e codici



  1. #1
    L'avatar di QUERIDO8175
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Messina
    Messaggi
    14
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Tabelle sommare o contare determinate celle e riportare determinati nomi e codici

    Salve a tutti!!
    Innanzitutto ringrazio Gerardo che con i suoi video è riuscito ad aiutarmi e darmi una infarinatura di come usare excel poi vorrei porvi delle domande su un file che vi allego.
    Praticamente necessito di contare e/o sommare determinati testi/valori in determinate celle in una stessa riga, ho già inserito delle formule il conta.se ma ogni volta dovrei selezionare manualmente quando invece vorrei che fosse solo per determinate celle in base al colore (tipo il rosso).
    L'altra domanda: è possibile da una tabella 1 (dove sono inseriti dei codici) riportare i nomi in un'altra tabella 2 in corrispondenza dei giorni (vedasi allegato)?

    Ringrazio in anticipo tutti
    File Allegati File Allegati
    Invia MPPM 

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Benvenuto in forumexcel.it
    tu scrivi:
    Praticamente necessito di contare e/o sommare determinati testi/valori in determinate celle in una stessa riga...vorrei che fosse solo per determinate celle in base al colore
    Per calcolare determinati valore in base al colore è difficile e credo bisogna ricorrere al VBA ma se i colori corrispondono al sabato e domenica è tutto più facile...

    [EDIT]

    Se ho capito bene la prima domanda
    in C10 metti questa formula e trascinala in fondo a destra

    =SE(O(GIORNO.SETTIMANA(C4;2)=6;GIORNO.SETTIMANA(C4;2)=7);CONTA.VALORI(C5:C9);"")

    Fammi sapere!
    Ultima modifica fatta da:Gerardo Zuccalà; 21/03/16 alle 20:25 Motivo: ortografico
    Invia MPPM 

  3. #3
    L'avatar di QUERIDO8175
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Messina
    Messaggi
    14
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Ciao Gerardo.
    Ho provato e funziona ma servirebbe nella stessa riga quindi penso che dovrei aggiungere questa formula a quella che ho scritto in U5 però solo se c'è scritto il determinato codice (T in questo caso).
    Io l'ho inserito =CONTA.SE($C5:$R5;"T")-SE(O(GIORNO.SETTIMANA(G4;2)=6;GIORNO.SETTIMANA(G4;2)=7);CONTA.VALORI(G5:G9);"")
    però mi da il numero 2 quando invece dovrebbe essere 3.
    Forse mi conviene farlo direttamente manualmente perchè il VBA non so usarlo completamente.:187:
    Solo che farlo ogni mese per 60 voci diverse per oltre 100 persone è un pò laborioso.
    Dimmi tu

    Invia MPPM 

  4. #4

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2815
    Versione Office
    Excel 2013
    Likes ricevuti
    1024
    Likes dati
    982
    Ciao se ho capito bene, vuoi compilata la tabella2 contando giornalmente le diverse "mansioni".
    Se è così ho scritto nella riga 10 (da U10:AD10) T - S - A - R - P per semplificare la formula
    per i feriali è =MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA($C$4:$R$4;2)<6);--($C5:$R5=U$10))
    per i festivi è =MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA($C$4:$R$4;2)>5);--($C5:$R5=V$10))

    Per la tabella1 ci vuole una matriciale ma risulta complicato in quanto ci sono celle unite.

    EDIT: volevo dire
    Per la tabella3 ci vuole una matriciale ma risulta complicato in quanto ci sono celle unite.
    File Allegati File Allegati
    Invia MPPM 

  5. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao adesso sono fuori casa, visto che non ho capito bene, facciamo cosi allega un file con il risultato desiderato scritto a mano cosi non ci saranno equivoci..ciao
    Invia MPPM 

  6. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7165
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1304
    Ciao Querido,
    provo a risolvere la seconda domanda ... ammesso che abbia capito!
    Ho solo modificato le tue formule.
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!
    Invia MPPM 

  7. #7
    L'avatar di QUERIDO8175
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Messina
    Messaggi
    14
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Rubik72 grazie mille la formula funziona sarebbe un onore anche capirla :167:.
    Gerardo poi ti allego tutto il file così puoi darmi anche i consigli a riguardo.
    Ges la seconda domanda riguarda la tabella 3 dove vorrei che si inseriscono in automatico il personale quando nella tabella 1 metto il codice o mansioni (T,S,P,R...)
    Comunque grande community e grazie ancora a tutti
    Ultima modifica fatta da:Canapone; 22/03/16 alle 08:46
    Invia MPPM 

  8. #8
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    @Quer1875...adesso che ho visto le bella formule di Rubik (che saluto) credo di aver capito bene il problema, ma non è colpa di tua e che dopo una lunga giornata di lavoro sono rintronato, addirittura avevo messo la formula sotto la tabella 1......
    Comunque visto che ci siamo con l'aggiunta di un SE sono riuscito a migliorarla e creare una formula unica

    Metti questa formula in U5 copiala in basso e a destra

    =SE(U$4="feriale";MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA($C$4:$R$4;2)<6);--($C5:$R5=U$10));MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA($C$4:$R$4;2)>5);--($C5:$R5=U$10)))

    Ciao un caro saluto a tutti
    Invia MPPM 

  9. #9

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2815
    Versione Office
    Excel 2013
    Likes ricevuti
    1024
    Likes dati
    982
    la funzione =MATR.SOMMA.PRODOTTO(matrice1,...) somma i prodotti di più matrici.
    In questo caso i prodotti sono VERO/FALSO (oppure 1/0) cioè il risultato di più condizioni.

    Per la seconda richiesta, ti dicevo che con delle formule matriciali risulta difficile in quanto è una tabella formata da celle unite.
    Proverò con il VBA.
    Invia MPPM 

  10. #10

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2815
    Versione Office
    Excel 2013
    Likes ricevuti
    1024
    Likes dati
    982
    In attesa di qualche bella matriciale (anche senza celle unite) ecco una soluzione VBA:
    Codice: 
    Sub Compila()
    Dim TabellaOrigine As Range
    Dim TabellaDestino As Range
    Dim iCol As Long, iRow As Long
    Dim i As Integer
    
    
    
    
    Set TabellaOrigine = Foglio1.Range("A4:R9") 'modificare riferimenti
    Set TabellaDestino = Foglio1.Range("B16:N31") 'modificare riferimenti
    
    
    TabellaDestino.Offset(0, 1).Resize(TabellaDestino.Rows.Count, TabellaDestino.Columns.Count - 1).ClearContents
    
    
    For iRow = 2 To TabellaOrigine.Rows.Count - 1
        For iCol = 3 To TabellaOrigine.Columns.Count - 2
    
    
            If TabellaOrigine.Cells(iRow, iCol) <> "" Then
                Select Case TabellaOrigine.Cells(iRow, iCol)
                    Case "T"
                        i = 2
                    Case "S"
                        i = 4
                    Case "A"
                        i = 6
                    Case "R"
                        i = 8
                    Case "P"
                        i = 10
                End Select
    
    
                TabellaDestino.Cells(iCol - 2, i) = TabellaOrigine.Cells(iRow, 1) & " " & TabellaOrigine.Cells(iRow, 2)
            End If
        Next
    Next
    
    
    End Sub
    Invia MPPM 

  11. I seguenti 3 utenti hanno dato un "Like" a Rubik72 per questo post:


  12. #11
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    In attesa di qualche bella matriciale (anche senza celle unite) ecco una soluzione VBA:
    Codice:
    Eccola!!
    da confermare con i tasti di scelta rapida CTRL+SHIFT+ENTER ( ho visto che hai excel 2010 allora ti preparo la formula con l'AGGREGA)

    =SE.ERRORE(INDICE($A$5:$A$9&" "&$B$5:$B$9;PICCOLO(SE(($C$4:$R$4=$B16)*($C$5:$R$9=SINISTRA(C$15;1));RIF.RIGA($C$5:$C$9)-RIF.RIGA($C$5)+1);CONTA.SE($C$15:C$15;C$15)));"")

    [EDIT] per questa formula ho dovuto togliere le celle unite
    File Allegati File Allegati
    Invia MPPM 

  13. I seguenti 2 utenti hanno dato un "Like" a Gerardo Zuccalà per questo post:


  14. #12
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    @Enzo anche se non ho capito il codice VBA che hai scritto ti faccio i miei più sinceri complimenti

    @querido8175
    Se vuoi semplificarti la vita questa formula qui sotto non ha bisogno di attivarla con CTRL+SHIT+ENTER
    nella cella C16 solo copia ed incolla poi trascini a destra e poi in basso

    =SE.ERRORE(INDICE($A$5:$A$9&" "&$B$5:$B$9;AGGREGA(15;6;(RIF.RIGA($C$5:$C$9)-RIF.RIGA($C$5)+1)/(($C$4:$R$4=$B16)*($C$5:$R$9=SINISTRA(C$15;1)));CONTA.SE($C$15:C$15;C$15)));"")


    [EDIT] per questa formula ho dovuto togliere le celle unite
    facci sapere!
    Invia MPPM 

  15. I seguenti utenti hanno dato un "Like"


  16. #13
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2134
    Ciao Querido, una variante alla formula di Gerardo, che saluto, può essere rappresentate dalle seguenti:

    In C16:
    =SE.ERRORE(INDICE(A:A&" "&B:B;AGGREGA(15;6;RIF.RIGA($B$4:$B$9)/(($C$4:$R$9="T")*($C$4:$R$4=$B16));1));"")

    In E16:
    =SE.ERRORE(INDICE(A:A&" "&B:B;AGGREGA(15;6;RIF.RIGA($B$4:$B$9)/(($C$4:$R$9="S")*($C$4:$R$4=$B16));1));"")

    In G16:
    =SE.ERRORE(INDICE(A:A&" "&B:B;AGGREGA(15;6;RIF.RIGA($B$4:$B$9)/(($C$4:$R$9="A")*($C$4:$R$4=$B16));1));"")

    In I16:
    =SE.ERRORE(INDICE(A:A&" "&B:B;AGGREGA(15;6;RIF.RIGA($B$4:$B$9)/(($C$4:$R$9="R")*($C$4:$R$4=$B16));1));"")

    In K16:
    =SE.ERRORE(INDICE(A:A&" "&B:B;AGGREGA(15;6;RIF.RIGA($B$4:$B$9)/(($C$4:$R$9="P")*($C$4:$R$4=$B16));1));"")

    In M16:
    =SE.ERRORE(INDICE(A:A&" "&B:B;AGGREGA(15;6;RIF.RIGA($B$4:$B$9)/(($C$4:$R$9="P")*($C$4:$R$4=$B16));2));"")

    Tutte da tirare giù alla bisogna.
    Allego il file di prova.
    Ciao.
    File Allegati File Allegati
    Invia MPPM 

  17. I seguenti 2 utenti hanno dato un "Like" a pkrome59 per questo post:


  18. #14
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Pkrome
    ottima soluzione anche se non sono d' accordo sulla parte iniziale della formula INDICE(A:A&" "&B:B
    perchè costringi le formule a vedere tutti gli intervalli A:A e B:B questi significa (10320000 righe x 2) cioè spreco di risorse e tempo.
    io Opterei per un Range come dici tu "alla bisogna" es A4:A9 e B4:B9
    ciao Pkrome
    Invia MPPM 

  19. I seguenti utenti hanno dato un "Like"


  20. #15
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2134
    Ciao Gerardo, hai perfettamente ragione, errori di gioventù, la tua affermazione arricchisce le mie conoscenze, infatti ho notato uno sperpero di risorse.
    Ciao e un augurio di una buona notte.
    Invia MPPM 

  21. #16
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da pkrome59 Visualizza Messaggio
    errori di gioventù
    hahah behe insomma..... comunque stai crescendo velocemente...
    Ciao Pkrome buona notte anche a te!
    Invia MPPM 

  22. #17
    L'avatar di QUERIDO8175
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Messina
    Messaggi
    14
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Ragazzi siete dei mostri nel senso buono ovviamente.
    Ho visto che qualcuno sta crescendo velocemente, beh allora io ho solo aperto gli occhi.
    cmq devo dire che tutti i file che mi avete mandato e relative formule soddisfano i miei criteri, oggi proverò a mettere in pratica tutte le formule che mi avete inserito e sperare che funzioni in grande scala dato che le tabelle sono riportate in fogli differenti ma credo che non sia un problema.
    Vi auguro una buona giornata di lavoro e a più tardi.
    Grazie infinite
    Invia MPPM 

  23. #18
    L'avatar di QUERIDO8175
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Messina
    Messaggi
    14
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Tabelle sommare o contare determinate celle e riportare determinati nomi e codici

    Salve a tutti,
    ho un problema tanto per cambiare.:223:
    Mi rivolgo a Pkrome59 e Gerardo Z., ho inserito la formula e apportando le modifiche alle mie esigenze praticamente non funziona.
    Vi ho allegato il file, magari mi potete dare qualche delucidazione in merito.
    Vi auguro una buona serata e a presto
    File Allegati File Allegati
    Invia MPPM 

  24. #19
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Tabelle sommare o contare determinate celle e riportare determinati nomi e codici

    Cioa Querido8175, bentornato
    Hai postato la tua domanda in una vecchia discussione, che tra l'altro era stata già risolta, questo significa che la tua domanda verrà vista da poche persone e quindi ti consiglio di iniziare una nuova discussione come tra l'altro previsto dal regolamento (da rileggere)
    In a attesa che riproponi la tua domanda
    ciao
    Invia MPPM 

  25. #20
    L'avatar di QUERIDO8175
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Messina
    Messaggi
    14
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Tabelle sommare o contare determinate celle e riportare determinati nomi e codici

    Perdonami Gerardo.
    L'ho fatto solo esclusivamente perché riguarda lo stesso file.
    Mi rivolgo a Pkrome59 e ovviamente a te Gerardo Z. in quanto siete quelli che mi avete suggerito la soluzione.
    ho inserito la formula che mi avete inviato e apportando le modifiche alle mie esigenze praticamente non funziona.

    Vi ho allegato il file, magari mi potete dare qualche delucidazione in merito.
    Vi auguro una buona serata e a presto.
    File Allegati File Allegati
    Invia MPPM 

  26. #21
    L'avatar di QUERIDO8175
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Messina
    Messaggi
    14
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Tabelle sommare o contare determinate celle e riportare determinati nomi e codici

    scusa ho sbagliato nuovamente:223:
    Invia MPPM 

Discussioni Simili

  1. Associare e contare nomi
    Di Mammut65 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 08/03/17, 23:10
  2. [Risolto] Sommare in base a parti di testo in codici
    Di CarloM nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 21/02/17, 22:58
  3. Risposte: 3
    Ultimo Messaggio: 14/11/16, 22:00
  4. riportare dati da una tabella generale ad altre tabelle
    Di mpaolett nel forum Domande su Excel in generale
    Risposte: 20
    Ultimo Messaggio: 10/06/16, 01:42
  5. Formula x contare celle con determinati valori testuali e colori...AIUTO!
    Di Fabio73 nel forum Domande su Excel VBA e MACRO
    Risposte: 10
    Ultimo Messaggio: 20/10/15, 22:53

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •