Risultati da 1 a 8 di 8

Discussione: Associare dati tra due fogli



  1. #1
    L'avatar di Caronte1980
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    italia
    Età
    37
    Messaggi
    32
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    4

    Associare dati tra due fogli

    Buonasera
    ho bisogno di un vostro aiutino, sapete se c'è una formula di excel che permette di associare un dato contente nel foglio2 ad un atro dato presente nel foglio1
    es: ho un foglio dove sono presenti 100 nominativi con i propri codici fiscali ai quali devo associare il numero di contratto di affitto presente nel foglio 2 che è composto dal codice fiscale e dal numero contratto

    spero di essere stato chiaro

    grazie mille

    Caronte1980

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Ciao,
    se intendi scrivere la formula in un'altra cella/colonna allora si... potresti usare la combinazione della funzione CERCA.VERT per la ricerca del codice fiscale nel foglio2 e della funzione CONCATENA per unire codice fiscale e numero di contratto.

    In una cella O usi una formula O scrivi il testo/valore manualmente (a meno di non ricorrere al VBA).

    Se allegassi un file d'esempio si capirebbe meglio la tua richiesta.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133
    Ciao Caronte 1980, se ho capito bene copia la seguente adattata al tuo Range:

    =SE.ERRORE(INDICE(Foglio2!$B$2:$B$10;AGGREGA(15;6;(RIF.RIGA(Foglio1!$A$2:$A$10)-RIF.RIGA(Foglio1!$A$2)+1)/(Foglio2!$A$2:$A$10=Foglio1!$B2);1));"")

    Allego il file di prova.
    Fa sapere se va bene.
    Ciao.
    File Allegati File Allegati

  4. I seguenti utenti hanno dato un "Like"

    ges

  5. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7149
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2064
    Likes dati
    1300
    Ciao a tutti,
    visto che si tratta di "associare" dei nominativi con codice fiscale si potrebbe anche utilizzare una formula più semplice di quella usata da pkrome, che cordialmente saluto (e uso il suo esempio), e cioè questa:

    =INDICE(Foglio2!$B$2:$B$10;CONFRONTA(Foglio1!B2;Foglio2!$A$2:$A$10;0))


    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. I seguenti utenti hanno dato un "Like"


  7. #5
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133
    Bravo Ges, formula semplice leggibile corta ed efficace.

  8. #6
    L'avatar di Caronte1980
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    italia
    Età
    37
    Messaggi
    32
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    4
    Wow Grazie mille ges era proprio quello che mi serviva:286:

  9. #7
    L'avatar di Caronte1980
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    italia
    Età
    37
    Messaggi
    32
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    4
    Grazie pkrome59 era proprio la formula che mi serviva anche perché ne foglio 2 ho anche le persone che non hanno il contratto e li devo ugualmente associare al codice fiscale presente nel foglio1 dal foglio2:286:

  10. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7149
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2064
    Likes dati
    1300
    Ciao Caronte,
    a quanto pare ti sono state utili le due formule.
    Se la tua domanda è stata risolta segna questa discussione come [RISOLTO].
    Vai nella barra dei menu, situata all’inizio di questa discussione, dove troverai il menu "Strumenti Discussione" quindi scegli "Segna questo Thread come risolto".
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

Discussioni Simili

  1. Associare e contare nomi
    Di Mammut65 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 08/03/17, 23:10
  2. [Risolto] associare specifici fogli excel
    Di AntoFrancio nel forum Domande su Excel VBA e MACRO
    Risposte: 25
    Ultimo Messaggio: 12/01/17, 18:46
  3. Associare dati selezionati
    Di sgnappi nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 23/11/16, 13:10
  4. Associare nomi
    Di Vincenzo Damiani nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 01/02/16, 20:55
  5. associare valore
    Di antonysameli nel forum Domande su Excel VBA e MACRO
    Risposte: 0
    Ultimo Messaggio: 19/10/15, 17:57

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •