Risultati da 1 a 6 di 6

Discussione: Utilizzo cerca.vert su 2 tabelle pivot



  1. #1
    L'avatar di Aleco_2016
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Milano
    Età
    38
    Messaggi
    15
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    1

    Utilizzo cerca.vert su 2 tabelle pivot

    Ciao a tutti,

    non riesco a far funzionare il cerca.vert su 2 tabelle pivot con Excel 2010 ma funzionava perfettamente con la versione 2007.

    Mi sapreste darmi qualche suggerimento in merito?

    Grazie dell'attenzione
    Ultima modifica fatta da:Canapone; 06/02/17 alle 15:03

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao,

    puoi allegare un estratto del file - senza dati sensibili - con un esempio el problema riscontrato?

    Saluti

  3. #3
    L'avatar di Aleco_2016
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Milano
    Età
    38
    Messaggi
    15
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    1
    Ciao ragazzi,

    vi allego un file di prova.

    Grazie e buona giornata
    File Allegati File Allegati

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao

    i campi della seconda pivot sono diversi da quelli della prima che presenta molti spazi alla fine. Dove gli spazi finali sono assenti, il cerca.vert - che chiede l'esatta corrispondenza - funziona.

    Nel tuo caso puoi ovviare

    =SOMMA.SE($A$5:$A$10;D5&"*";$B$5:$B$10)

    o così

    =INDICE($B$5:$B$10;CONFRONTA(D5;INDICE(ANNULLA.SPAZI($A$5:$A$10););0))

    Oppure elimini gli spazi nella tabella sorgente.

    Spero sia d'aiuto

  5. #5
    L'avatar di Aleco_2016
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Milano
    Età
    38
    Messaggi
    15
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    1
    Ciao Canapone,

    funziona la tua formula.

    Ho provato anche con il cerca.cert e funziona nel seguente modo:

    =CERCA.VERT(E5&"*";$A$5:$C$17;3;0)

    Grazie mille e buona giornata

  6. #6
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao,

    grazie a te del riscontro.

    Bello arrivare alla soluzione in tanti modi.

Discussioni Simili

  1. [Risolto] Problema formula cerca.vert con utilizzo funzione valore
    Di Ale64 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 02/01/17, 20:11
  2. [Risolto] Cerca valori che si ripetono in tabella. Formula per arrivare dove il cerca.vert non può
    Di Gatt88 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 02/12/16, 11:45
  3. Utilizzo funzione CERCA.VERT
    Di tokio21 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 23/10/16, 14:58
  4. [Risolto] combinare due tabelle ma non con il semplice cerca.vert
    Di maverick69net nel forum Domande su Excel in generale
    Risposte: 22
    Ultimo Messaggio: 06/10/16, 11:30
  5. pivot da due tabelle
    Di Timoteo nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 30/06/16, 10:18

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •