Risultati da 1 a 16 di 16

Discussione: Somma con doppio Criterio



  1. #1
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Exclamation Somma con doppio Criterio

    Caio a tutti
    ho un piccolo data set sulla sinistra e
    in D5 devo fare una somma con doppio criterio che si trovano in D2 e E2

    A
    B
    C
    D
    E
    1
    a
    10
    criterio criterio
    2
    b
    4
    a c
    3
    c
    2
    4
    a
    25
    risultato
    5
    b
    4
    39
    6
    c
    2
    7
    b
    2
    8
    b
    5

  2. #2
    L'avatar di Luigi Paravan
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Arquata Scrivia
    EtÓ
    62
    Messaggi
    46
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    0
    Ciao sii clemente la giornata di lavoro Ŕ stata molto calda e lunga
    =SOMMA.SE(A1:A8;D2;B1:B8)+SOMMA.SE(A1:A8;E2;B1:B8)

  3. #3
    L'avatar di Ste
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Brescia
    EtÓ
    16
    Messaggi
    250
    Versione Office
    2016 PC
    Likes ricevuti
    4
    Likes dati
    19
    Ciao a tutti..

    Potete dirmi per favore perchŔ questa formula non funziona?!

    =SOMMA.PI┘.SE(B1:B8;A1:A8;D2;A1:A8;E2)
    Se non credi in te stesso, nessuno lo farÓ per te. - Kobe Bryant

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Como
    EtÓ
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Citazione Originariamente Scritto da Ste Visualizza Messaggio
    Ciao a tutti..

    Potete dirmi per favore perchŔ questa formula non funziona?!

    =SOMMA.PI┘.SE(B1:B8;A1:A8;D2;A1:A8;E2)
    La formula SOMMA.PIU'.SE Ŕ fatta per sommare la "COMBINAZIONE" di pi¨ valori; nel quiz postato da Gerardo si chiede invece di sommare le celle corrispondenti al dato "a" E quelle corrispondenti al dato "b".

    Avrebbe invece funzionato se per esempio nella colonna C c'erano altre lettere e venisse chiesto di sommare le COMBINAZIONI di lettere tra la colonna A e quelle C.

  5. #5
    L'avatar di Ste
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Brescia
    EtÓ
    16
    Messaggi
    250
    Versione Office
    2016 PC
    Likes ricevuti
    4
    Likes dati
    19
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    ...
    Perfetto grazie
    Ultima modifica fatta da:Canapone; 07/02/17 alle 17:11
    Se non credi in te stesso, nessuno lo farÓ per te. - Kobe Bryant

  6. #6
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao a tutti,

    condivido un altro approccio

    =MATR.SOMMA.PRODOTTO(SOMMA.PI┘.SE(B1:B8;A1:A8;D2:E2))

    =MATR.SOMMA.PRODOTTO(SOMMA.SE(A1:A8;D2:E2;B1:B8))

    Potrebbe essere comodo per sommare le corrispondenze con pi¨ lettere.

    Fate qualche prova, non sono sicurissimo.

  7. #7
    L'avatar di Ste
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Brescia
    EtÓ
    16
    Messaggi
    250
    Versione Office
    2016 PC
    Likes ricevuti
    4
    Likes dati
    19
    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    ...
    Ciao Canapone

    Io le ho provate e funzionano entrambe come al solito (Un Guru INFALLIBILE)

    Saluti!
    Ultima modifica fatta da:Canapone; 07/02/17 alle 17:11
    Se non credi in te stesso, nessuno lo farÓ per te. - Kobe Bryant

  8. #8
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao Ste e grazie,

    la formula Ŕ un po' lunga: Ŕ scomodo scrivere matr.somma.prodotto.

    Il vantaggio Ŕ che puoi scrivere in D2:Z2 - Ŕ un esempio- tutti le lettere di cui vuoi sommare i numeri. Scrivendo due volte "A" in D2:Z2, la formula somma due volte gli stessi numeri corrispondenti.

    Saluti

    (Scappo in palestra. A far niente)
    Ultima modifica fatta da:Canapone; 11/07/15 alle 12:21

  9. #9
    Santo
    Ospite L'avatar di Santo
    Citazione Originariamente Scritto da Luigi Paravan Visualizza Messaggio
    ...
    Quesito semplice. Risposta semplice, efficiente ed efficace
    Ultima modifica fatta da:Canapone; 07/02/17 alle 17:11

  10. #10
    Santo
    Ospite L'avatar di Santo
    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    ...
    I vantaggi sono nettamente inferiori agli svantaggi. La formula somma.pi¨.se Ŕ di gran lunga pi¨ veloce di matr.somma.prodotto. Non ha senso nidificare una funzione veloce all'interno di una lenta. Provare anche solo con un centinaio di intervalli e qualche decine di condizioni. La considero una simpatica goliardata del pur bravo Canapone. Tecnicamente la risposta vincente Ŕ quella di Luigi Paravan che invito a uscire fuori dalla sua "timidezza"
    Ultima modifica fatta da:Canapone; 07/02/17 alle 17:12

  11. #11
    Santo
    Ospite L'avatar di Santo
    Citazione Originariamente Scritto da Ste Visualizza Messaggio
    Perfetto grazie
    Tutto sbagliato invece. Consiglio Ges a curiosare nella Guida per la formula in questione ed anche di capire meglio la logica booleana di Excel

  12. #12
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    1678
    Versione Office
    2010 PC
    Likes ricevuti
    895
    Likes dati
    184
    Ciao
    un'altra possibilitÓ:
    =MATR.SOMMA.PRODOTTO(((A1:A8=D2)+(A1:A8=E2))*B1:B8)

    oppure
    =MATR.SOMMA.PRODOTTO((A1:A8=D2:E2)*B1:B8)
    Ultima modifica fatta da:ninai; 11/07/15 alle 14:06

  13. #13
    Santo
    Ospite L'avatar di Santo
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ...
    Le formule da te proposte, senza bisogno di testarle, funzionano. Il discorso per˛ Ŕ sempre lo stesso. L'economicitÓ del sistema. A partire da Excel 2007 per contare e sommare intervalli con uno o pi¨ criteri conviene usare le nuove funzioni introdotte appositamente. E' inutile quindi andare anche su vetuste formule, quali CONTA.SE e SOMMA.SE
    Ultima modifica fatta da:Canapone; 07/02/17 alle 17:13

  14. #14
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    Ciao
    un'altra possibilitÓ:
    =MATR.SOMMA.PRODOTTO(((A1:A8=D2)+(A1:A8=E2))*B1:B8)

    oppure
    =MATR.SOMMA.PRODOTTO((A1:A8=D2:E2)*B1:B8)
    Evvaii! grande Ninai
    e con questa ultima chicca considero risolto questa discussione :87:_

    Benvenuto nel forum!!

  15. #15
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    1678
    Versione Office
    2010 PC
    Likes ricevuti
    895
    Likes dati
    184
    Citazione Originariamente Scritto da Santo Visualizza Messaggio
    ....... A partire da Excel 2007 per contare e sommare intervalli con uno o pi¨ criteri conviene usare le nuove funzioni introdotte appositamente. E' inutile quindi andare anche su vetuste formule, quali CONTA.SE e SOMMA.SE
    Mah, parzialmente d'accordo , per˛, a parte che sono molto "affezionato" alla MATR.SOMMA.PRODOTTO(), se devi estrarre i dati o il/i criteri con qualche funzione annidata, con le "moderne, funzioni hai qualche problema.

    Grazie per il benvenuto

  16. #16

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Como
    EtÓ
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Citazione Originariamente Scritto da Santo Visualizza Messaggio
    Tutto sbagliato invece. Consiglio Ges a curiosare nella Guida per la formula in questione ed anche di capire meglio la logica booleana di Excel
    Ciao Santo, premetto che non me ne intendo di logiche booleane di excel e sono qui per imparare; quindi secondo te la formula CONTA.PIU'.SE pu˛ essere utilizzata da sola per il caso in questione?
    Da parte mia Ŕ bene accetto se ci spieghi come.

Discussioni Simili

  1. [Risolto] Somma.doppio.se
    Di alexsurfer nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 07/03/17, 11:03
  2. formattazione condizionale con doppio criterio
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 26/01/16, 11:16
  3. Matrice da popolare con verifica doppio criterio date
    Di AlphaCent nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 19/12/15, 12:09
  4. Somma con singolo criterio su fogli multipli
    Di Gerardo ZuccalÓ nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 09/09/15, 08:17
  5. Somma con criterio parziale
    Di Gerardo ZuccalÓ nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 01/07/15, 09:03

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •