Risultati da 1 a 3 di 3

Discussione: Formula Excel per automatizzare classifica



  1. #1
    L'avatar di alex22
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Taranto
    Età
    21
    Messaggi
    1
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Formula Excel per automatizzare classifica

    Salve a tutti, inizio a dire già da ora che non sono un esperto di Excel e dell'informatica in generale ma comunque sono parecchio attirato da essa per le numerose funzioni che si possono svolgere.
    Ho un urgente bisogno di finire questo lavoro Excel, in pratica devo fare una classifica dei marcatori del Milan del girone di andata del campionato Serie A 2015/2016. C'è una colonna (foglio 1) dove ci sono tutti i marcatori a seconda delle partite, l'obbiettivo è quello di fare una classifica marcatori utilizzando una formula di Excel, la classifica marcatori si trova nel foglio 2
    Sapete per caso dirmi qual'è la formula ?
    Lascio comunque in allegato il mio foglio Excel
    File Allegati File Allegati
    Ultima modifica fatta da:Canapone; 29/03/16 alle 17:16 Motivo: Meglio usare - come da regolamento - un titolo significativo

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Alex22
    Benvenuto in forumexcel.it

    Alla tua domanda ci sono diverse soluzioni, anche molto complesse con formule matriciali, ma io con l'aiuto di alcune colonne aggiuntive rendo il tutto molto semplice..

    Nella colonna G ho messo tutti i nomi dei calciatori una lista unica scritta a mano (senza formule)

    e nella colonna H ho messo tutti i gol che ha fatto ognuno di loro la funzione CONTA.SE
    =CONTA.SE($G$2:$J$20;G23)

    nella colonna J ho messo il numero di gol dal più grande al più piccolo
    =GRANDE($H$23:$H$35;RIGHE($J$23:J23))

    nella colonna K ho assegnato il nome corrispondente al numero di Goal
    Attenzione questa formula per poter funzionare devi attivarla digitando CTRL++SHIFT+ENTER

    =INDICE($G$23:$G$35;PICCOLO(SE($H$23:$H$35=J23;RIF.RIGA($G$23:$G$35)-RIF.RIGA($G$23)+1);CONTA.SE($J$23:J23;J23)))

    PS per pigrizia l'ho fatta tutto nello stesso foglio, ma ovviamente adesso sta a te fare un minimo di lavoro e adattarla al foglio 2, comunque se le colonne aggiuntive ti danno fastidio, puoi sempre nasconderle
    Fai sapere!

    G
    H
    I
    J
    K
    22
    Lista calciatori conto i goal >numero gol nome
    23
    Mexes
    1
    7
    bacca
    24
    luiz adriano
    3
    4
    bonaventura
    25
    guarin
    1
    3
    luiz adriano
    26
    bonaventura
    4
    2
    Antonelli
    27
    Balotelli
    1
    2
    Niang
    28
    Zapata
    1
    1
    Mexes
    29
    Antonelli
    2
    1
    guarin
    30
    Bertolacci
    1
    1
    Balotelli
    31
    bacca
    7
    1
    Zapata
    32
    Niang
    2
    1
    Bertolacci
    33
    Alex
    1
    1
    Alex
    34
    Abate
    1
    1
    Abate
    35
    Kucka
    1
    1
    Kucka

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Un'altra soluzione a quella proposta da Gerardo, che saluto:

    Per la classifica:

    =INDICE(Foglio1!$K$2:$K$29;CONFRONTA(GRANDE(Foglio1!$L$2:$L$28-RIF.RIGA(Foglio1!$L$2:$L$28)/10000;RIGHE($A$1:$A1));Foglio1!$L$2:$L$28-RIF.RIGA(Foglio1!$L$2:$L$28)/10000;0))

    Per i gol fatti:

    =SE(SINISTRA(A2;5)="Milan";SINISTRA(C2;1);DESTRA(C2;1))+0

    Per i gol subiti:

    =SE(DESTRA(A2;5)="Milan";SINISTRA(C2;1);DESTRA(C2;1))+0
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

Discussioni Simili

  1. Creazione classifica Excel
    Di Whipper nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 01/02/17, 16:06
  2. Risposte: 16
    Ultimo Messaggio: 30/11/16, 22:19
  3. Estrapolare una classifica di categoria da una classifica generale
    Di Albyspace nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 29/09/16, 00:54
  4. Problema formula per classifica
    Di luca.cr7 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 30/05/16, 09:40
  5. Automatizzare operazioni
    Di karotto nel forum Domande su Excel VBA e MACRO
    Risposte: 24
    Ultimo Messaggio: 21/12/15, 21:30

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •