Risultati da 1 a 4 di 4

Discussione: Calcolo differenza oraria



  1. #1
    L'avatar di Harry
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Milano
    Età
    47
    Messaggi
    5
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    Calcolo differenza oraria

    Ciao a tutti,

    cercando un po' sul forum, non credo di aver trovato risposta e quindi apro nuova discussione.
    Ho necessità di calcolare la differenza in ore tra due celle che contengono Data+ora.
    La cosa sembra facile, ma temo che il formato in cui mi vengono esportati i dati, non mi permette di usare la formula "elementare"

    Vi allego il file per comodità.
    I tentativi che ho fatto sono stati:
    cambio formato da Generale a Data/Ora ma nulla di fatto
    Separazione testo in colonne: anche in questo caso nulla di fatto, anche perchè (almeno credo) l'orario delle prime del mattino viene proposto senza lo ZERO iniziale.
    Per lo stesso motivo non ho tentato STRINGA.ESTRAI in quanto il contenuto della cella è variabile.

    Grazie anticipatamente per chi potrà supportarmi.

    Harry
    File Allegati File Allegati

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1668
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    ciao
    se ho ben capito, in D2:
    =SE.ERRORE(SOSTITUISCI(C2;".";":")-SOSTITUISCI(B2;".";":");"")
    il formato devi usare:
    [hh]:mm o similari

    se vuoi i minuti in formato decimale, con formato numero, basta moltiplicare per 24:
    =SE.ERRORE((SOSTITUISCI(C2;".";":")-SOSTITUISCI(B2;".";":"))*24;"")
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Harry
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Milano
    Età
    47
    Messaggi
    5
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    Re: Calcolo differenza oraria

    Wonderful!
    NOn avevo pensato alla cosa più semplice (sostituire il . con i :)
    E soprattutto in questa maniera (non conoscevo la formula)

    Provo a fare un passo in più, visto che sono di nuovo arenato :-(

    In realtà tutto ciò che è precedente alle 9 del mattino, devo considerarlo le 9 del mattino
    Questo perchè nel calcolo non devo tenere conto dell'orario "fuori ufficio"
    Lo stesso dicasi per le posizioni dopo le 18 che devono diventare "giorno +1" alle 9. del mattino.

    Avresti una soluzione?

    Grazie ancora tantissimoooooo

    Harry

  5. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1668
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Calcolo differenza oraria

    mi spiace ma non capisco cosa ti serve, dovresti fare degli esempi di risultati voluti in base ai dati del file.

    in ogni caso, se devi fare calcoli più articolati, ti conviene sistemare prima i formati dei dati con il sostituisci, per snellire le formule che si dovranno applicare
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

Discussioni Simili

  1. [Risolto] Somma oraria
    Di alex_drastic nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 19/02/17, 13:18
  2. [Risolto] Differenza ora
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 07/12/16, 19:23
  3. [Risolto] Estrapolazione record in una determinata fascia oraria.
    Di NicolaM nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 02/12/16, 22:15
  4. [Risolto] Breakout dei massimi e minimi in una fascia oraria
    Di Andreaude nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 20/10/16, 20:18
  5. calcolo media oraria
    Di ScaliseG nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 06/06/16, 19:29

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •