Risultati da 1 a 7 di 7

Discussione: somma valori per mese



  1. #1
    L'avatar di KARL184
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Cormano
    Messaggi
    3
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    somma valori per mese

    Buonasera,
    mi sono già presentato nel forum, non sono espertissimo ma grazie al forum sto cercando si studiare sia formule sia qualche spunto vba.
    Con una macro (ispirata dal forum, registrata e pulita forse) ho eliminato i doppioni che si trovavano nella colonna C e messi in F.
    Ora dovrei per nome univoco colonna F sommare i valori posti nella colonna D nella tabella divisa per mese in relazione al nome in colonna C e data B.
    Grazie 1000

    Buon we

    Codice: 
    Sub Macro1()
    '
    ' Macro1 Macro
    '
    
    
    '
        Range("C3:C2370").Select
        Selection.Copy
        Range("F3").Select
        Selection.PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks _
            :=False, Transpose:=False
        Columns("F:F").EntireColumn.AutoFit
        Application.CutCopyMode = False
        ActiveSheet.Range("$F$3:$F$2370").RemoveDuplicates Columns:=1, Header:=xlNo
    End Sub
    File Allegati File Allegati
    Ultima modifica fatta da:cromagno; 01/04/16 alle 18:48 Motivo: Inserito codice

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Ciao,
    prova con questa formula da mettere nella cella G3 e dopo copia in basso e a destra:

    =MATR.SOMMA.PRODOTTO(($C$3:$C$19=$F3)*($B$3:$B$19>=G$1)*($B$3:$B$19<=G$2)*$D$3:$D$19)

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di KARL184
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Cormano
    Messaggi
    3
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0
    Ciao,
    ti ringrazio Cromagno. Funziona perfettamente. Ho sempre usato poco matr.somma.prodotto. La studio bene, semplice e funzionale!!

  5. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Citazione Originariamente Scritto da KARL184 Visualizza Messaggio
    Ciao,
    ti ringrazio Cromagno. Funziona perfettamente. Ho sempre usato poco matr.somma.prodotto. La studio bene, semplice e funzionale!!
    Ciao Karl,
    se hai risolto il problema, segna questa discussione come "RISOLTO".
    Vai sul menù "Strumenti Discussione" (all'inizio del thread) e scegli la voce "Segna questo thread come risolto...".

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  6. #5
    L'avatar di KARL184
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Cormano
    Messaggi
    3
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0
    Fatto! :)

  7. #6
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buona Sera

    In alternativa a Matrice.Somma.Prodotto


    =SOMMA.PIÙ.SE($D$3:$D$19;$C$3:$C$19;$F3;$B$3:$B$19;">="&G$1;$B$3:$B$19;"<="&G$2) copia in basso e a destra

    per nascondere gli zero formato personalizzato [=0]""

    Saluti
    Window 8.1 Excel 2013/2016

  8. I seguenti utenti hanno dato un "Like"


  9. #7
    L'avatar di Giuseppe Zammuto
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Montebello Vicentino
    Età
    64
    Messaggi
    69
    Versione Office
    Office 2013
    Likes ricevuti
    1
    Ciao
    Bravissimo:262:

Discussioni Simili

  1. excel scalare ferie annuali mese mese ad ore
    Di babi66v nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 09/03/17, 14:26
  2. Somma Entrate per mese
    Di pinnighi nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 24/11/16, 21:36
  3. [Risolto] Formula Somma riepilogativa da più fogli fino al mese corrente
    Di Berna11 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 13/09/16, 18:53
  4. Ricerca giorni mancanti a fine mese e mese successivo
    Di pixartao nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 02/08/16, 15:08
  5. Sommare valori aggregandoli per mese da date giornaliere
    Di G.Bove nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 29/11/15, 14:17

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •