Risultati da 1 a 10 di 10

Discussione: Somma con ricerca parziale del testo



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Somma con ricerca parziale del testo

    Ciao A tutti
    la pillola del giorno
    oggi ho sfoderato dal mio repertorio una vecchia formula sempre molto interessante
    ci potrebbero essere piu di una soluzione
    In E2 ho bisogno di una formula da copiare in basso che mi dia la somma da una ricerca parziale del testo
    Buon Divertimento

    A
    B
    C
    D
    E
    1
    Codice Venduti Testo parziale Risultato
    2
    GoldXXL
    100
    Platinum
    300
    3
    GoldSL
    200
    Silver
    200
    4
    GoldVVV
    100
    Gold
    900
    5
    SilverXXX
    200
    6
    GoldSL
    300
    7
    PlatinumXLM
    200
    8
    Gold+XL
    200
    9
    PlatinumXXX
    100


    PS. queste tabelle sono esportabili in excel, Seleziona la tabella, copia, ed incolla in excel
    Ultima modifica fatta da:Gerardo Zuccalà; 11/07/15 alle 18:26

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1653
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    ciao

    una delle possibilità:
    =MATR.SOMMA.PRODOTTO(VAL.NUMERO(TROVA(K3;$A$2:$A$9))*$B$2:$B$9)

  3. #3
    L'avatar di Luigi Paravan
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Arquata Scrivia
    Età
    62
    Messaggi
    46
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    0
    Ciao 2° possibilità
    =SOMMA.PIÙ.SE($B$2:$B$9;$A$2:$A$9;D2&"*")

  4. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1653
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    anche
    =SOMMA.SE($A$2:$A$9;D2&"*";$B$2:$B$9)

  5. #5
    L'avatar di MauroS
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Abruzzo
    Età
    40
    Messaggi
    56
    Versione Office
    2007 WIN
    Likes ricevuti
    1
    Ciao Luigi,
    approfitto della tua formula dato che ho imparato una cosa nuova e così la aggiusterei in questo modo da poter cercare anche solo la parte centrale del testo
    Grazie.

    =SOMMA.PIÙ.SE($B$2:$B$9;$A$2:$A$9;"*"&D2&"*")

    Mauro.

  6. #6
    L'avatar di Luigi Paravan
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Arquata Scrivia
    Età
    62
    Messaggi
    46
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    0
    e io approfitterò della tua
    grazie
    Luigi

  7. #7
    L'avatar di Ste
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    16
    Messaggi
    250
    Versione Office
    2016 PC
    Likes ricevuti
    4
    Likes dati
    19
    Ciao a tutti, simile a una precedente.. Sono arrivato tardi!!

    =SOMMA.SE($A$2:$A$9;"*"&D2&"*";$B$2:$B$9)
    Ultima modifica fatta da:Gerardo Zuccalà; 12/07/15 alle 10:54
    Se non credi in te stesso, nessuno lo farà per te. - Kobe Bryant

  8. #8
    L'avatar di Ste
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    16
    Messaggi
    250
    Versione Office
    2016 PC
    Likes ricevuti
    4
    Likes dati
    19
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    ***
    Ciao Gerardo come mai mi hai modificato il post?

    Grazie saluti
    Ultima modifica fatta da:Canapone; 10/02/17 alle 11:21
    Se non credi in te stesso, nessuno lo farà per te. - Kobe Bryant

  9. #9
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da Ste Visualizza Messaggio
    Ciao Gerardo come mai mi hai modificato il post?

    Grazie saluti
    Ciao Ste
    mancava il segno uguale (=) all'inizio.. avevo capito che era un errore di copia ed incolla e l'ho aggiustato io
    ciao

  10. #10
    L'avatar di Ste
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    16
    Messaggi
    250
    Versione Office
    2016 PC
    Likes ricevuti
    4
    Likes dati
    19
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    ***
    Grazie e scusami!
    Ultima modifica fatta da:Canapone; 10/02/17 alle 11:22
    Se non credi in te stesso, nessuno lo farà per te. - Kobe Bryant

Discussioni Simili

  1. somma.se testo concatena
    Di m.davide nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 31/07/17, 12:36
  2. [Risolto] Restituire una somma di valori dopo una ricerca di testo
    Di ambaradam nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 08/03/17, 01:14
  3. Combo Box per menu a tendina dinamico con inserimento parziale del testo
    Di Gerardo Zuccalà nel forum Domande su Excel VBA e MACRO
    Risposte: 15
    Ultimo Messaggio: 15/06/16, 20:28
  4. Ricerca con criteri somma
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 03/08/15, 22:42
  5. Somma con criterio parziale
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 01/07/15, 09:03

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •