Risultati da 1 a 11 di 11

Discussione: Pagato non pagato.2



  1. #1
    L'avatar di kojak08
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    MASSA
    Età
    80
    Messaggi
    17
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Pagato non pagato.2

    Salve a tutti,
    sono ricorso a voi qualche settimana fà per un problema su una formula, che mi avete risolto in un batter di ciglia, ora torno sullo stesso argomento, poiché non riesco ad andare avanti.
    Spigo meglio con il File che allego.
    Grazie a tutti.

    kojak08
    File Allegati File Allegati

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1660
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Pagato non pagato.2

    ciao
    presumendo che i nomi in B, si possano ripetere anche nello stesso mese:
    in L8:
    =MATR.SOMMA.PRODOTTO(($B$8:$B$18=$B8)*(MESE($F$8:$F$18)=MESE(1&L$3))*$I$8:$I$18)

    in M8:
    =MATR.SOMMA.PRODOTTO(($B$8:$B$18=$B8)*(MESE($F$8:$F$18)=MESE(1&L$3))*$J$8:$J$18)

    poi, ambedue si trascinano a destra ed in basso.
    si potrebbe uniformare tutto in una sola formula ma si sembra una complicazione superflua.
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3
    L'avatar di kojak08
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    MASSA
    Età
    80
    Messaggi
    17
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Pagato non pagato.2

    Ciao ninai,
    Grazie, sei stato velocissimo e bravo. Ora però, ho un altro problema meglio evidenziato nel File che allego.

    Ciao kojak08
    File Allegati File Allegati

  4. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1660
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Pagato non pagato.2

    da quello che vedo non hai dimensionato i range nelle formule. Se i dati arrivano alla riga 31 (o oltre), non puoi avere nella formula i range fino alla 18.
    =MATR.SOMMA.PRODOTTO(($B$8:$B$18=$B8)*(MESE($F$8:$F$18)=MESE(1&L$3))*$I$8:$I$18)

    il 18 deve diventare 31 o quanto ti serve.
    io ti consiglio di dimensionare con una riga finale vuota e prima di usarla procedi con inserimento riga, così le formule si adeguano automaticamente. oppure trasformi tutto in tabella.
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  5. #5
    L'avatar di kojak08
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    MASSA
    Età
    80
    Messaggi
    17
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Pagato non pagato.2

    Ciao ninai,
    ho capito quanto mi hai detto e cosi ho fatto per0 ora mi si ripetono i numeri in tutte le celle a seguire.
    Vedi File. Grazie
    kojak08
    File Allegati File Allegati

  6. #6
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1660
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Pagato non pagato.2

    puoi condizionare la formula con un SE(), ad esempio se in A vi è un valore:
    =SE($A8;MATR.SOMMA.PRODOTTO(($B$8:$B$31=$B8)*(MESE($F$8:$F$31)=MESE(1&L$3))*$I$8:$I$31);0)

    Se tu credi che i nomi in B non si ripetono e pertanto non si devono sommare più valori, la formula si può semplificare, in L:

    =SE(($A8<>"")*(MESE($F8)=MESE(1&L$3));$I8;0)

    e in M:
    =SE(($A8<>"")*(MESE($F8)=MESE(1&L$3));$J8;0)
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  7. #7
    L'avatar di kojak08
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    MASSA
    Età
    80
    Messaggi
    17
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Pagato non pagato.2

    Ciao ninai,
    scusa il ritardo nel risponderti, ma non ero in casa. Per ora tutto OK. Ti ringrazio.

    kojak08

  8. #8
    L'avatar di kojak08
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    MASSA
    Età
    80
    Messaggi
    17
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Pagato non pagato.2

    Ciao ninai,
    Sono, ancora qui a romperti, ma sono imbranato e quando non riesco sono abbituato a chiedere aiuto e trovo sempre la persona giusta. Grazie.
    Ho allegato il Fille che sto facendo ed ho dei problemi in esso evidenziati, aiutami.
    File Allegati File Allegati

  9. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7131
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299

    Re: Pagato non pagato.2

    Ciao,
    vedi se va bene così.
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  10. #10
    L'avatar di kojak08
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    MASSA
    Età
    80
    Messaggi
    17
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Pagato non pagato.2

    Ciao ges,
    va benissimo, molte grazie.
    kojak08

  11. #11
    L'avatar di kojak08
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    MASSA
    Età
    80
    Messaggi
    17
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Pagato non pagato.2

    Ciao a tutti,
    sono il solito rompi, n on me ne volete.
    Il mio Pagato non pagato è in evoluzione, ma ho un grosso problema su alcune voci che sono composite ma con un unico totale, mi spiego meglio con il file.
    Aiutatemi, Grazie kojak08
    File Allegati File Allegati

Discussioni Simili

  1. [Risolto] Registra l'avvenuto pagamento di una bolletta condominiale "Pagato"
    Di Vincenzo Damiani nel forum Domande su Excel VBA e MACRO
    Risposte: 17
    Ultimo Messaggio: 29/12/16, 13:50
  2. Pagato non pagato.3
    Di kojak08 nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 26/12/16, 16:40

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •