Risultati da 1 a 9 di 9

Discussione: Calcolare le ore



  1. #1

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Como
    EtÓ
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Calcolare le ore

    Un dipendente lavora a turni, questa settimana ha svolto il seguente orario:

    Lunedý ha iniziato il turno alle 7,12 e concluso alle 12,25
    Martedý ha iniziato il turno alle 23,21 e concluso alle 12,25 di mercoledý
    Mercoledý Ŕ stato di riposo
    Giovedý ha iniziato il turno alle 6,37 e concluso alle 12,45
    Venerdý ha iniziato il turno alle 23,55 e concluso alle 0,12 di domenica (turno lungo)
    Domenica riposo

    Bisogna trovare nelle celle di destra delle formule che calcolano le ore.

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    1678
    Versione Office
    2010 PC
    Likes ricevuti
    895
    Likes dati
    184
    ciao

    potrebbe andare:
    =C2-B2+(B2>C2)

    aggiustare il dato in C2 e gestire eventuali errori per il testo con SE.ERRORE()

  3. #3
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    1678
    Versione Office
    2010 PC
    Likes ricevuti
    895
    Likes dati
    184
    correzione
    Il dato da aggiustare Ŕ quello in B2
    la formula completa diventa:
    =SE.ERRORE(C2-B2+(B2>C2);"")

  4. #4
    L'avatar di Luigi Paravan
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Arquata Scrivia
    EtÓ
    62
    Messaggi
    46
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    0
    Ciao a tutti
    =SE(B2="riposo";"";SE(B2="";"inserire ora inizio turno";SE(C2="";"inserire ora fine turno";(C2-B2+SE(B2>C2;1)))))

    mi piace (B2>C2)=VERO quindi 1
    Ultima modifica fatta da:Luigi Paravan; 12/07/15 alle 08:41

  5. #5
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao a tutti
    devo rimarcare alcune cose che non mi quadrano
    @Ges credo che la logica di questa tabella Ŕ sbagliata, perchŔ se questa persona lavora anche di sabato, dove inseriamo (entrata e uscita)? se lavora dopo la mezza notte non sarebbe meglio inserire nella stessa riga di quando ha iniziato?
    @ninai @ Luigi ho provato le vostre formule ma non mi funzionano Boh!

    Comunque questa Ŕ la mia soluzione con la funzione RESTO
    in D2 fai questa formula e copia in basso
    =SE.ERRORE(RESTO(C2-B2;1);"")

    A
    B
    C
    D
    1
    inizio turno fine turno ore effettuate
    2
    Lunedý
    7:12
    12:25
    5:13
    3
    Martedý
    23:21
    6:30
    7:09
    4
    Mercoledý riposo
    5
    Giovedý
    6:37
    12:45
    6:08
    6
    Venerdý
    23:55
    0:05
    7
    Sabato
    0:12
    0:12
    8
    Domenica riposo


    PS. Queste tabelle sono esportabili dal forum ad excel

  6. #6
    L'avatar di Luigi Paravan
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Arquata Scrivia
    EtÓ
    62
    Messaggi
    46
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    0
    nel file di ges non funziona se riscrivi gli orari di inizio e fine turno funziona Boh!

    =SE.ERRORE(C2-B2+SE(B2>C2;1);"")

  7. #7
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da Luigi Paravan Visualizza Messaggio
    nel file di ges non funziona se riscrivi gli orari di inizio e fine turno funziona Boh!

    =SE.ERRORE(C2-B2+SE(B2>C2;1);"")
    Ahhh ok e vero adesso le vostre formule funzionano, per˛ strano che bisogna riscrivere tutto...

  8. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Como
    EtÓ
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Citazione Originariamente Scritto da Gerardo ZuccalÓ Visualizza Messaggio
    ...
    .....
    @Ges credo che la logica di questa tabella Ŕ sbagliata, perchŔ se questa persona lavora anche di sabato, dove inseriamo (entrata e uscita)? se lavora dopo la mezza notte non sarebbe meglio inserire nella stessa riga di quando ha iniziato?
    ...
    .....l
    Ciao Gerardo, grazie per le tabelle esportabili io - come credo sia ormai noto a tutti - non sono nelle condizioni di inserirle.
    Per il sabato non Ŕ un errore, ho considerato ipoteticamente (nella realtÓ spero non esista una situazione del genere) che la persona inizi il turno venerdý notte (alle 23.55) e lo termini ininterrottamente domenica notte (alle 0:12) questo come avrai capito per complicare il doppio conteggio ore notturne.

    P.S. Sulle formule non so come mai non funzionano nel mio file! E' un mistero!

  9. #9
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao Gerardo, grazie per le tabelle esportabili io - come credo sia ormai noto a tutti - non sono nelle condizioni di inserirle.
    Per il sabato non Ŕ un errore, ho considerato ipoteticamente (nella realtÓ spero non esista una situazione del genere) che la persona inizi il turno venerdý notte (alle 23.55) e lo termini ininterrottamente domenica notte (alle 0:12) questo come avrai capito per complicare il doppio conteggio ore notturne.
    aaah ok allora la mia formula non funziona, bisogna aggiungere 24 ore

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    P.S. Sulle formule non so come mai non funzionano nel mio file! E' un mistero!
    Prova a guardare in qualche impostazione del tuo MAC, per˛ prima ancora prova a mandare un file di prova via e mail a qualcuno che conosci che ha PC cosi pui verificare se gli allegati non funzionano e allora credo che sarÓ un problema di impostazioni opzioni
    Ciao

Discussioni Simili

  1. Calcolare differenza a fasce
    Di Gianfranco55 nel forum Domande su Excel in generale
    Risposte: 32
    Ultimo Messaggio: 22/09/17, 18:08
  2. Calcolare i mesi da un numero
    Di mjchele nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 02/03/17, 01:14
  3. Calcolare la media su excel
    Di Alejandrina nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 11/09/16, 18:15
  4. [Risolto] Calcolare i valori consecutivi
    Di Remida nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 08/04/16, 14:40
  5. Calcolare multipli di un valore
    Di Sandler nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 09/03/16, 21:32

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •