Risultati da 1 a 13 di 13

Discussione: Accorciare formula "SE" "O" con tanti valori



  1. #1
    L'avatar di Theinvoker
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Milano
    Età
    39
    Messaggi
    110
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    3

    Accorciare formula "SE" "O" con tanti valori

    Dovrei semplificare la seguente formula,se possibile,semplicemente per accorciarla,visto che in realtà è molto più lunga e comprende più colonne ma una volta capito come fare per una colonna farò anche per le altre.

    =SE(A1=VERO;3;0)+SE(A2=VERO;3;0)+SE(A3=VERO;3;0)+SE(A4=VERO;3;0)+SE(A5=VERO;3;0)+SE(A6=VERO;3;0) ecc ecc


    Già usando O si accorcia ma non troppo
    =SE(O(A1=VERO;A2=VERO;A3=VERO;A4=VERO;A5=VERO;A6=VERO);3;0) ecc ecc

    Non si può raggruppare in modo da scrivere VERO solo una volta? tipo così (anche se così non funziona,è per farvi capire)
    =SE(quando A1 o A2 o A3 o A4 ecc =VERO;3;0)

    le varie celle restituiscono vero o falso perchè sono collegate a delle caselle di controllo.

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1687
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185

    Re: Accorciare formula "SE" "O" con tanti valori

    da quello che ho intuito, un modo:
    =3*(CONTA.SE(A1:A6;1=1)>0)
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Theinvoker
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Milano
    Età
    39
    Messaggi
    110
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    3

    Re: Accorciare formula "SE" "O" con tanti valori

    E dove dice che deve contare se nella cella c'è scritto "VERO" e non "FALSO"?
    Perchè una delle 2 cose ci sarà...non sarà mai vuota

    cmq buona idea il CONTA.SE. Non ci avevo pensato
    Basta dirgli di contare i VERO

  5. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1687
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185

    Re: Accorciare formula "SE" "O" con tanti valori

    puoi usare anche:
    =SE(CONTA.SE(A1:A6;1=1);3;0)


    1=1, secondo te è VERO o FALSO???

    mi parlavi di brevità

    1=1 sono 3 caratteri

    "VERO", sono 6 caratteri
    un bel risparmio !!!:25:
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  6. I seguenti utenti hanno dato un "Like"


  7. #5
    L'avatar di Theinvoker
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Milano
    Età
    39
    Messaggi
    110
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    3

    Re: Accorciare formula "SE" "O" con tanti valori

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    puoi usare anche:
    =SE(CONTA.SE(A1:A6;1=1);3;0)


    1=1, secondo te è VERO o FALSO???

    non so,le poche volte che ho usato il conta.se ho specificato proprio la parola (che era sempre per contare i "SI" o i "NO")

    Cmq provata e funziona,adesso la modifico io in base a quello che mi serve precisamente.
    Grazie

  8. #6
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1687
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185

    Re: Accorciare formula "SE" "O" con tanti valori

    pure io, prima che scossa mi "strigliasse" in continuazione, facevo formulone ridondanti che sembravano "mostri alieni" . Fu così che mi venne il pallino della sintesi.:288:
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  9. #7
    L'avatar di Theinvoker
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Milano
    Età
    39
    Messaggi
    110
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    3

    Re: Accorciare formula "SE" "O" con tanti valori

    Alt!!! non funziona! Ma forse è colpa mia che ho spiegato male con "O"

    =SE(CONTA.SE(I6:I10;1=1);2;0)
    io voglio che mettendo VERO in I6 il risultato sia 2,e ci siamo,però voglio che se metto VERO anche in I8 il risultato sia 4,insomma che aggiunga 2 ogni volta che metto vero ina cella di quell'intervallo

    Ho modificato alla "mia" maniera,come ti dicevo prima,specificando la parola

    =2*CONTA.SE(I6:I11;"VERO")

  10. #8
    L'avatar di Theinvoker
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Milano
    Età
    39
    Messaggi
    110
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    3

    Re: Accorciare formula "SE" "O" con tanti valori

    Ok la formula parziale è

    =2*CONTA.SE(I6:I9;"VERO")+3*CONTA.SE(J6:J9;"VERO")+6*CONTA.SE(K6:K9;"VERO")+9*CONTA.SE(L6:L9;"VERO")+12*CONTA.SE(M6:M9;"VERO")

    Dove ogni colonna moltiplica per un valore diverso
    In realtà però ci sarebbero altre 2 colonne che moltiplicano per gli stessi valori,sempre sulle stesse righe...ad esempio da O6 ad O9
    è possibile aggiungere 06:09 già nella prima moltiplicazione per 2 senza dover risscrivere

    +2*CONTA.SE(I6:I9;"VERO")

  11. #9

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4027
    Versione Office
    2013
    Likes ricevuti
    1229
    Likes dati
    925

    Re: Accorciare formula "SE" "O" con tanti valori

    Citazione Originariamente Scritto da Theinvoker Visualizza Messaggio
    Alt!!! non funziona! Ma forse è colpa mia che ho spiegato male con "O"

    =SE(CONTA.SE(I6:I10;1=1);2;0)
    io voglio che mettendo VERO in I6 il risultato sia 2,e ci siamo,però voglio che se metto VERO anche in I8 il risultato sia 4,insomma che aggiunga 2 ogni volta che metto vero ina cella di quell'intervallo
    Ciao a tutti,
    non potresti modificarla semplicemente così:

    =SE(CONTA.SE(I6:I10;1=1);2*CONTA.SE(I6:I10;1=1);0)

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  12. #10
    L'avatar di Theinvoker
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Milano
    Età
    39
    Messaggi
    110
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    3

    Re: Accorciare formula "SE" "O" con tanti valori

    beh è più corta come ho fatto io,cmq quello è un problema superato....leggi il messaggio successivo!

  13. #11

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4027
    Versione Office
    2013
    Likes ricevuti
    1229
    Likes dati
    925

    Re: Accorciare formula "SE" "O" con tanti valori

    Citazione Originariamente Scritto da Theinvoker Visualizza Messaggio
    beh è più corta come ho fatto io,cmq quello è un problema superato....leggi il messaggio successivo!
    Si ho letto...
    ma perchè non alleghi un file che rappresenti la situazione che hai realmente invece di andare a tentoni ?

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  14. #12
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1687
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185

    Re: Accorciare formula "SE" "O" con tanti valori

    un'idea potrebbe essere:
    =MATR.SOMMA.PRODOTTO(((I6:O9=(1=1))*{2\3\6\9\12\2\2}))

    NB
    con il 2007, devi cambiare il segno \ ,con non ricordo se ; oppure .
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  15. #13
    L'avatar di Theinvoker
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Milano
    Età
    39
    Messaggi
    110
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    3

    Re: Accorciare formula "SE" "O" con tanti valori

    Citazione Originariamente Scritto da cromagno Visualizza Messaggio
    Si ho letto...
    ma perchè non alleghi un file che rappresenti la situazione che hai realmente invece di andare a tentoni ?
    Non tutte le caselle sono già collegate correttamente alla cella giusta perchè le ho copiate....

    Cmq B4:B7 , H4:H7 , N4:N7 aggiungono 2
    C4:C7 , I4:I7 , I4:I7 aggiungono 3

    ecc ecc
    File Allegati File Allegati

Discussioni Simili

  1. [Risolto] Ordinare con la funzione "piccolo"..ma "portandosi dietro" anche altri dati affiancati
    Di mauri73 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 05/02/17, 14:57
  2. [Risolto] Come leggere la seguente formula =SE.ERRORE(INDIRETTO("'"&A1&"'!K1";1);""))
    Di sitolofi nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 20/12/16, 14:54
  3. >Come estrappolare la somma "automatica" di un DB con funzione "FILTRO"<
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 11/06/16, 11:44
  4. problema con formula se con "maggiore" e "minore" > e <
    Di fireman80 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 09/05/16, 21:36
  5. Collegamento "foglio elenco" e "fogli singoli"
    Di Maurizio76 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 23/11/15, 10:14

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •