Risultati da 1 a 18 di 18

Discussione: unire il testo presente su celle differenti



  1. #1
    L'avatar di vitangelo
    Clicca e Apri
    Data Registrazione
    Sep 2015
    LocalitÓ
    Bari
    EtÓ
    38
    Messaggi
    78
    Versione Office
    2010
    Likes ricevuti
    1

    unire il testo presente su celle differenti

    Ciao a Tutti

    ho un file dove ho 2 colone in una c'Ŕ un numero (avvolte ripetuto) nella cella affianco Ŕ presente un testo. Vorrei unire il testo presente nelle 2 celle che hanno il numero uguale.

    Ex. ho la colonna A che contiene il numero colonna B il testo. il mio scopo Ŕ quello di unire il testo presente nelle celle della colonnaB quando il numero presente in colonna A Ŕ uguale.

    Grazie del vostro supporto
    V

  2. #2
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    LocalitÓ
    Reggio Calabria
    EtÓ
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: unire il testo presente su celle differenti

    Ciao Vitangelo, se ho capito bene, nell'ipotesi che in A1:A10 hai i numeri e in B1:B10 i testi, copia e incolla la seguente:

    In C1:
    =SE.ERRORE(INDICE($A$1:$A$10&" "&$B$1:$B$10;AGGREGA(15;6;(RIF.RIGA($A$1:$A$10)-RIF.RIGA($A$1)+1)/(FREQUENZA($A$1:$A$10;$A$1:$A$10)>1);RIGHE($A$1:$A1)));"")

    e tiri gi¨.
    Allego il file di prova, fa sapere ciao.
    File Allegati File Allegati

  3. I seguenti 3 utenti hanno dato un "Like" a pkrome59 per questo post:


  4. #3
    L'avatar di vitangelo
    Clicca e Apri
    Data Registrazione
    Sep 2015
    LocalitÓ
    Bari
    EtÓ
    38
    Messaggi
    78
    Versione Office
    2010
    Likes ricevuti
    1

    Re: unire il testo presente su celle differenti

    Ciao Pkrome59

    ti allego esempio, quello che devo unire Ŕ il testo presente nella colonna B in base al numero presente in colonna A.

    come allegato,

    Grazie
    Vitangelo
    File Allegati File Allegati

  5. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Sardegna
    EtÓ
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1229
    Likes dati
    923

    Re: unire il testo presente su celle differenti

    Ciao a tutti,

    @Vitangelo
    con le formule la vedo un p˛ dura (i concatenamenti di testo multipli non sono ben visti dalle formule)....

    Con il VBA potresti usare un codice del genere (da migliorare, evitando il doppio ciclo, in caso di database di grosse dimensioni):

    Codice: 
    Sub Unisci()
    Dim uRiga As Long, i As Long, j As Long, Testo As String
    Dim Numero As Double
    
    
    uRiga = Range("A1").End(xlDown).Row
    For i = 2 To uRiga
        Numero = Cells(i, 1).Value
        Testo = ""
        For j = 2 To uRiga
            If Cells(j, 1).Value = Numero Then
                Testo = Testo & Cells(j, 2).Value & "; "
            End If
        Next j
        Cells(i, 3).Value = Left(Testo, Len(Testo) - 2)
    Next i
    Range("B2:B" & uRiga).WrapText = True
    End Sub
    riallego il file...
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno pu˛ immaginare."

  6. I seguenti 4 utenti hanno dato un "Like" a cromagno per questo post:


  7. #5
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204

    Re: unire il testo presente su celle differenti

    Ciao a tutti

    in B2 ed in basso

    Codice: 
    =SE(A2;INDICE($B$1:$B$100;AGGREGA(15;6;RIF.RIGA($1:$100)/($A$1:$A$100=A2);1))&SE.ERRORE("; "&INDICE($B$1:$B$100;AGGREGA(15;6;RIF.RIGA($1:$100)/($A$1:$A$100=A2);2));"");"")
    Spero sia d'aiuto

    Ciao Tore: non avevo visto la tua risposta.

  8. I seguenti 6 utenti hanno dato un "Like" a Canapone per questo post:


  9. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Sardegna
    EtÓ
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1229
    Likes dati
    923

    Re: unire il testo presente su celle differenti

    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    Ciao a tutti.....
    Ciao Stefano,
    nessun problema...Ŕ sempre un piacere essere smentito :246:

    anche se...sempre se non sbaglio, la formula va bene per un massimo di due nomi con lo stesso numero, ma forse basta anche cosý :43:
    Ultima modifica fatta da:Canapone; 26/06/17 alle 12:43

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno pu˛ immaginare."

  10. #7
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: unire il testo presente su celle differenti

    Ciao Ragazzi
    giusto per condividere una formula con un approccio un po diverso
    con excel ci sono sempre pi¨ soluzioni



    In C2 CTRL+SHIFT+ENTER copiare in basso
    =SE.ERRORE(INDICE($A$2:$A$11;PICCOLO(SE(FREQUENZA($A$2:$A$11;$A$2:$A$11);RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1);RIGHE($C$2:C2)));"")

    in D2 CTRL+SHIFT+ENTER copiare in basso e a destra

    =SE.ERRORE(INDICE($B$2:$B$11;PICCOLO(SE($A$2:$A$11=$C2;RIF.RIGA($B$2:$B$11)-RIF.RIGA($B$2)+1);COLONNE($D2:D2)));"")


    Se Ŕ necessario trasformo queste formule con l'AGGREGA
    File Allegati File Allegati

  11. I seguenti 4 utenti hanno dato un "Like" a Gerardo ZuccalÓ per questo post:


  12. #8
    L'avatar di vitangelo
    Clicca e Apri
    Data Registrazione
    Sep 2015
    LocalitÓ
    Bari
    EtÓ
    38
    Messaggi
    78
    Versione Office
    2010
    Likes ricevuti
    1

    Re: unire il testo presente su celle differenti

    Ciao a tutti e grazie x le molteplici soluzioni. Ho avuto modo di provarle e la macro consigliata da cromagno mi sembra quella + adatta.

    Il file che andr˛ a creare, unirÓ + testi presenti in colonna B che abbiano lo stesso numero in A. Ed attraverso una 2░ macro canceller˛ i doppioni.

    Grazie 1000 dell'aiuto

  13. #9
    L'avatar di vitangelo
    Clicca e Apri
    Data Registrazione
    Sep 2015
    LocalitÓ
    Bari
    EtÓ
    38
    Messaggi
    78
    Versione Office
    2010
    Likes ricevuti
    1

    Re: unire il testo presente su celle differenti

    @cromagno, ho adattato la tua macro al mio file, dove in A ci sono i numeri, ed in E Ŕ presente il testo, io devo far uscire in F l'unione.

    Ho modificato la macro, ma le celle 2-3-4 del file non si popolano...sicuramente ho sbagliato io qualcosa, riesci ad aiutarmi?

    Codice HTML: 
    Sub Unisci()
    Dim uRiga As Long, i As Long, j As Long, Testo As String
    Dim Numero As Double
    
    
    
    
    uRiga = Range("A1").End(xlDown).Row
    For i = 5 To uRiga
        Numero = Cells(i, 1).Value
        Testo = ""
        For j = 5 To uRiga
            If Cells(j, 1).Value = Numero Then
                Testo = Testo & Cells(j, 5).Value & "; "
            End If
        Next j
        Cells(i, 6).Value = Left(Testo, Len(Testo) - 2)
    Next i
    Range("E2:E" & uRiga).WrapText = True
    End Sub

  14. #10
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    LocalitÓ
    Reggio Calabria
    EtÓ
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: unire il testo presente su celle differenti

    Ciao a tutti e buona domenica, tenuto conto che la soluzione pi¨ appropriata sembra essere l'uso del VBA che mi Ŕ ostico, tanto per partecipare propongo una formula che funziona fino a 5 numeri uguali, facilmente implementabile, ma impresentabile sotto l'aspetto della lunghezza.
    Il lato positivo e che elimina da subito i doppioni.

    In D2:
    =SE.ERRORE(INDICE($B$2:$B$11;AGGREGA(15;6;(RIF.RIGA($B$2:$B$11)-RIF.RIGA($B$2)+1)/($A$2:$A$11=SE.ERRORE(INDICE($A$2:$A$11;AGGREGA(15;6;(RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1)/(FREQUENZA($A$2:$A$11;$A$2:$A$11)>0);RIGHE($C$2:C2)));""));1));"")&SE.ERRORE("; "&INDICE($B$2:$B$11;AGGREGA(15;6;(RIF.RIGA($B$2:$B$11)-RIF.RIGA($B$2)+1)/($A$2:$A$11=SE.ERRORE(INDICE($A$2:$A$11;AGGREGA(15;6;(RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1)/(FREQUENZA($A$2:$A$11;$A$2:$A$11)>0);RIGHE($C$2:C2)));""));2));"")&SE.ERRORE("; "&INDICE($B$2:$B$11;AGGREGA(15;6;(RIF.RIGA($B$2:$B$11)-RIF.RIGA($B$2)+1)/($A$2:$A$11=SE.ERRORE(INDICE($A$2:$A$11;AGGREGA(15;6;(RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1)/(FREQUENZA($A$2:$A$11;$A$2:$A$11)>0);RIGHE($C$2:C2)));""));3));"")&SE.ERRORE("; "&INDICE($B$2:$B$11;AGGREGA(15;6;(RIF.RIGA($B$2:$B$11)-RIF.RIGA($B$2)+1)/($A$2:$A$11=SE.ERRORE(INDICE($A$2:$A$11;AGGREGA(15;6;(RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1)/(FREQUENZA($A$2:$A$11;$A$2:$A$11)>0);RIGHE($C$2:C2)));""));4));"")&SE.ERRORE("; "&INDICE($B$2:$B$11;AGGREGA(15;6;(RIF.RIGA($B$2:$B$11)-RIF.RIGA($B$2)+1)/($A$2:$A$11=SE.ERRORE(INDICE($A$2:$A$11;AGGREGA(15;6;(RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1)/(FREQUENZA($A$2:$A$11;$A$2:$A$11)>0);RIGHE($C$2:C2)));""));5));"")

    da tirare gi¨ alla bisogna.
    Allego il file di prova.
    File Allegati File Allegati

  15. I seguenti 4 utenti hanno dato un "Like" a pkrome59 per questo post:


  16. #11
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: unire il testo presente su celle differenti

    PkRome59 Posso commentare con una faccina? :252:

  17. I seguenti utenti hanno dato un "Like"


  18. #12

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Sardegna
    EtÓ
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1229
    Likes dati
    923

    Re: unire il testo presente su celle differenti

    Citazione Originariamente Scritto da vitangelo Visualizza Messaggio
    @cromagno, ho adattato la tua macro al mio file, dove in A ci sono i numeri, ed in E Ŕ presente il testo, io devo far uscire in F l'unione.

    Ho modificato la macro, ma le celle 2-3-4 del file non si popolano...sicuramente ho sbagliato io qualcosa, riesci ad aiutarmi?

    Codice HTML: 
    Sub Unisci()
    Dim uRiga As Long, i As Long, j As Long, Testo As String
    Dim Numero As Double
    
    uRiga = Range("A1").End(xlDown).Row
    For i = 5 To uRiga
        Numero = Cells(i, 1).Value
        Testo = ""
        For j = 5 To uRiga
            If Cells(j, 1).Value = Numero Then
                Testo = Testo & Cells(j, 5).Value & "; "
            End If
        Next j
        Cells(i, 6).Value = Left(Testo, Len(Testo) - 2)
    Next i
    Range("E2:E" & uRiga).WrapText = True
    End Sub
    Ciao a tutti,

    @vitangelo
    Non ti compilava le celle 2,3,4 perchŔ il ciclo "For...Next" iniziava da 5 (quinta riga) invece che da 2.
    Inoltre, l'ultima riga:

    Codice: 
    Range("E2:E" & uRiga).WrapText = True
    Ŕ stata una mia dimenticanza nel codice precedente...
    "WrapText" significa "Testo a capo" e lo devo impostare a "VERO" nella colonna dove eseguo l'unione (in previsione di molti nomi nella stessa cella), quindi la colonna in questione Ŕ la "F" :

    Codice: 
    Range("F2:F" & uRiga).WrapText = True
    Visto che vuoi solo i valori univoci, ho aggiunto una "Collection" nel codice:

    Codice: 
    Sub Unisci()
    Dim uRiga As Long, i As Long, j As Long, Testo As String
    Dim Numero As Double, Unici As Collection
    
    
    Set Unici = New Collection
    uRiga = Range("A1").End(xlDown).Row
    
    
    On Error Resume Next
    For i = 2 To uRiga
        Unici.Add Range("A" & i).Value, CStr(Range("A" & i).Value)
    Next i
    On Error GoTo 0
    
    
    For i = 1 To Unici.Count
        Numero = Unici(i)
        Testo = ""
        For j = 2 To uRiga
            If Cells(j, 1).Value = Numero Then
                Testo = Testo & Cells(j, 5).Value & "; "
            End If
        Next j
        Cells(i + 1, 6).Value = Left(Testo, Len(Testo) - 2)
    Next i
    
    
    Range("F2:F" & uRiga).WrapText = True
    Set Unici = Nothing
    End Sub
    Prova il file allegato....

    P.S.
    Se non dovessi riuscire ad adattare il codice, allega il file per poter vederne la struttura reale.
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno pu˛ immaginare."

  19. I seguenti utenti hanno dato un "Like"


  20. #13

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Como
    EtÓ
    53
    Messaggi
    7165
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1304

    Re: unire il testo presente su celle differenti

    Citazione Originariamente Scritto da pkrome59 Visualizza Messaggio
    Ciao a tutti e buona domenica, tenuto conto che la soluzione pi¨ appropriata sembra essere l'uso del VBA che mi Ŕ ostico, tanto per partecipare propongo una formula che funziona fino a 5 numeri uguali, facilmente implementabile, ma impresentabile sotto l'aspetto della lunghezza.
    Il lato positivo e che elimina da subito i doppioni.

    In D2:
    =SE.ERRORE(INDICE($B$2:$B$11;AGGREGA(15;6;(RIF.RIGA($B$2:$B$11)-RIF.RIGA($B$2)+1)/($A$2:$A$11=SE.ERRORE(INDICE($A$2:$A$11;AGGREGA(15;6;(RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1)/(FREQUENZA($A$2:$A$11;$A$2:$A$11)>0);RIGHE($C$2:C2)));""));1));"")&SE.ERRORE("; "&INDICE($B$2:$B$11;AGGREGA(15;6;(RIF.RIGA($B$2:$B$11)-RIF.RIGA($B$2)+1)/($A$2:$A$11=SE.ERRORE(INDICE($A$2:$A$11;AGGREGA(15;6;(RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1)/(FREQUENZA($A$2:$A$11;$A$2:$A$11)>0);RIGHE($C$2:C2)));""));2));"")&SE.ERRORE("; "&INDICE($B$2:$B$11;AGGREGA(15;6;(RIF.RIGA($B$2:$B$11)-RIF.RIGA($B$2)+1)/($A$2:$A$11=SE.ERRORE(INDICE($A$2:$A$11;AGGREGA(15;6;(RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1)/(FREQUENZA($A$2:$A$11;$A$2:$A$11)>0);RIGHE($C$2:C2)));""));3));"")&SE.ERRORE("; "&INDICE($B$2:$B$11;AGGREGA(15;6;(RIF.RIGA($B$2:$B$11)-RIF.RIGA($B$2)+1)/($A$2:$A$11=SE.ERRORE(INDICE($A$2:$A$11;AGGREGA(15;6;(RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1)/(FREQUENZA($A$2:$A$11;$A$2:$A$11)>0);RIGHE($C$2:C2)));""));4));"")&SE.ERRORE("; "&INDICE($B$2:$B$11;AGGREGA(15;6;(RIF.RIGA($B$2:$B$11)-RIF.RIGA($B$2)+1)/($A$2:$A$11=SE.ERRORE(INDICE($A$2:$A$11;AGGREGA(15;6;(RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1)/(FREQUENZA($A$2:$A$11;$A$2:$A$11)>0);RIGHE($C$2:C2)));""));5));"")

    da tirare gi¨ alla bisogna.
    Allego il file di prova.
    Grande pkrome!!! :255:
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se pu˛ sembrare improbabile, non pu˛ che essere quella giusta!

  21. #14
    L'avatar di vitangelo
    Clicca e Apri
    Data Registrazione
    Sep 2015
    LocalitÓ
    Bari
    EtÓ
    38
    Messaggi
    78
    Versione Office
    2010
    Likes ricevuti
    1

    Re: unire il testo presente su celle differenti

    Citazione Originariamente Scritto da pkrome59 Visualizza Messaggio
    Ciao a tutti e buona domenica,....

    Spettacolo :171:
    Ultima modifica fatta da:Canapone; 26/06/17 alle 12:42

  22. #15
    L'avatar di vitangelo
    Clicca e Apri
    Data Registrazione
    Sep 2015
    LocalitÓ
    Bari
    EtÓ
    38
    Messaggi
    78
    Versione Office
    2010
    Likes ricevuti
    1

    Re: unire il testo presente su celle differenti

    Citazione Originariamente Scritto da cromagno Visualizza Messaggio
    Visto che vuoi solo i valori univoci...
    Preferisco la 1 versione, perchŔ con questa seconda che hai creato i doppi mi rimangono nel file. Mentre il mio scopo Ŕ quello di unire il testo presente in colonna E se i numeri in colonna A sono uguali e dopo cancellare le righe doppie.

    Adesso funziona alla grandissima :57:

    adesso lo provo e nei prossimi giorni vi faccio sapere.
    Ultima modifica fatta da:Canapone; 26/06/17 alle 12:43

  23. #16
    L'avatar di tk71
    Clicca e Apri
    Data Registrazione
    Dec 2015
    LocalitÓ
    Svizzera
    Messaggi
    108
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    59

    Re: unire il testo presente su celle differenti

    Ciao Vitangelo, e in particolare un ciao a tutti i GURU....

    Per me e`la prima risposta che faccio!
    Spero di aver capito giusto e di aver dato risposta giusta. All`interno del FILE.

    Vorrei vostro commento.

    Un saluto a tutti

    TK 71 :251:
    File Allegati File Allegati

  24. #17
    L'avatar di vitangelo
    Clicca e Apri
    Data Registrazione
    Sep 2015
    LocalitÓ
    Bari
    EtÓ
    38
    Messaggi
    78
    Versione Office
    2010
    Likes ricevuti
    1

    Re: unire il testo presente su celle differenti

    Ciao TK71 grazie della risposta,
    ma non Ŕ quello che volevo ottenere, a me interessa unire le celle presenti in colonna B se il numero presente in colonna A Ŕ uguale.

  25. #18

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Sardegna
    EtÓ
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1229
    Likes dati
    923

    Re: unire il testo presente su celle differenti

    Ciao a tutti,

    @vitangelo
    se hai risolto il problema, segna questo thread come "RISOLTO".
    Vai sul men¨ "Strumenti Discussione" (all'inizio del thread) e scegli la voce "Segna questa discussione come Risolta...".

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno pu˛ immaginare."

Discussioni Simili

  1. Unire cella importata da Excell e disporre testo in centro
    Di Paolerrai nel forum Domande sul Microsoft Word
    Risposte: 36
    Ultimo Messaggio: 18/12/16, 16:56
  2. Copiare cella concatenata se presente testo specifico in combobox
    Di G.Bove nel forum Domande su Excel VBA e MACRO
    Risposte: 12
    Ultimo Messaggio: 10/08/16, 10:10
  3. Copiare testo solo se non presente testo specifico
    Di G.Bove nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 01/06/16, 23:44
  4. Risposte: 15
    Ultimo Messaggio: 21/05/16, 17:52
  5. Funzione: se testo presente in un intervallo allora..
    Di serra890 nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 21/12/15, 10:48

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •