Risultati da 1 a 7 di 7

Discussione: Calcolo ore con criterio



  1. #1
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1289
    Versione Office
    Excel 2016
    Likes ricevuti
    25
    Likes dati
    19

    Calcolo ore con criterio

    Di nuovo ciao a tutti gli amici del forum.....vorrei risolvere un problema con un calcolo ore in base a un criterio, mi spiego meglio:
    Nelle celle A7:G7 Colorate di rosa ho gia un risultato di 01:00 che va bene cosi.

    Vorrei però che in base al criterio B10 (in questo caso specifico di 04:00) mi sospendesse la formula da A7 a G7 e che il valore di 01:00 E7-E7-G7 rimanesse vuoto

    spero sia stato abbastanza chiaro:::::
    Excel 2013
    Row\Col
    A
    B
    C
    D
    E
    F
    G
    1
    05:51
    05:56
    05:57
    05:56
    05:59
    05:57
    05:51
    2
    13:02
    13:30
    13:34
    13:30
    13:31
    13:34
    13:00
    3
    13:50
    13:50
    13:58
    13:50
    13:49
    13:58
    14:25
    4
    17:31
    17:01
    17:00
    17:01
    17:00
    17:00
    17:00
    5
    10:52
    10:45
    10:39
    10:45
    10:43
    10:39
    09:44
    6
    08:00
    08:00
    08:00
    08:00
    08:00
    08:00
    08:00
    7
    01:00
    01:00
    01:00
    01:00
    8
    9
    10
    Criterio
    04:00
    Sheet: Foglio2

    In questo momento le celle E7-F7-G7 sono vuote perche non ce copiata la formula

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342
    Ciao prova a fare questa formula in A7 e trascina verso destra

    =SE(COLONNE($A$7:A7)>$B$10*24;"";1/24)
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  3. #3
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1289
    Versione Office
    Excel 2016
    Likes ricevuti
    25
    Likes dati
    19
    Grazie come sempre funziona alla perfezione

    :285:

  4. #4
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1289
    Versione Office
    Excel 2016
    Likes ricevuti
    25
    Likes dati
    19
    ci sarebbe da fare una piccola modifica Gerardo perche come vedi dall allegato mi conta anche le celle vuote....


    Excel 2013
    Row\Col
    A
    B
    C
    D
    E
    F
    G
    1
    05:51
    05:56
    05:57
    05:56
    05:59
    05:57
    05:51
    2
    13:02
    13:30
    13:34
    13:30
    13:31
    13:34
    13:00
    3
    13:50
    13:50
    13:58
    13:50
    13:49
    13:58
    14:25
    4
    17:31
    17:01
    17:01
    17:00
    17:00
    17:00
    5
    10:52
    10:45
    10:45
    10:43
    10:39
    09:44
    6
    08:00
    08:00
    08:00
    08:00
    08:00
    08:00
    7
    01:00
    01:00
    01:00
    01:00
    8
    9
    10
    Criterio
    05:00
    Sheet: Foglio2

  5. #5
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    2142
    Versione Office
    2010 PC
    Likes ricevuti
    1180
    Likes dati
    239
    sostituisci:
    COLONNE($A$7:A7)
    con conta.valori
    ($A$7:A7) oppure conta.numeri(...)

    =SE(conta.valori($A$7:A7)>$B$10*24;"";1/24)

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342
    Citazione Originariamente Scritto da nick0573 Visualizza Messaggio
    ci sarebbe da fare una piccola modifica Gerardo perche come vedi dall allegato mi conta anche le celle vuote...
    Non credo che sia possibile con le formule, forse con il VBA, perche la parte che hai cancellato è parte di una formula
    e di conseguenza credo che tu abbia bisogno ti tanti uno (1) quanti ce ne sono scritti in B10 (criterio) e che se ne elimini uno della riga 7 automaticamente te ne da un'altro...
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  7. #7
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1289
    Versione Office
    Excel 2016
    Likes ricevuti
    25
    Likes dati
    19
    Penso tu abbia ragione perche infatti non funziona bene la formula


    Grazie

Discussioni Simili

  1. Ricerca con criterio
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 24/06/16, 11:26
  2. Criterio data
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 20/04/16, 14:49
  3. criterio variabile per una espressione
    Di Stefano nel forum Domande su Microsoft Access
    Risposte: 7
    Ultimo Messaggio: 09/02/16, 16:48
  4. [Risolto] criterio per query
    Di Stefano nel forum Domande su Microsoft Access
    Risposte: 5
    Ultimo Messaggio: 22/11/15, 22:32
  5. Conta su più Fogli con un criterio
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 18/09/15, 07:17

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •