Risultati da 1 a 9 di 9

Discussione: estrarre dati con più condizioni



  1. #1
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    estrarre dati con più condizioni

    Ciao di nuovo a tutti glia amici del forum

    ho questa formula che mi estrae i dati correttamente:
    =SE.ERRORE(INDICE(A$22:A$500;AGGREGA(15;6;(RIF.RIGA($A22:$A500)-RIF.RIGA($A$22)+1)/($A22:$A500=$H$16);RIGHE(A$22:A22)));"")

    vorrei pero estrarre dati da più riferimenti e ho modificato la formula in questa maniera:
    =SE.ERRORE(INDICE(A$22:A$500;AGGREGA(15;6;(RIF.RIGA($A22:$A500)-RIF.RIGA($A$22)+1)/(($A22:$A500=$H$16)*($A22:$A500=$F$16));RIGHE(A$22:A22)));"")
    ma non funziona

    dove sbaglio?


    La formula si trova in G22

    Grazie in anticipo
    File Allegati File Allegati
    windows 10
    Excel 2016

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7166
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2066
    Likes dati
    1305

    Re: estrarre dati con più condizioni

    Ciao l'errore è proprio nella tua parte in rosso.
    Stai chiedendo alla formula di estrarti i dati in base a due condizioni presenti nella stessa colonna (=H16 e = F16) ma nella stessa colonna ($A22:$A500) per ogni cella ci può essere solo la prima o la seconda condizione.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Re: estrarre dati con più condizioni

    Ciao Ges e grazie per la spiegazione

    qual'è alternativa?

    Vorrei elencare nella stessa tabella tutti gli eventi potendo scegliere condizioni da più menu a tendina..........
    windows 10
    Excel 2016

  4. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1689
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185

    Re: estrarre dati con più condizioni

    Citazione Originariamente Scritto da nick0573 Visualizza Messaggio

    qual'è alternativa?
    se ho capito bene, vorresti estrarre i dati che siano conformi ad uno O all'altro criterio. Moltiplicando hai esperesso l'operatore logico E, se ti serve l'operatore O, devi addizionare.
    pertanto, :
    (($A22:$A500=$H$16)+($A22:$A500=$F$16))
    se uno dei due e vero ( e solo uno dei due può esserlo), la divisione non darà errore e bla bla bla
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  5. #5
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Re: estrarre dati con più condizioni

    Grazie ninai
    per quanto riguarda estrazione del file e giusto era il risultato che volevo però se nel menu a tendina (cioè il criterio lo cancello lui mi restituisce tutti i dati)

    io invece non vorrei niente se non scelgo il criterio

    proverò a modificare quest ultima parte
    windows 10
    Excel 2016

  6. #6
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Re: estrarre dati con più condizioni

    Grazie ges e ninai ho risolto il tutto cosi..........

    =SE(E($F$16="";$H$16="");"";SE.ERRORE(INDICE(A$22:A$500;AGGREGA(15;6;(RIF.RIGA($A22:$A500)-RIF.RIGA($A$22)+1)/(($A22:$A500=$H$16)+($A22:$A500=$F$16));RIGHE(A$22:A22)));""))
    windows 10
    Excel 2016

  7. #7
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Re: estrarre dati con più condizioni

    Scusate ho cantato vittoria troppo presto con due condizioni funziona tutto bene, però con tre non è perfetta, cioe........

    con questa formula:

    =SE(E($F$16="";$H$16="";$D$16="");"";SE.ERRORE(INDICE(A$22:A$500;AGGREGA(15;6;(RIF.RIGA($A22:$A500)-RIF.RIGA($A$22)+1)/(($A22:$A500=$H$16)+($A22:$A500=$F$16)+($A22:$A500=$D$16));RIGHE(A$22:A22)));""))

    se scelgo di visualizzare due o tre condizioni lavora bene la formula ma se scelgo una sola condizione mi dà tutti gli eventi e non è corretto
    File Allegati File Allegati
    windows 10
    Excel 2016

  8. #8
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1689
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185

    Re: estrarre dati con più condizioni

    ciao
    secondo me i problemi sono:
    i riferimenti assoluti nei range non sono ben attribuiti
    avendo più criteri, per evitare "divisioni improprie" meglio rendere la somma vincolata a >0

    Inoltre, la parte che riguarda il SE() si può evitare.
    prova con:
    =SE.ERRORE(INDICE(A$22:A$500;AGGREGA(15;6;(RIF.RIGA($A$22:$A$500)-RIF.RIGA($A$22)+1)/((($A$22:$A$500=$H$16)+($A$22:$A$500=$F$16)+($A$22:$A$500=$D$16))>0);RIGHE(A$22:A22)));"")
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  9. #9
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Re: estrarre dati con più condizioni

    Già fatta la verifica e funziona come deve
    grande ninai

    è perfetta............:28:
    windows 10
    Excel 2016

Discussioni Simili

  1. Estrarre dati con più condizioni
    Di Stavros nel forum Domande su Excel in generale
    Risposte: 21
    Ultimo Messaggio: 03/07/17, 23:32
  2. estrarre elementi su più condizioni
    Di pipp333 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 03/09/16, 15:33
  3. Riportare dati con condizioni multiple
    Di G.Bove nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 19/07/16, 16:25
  4. Estrarre dati con piu condizioni
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 01/07/16, 10:30
  5. Inserire dati su più fogli con condizioni
    Di ges nel forum Domande su Excel VBA e MACRO
    Risposte: 48
    Ultimo Messaggio: 24/11/15, 14:19

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •