Risultati da 1 a 11 di 11

Discussione: Problema nel sommare don DATA.DIFF



  1. #1
    L'avatar di alessioje
    Clicca e Apri
    Data Registrazione
    Apr 2016
    LocalitÓ
    roma
    EtÓ
    37
    Messaggi
    22
    Versione Office
    Excel 2007,
    Likes ricevuti
    0
    Likes dati
    0

    Problema nel sommare don DATA.DIFF

    Salve ragazzi, uso spesso la funzione data.diff per ricavare i giorni compresi tra due date.
    Ora mi trovo a dover sommare questi giorni e fin qui tutto ok usando =DATA.DIFF("A1";"B1";"D")+("C1";"D1";"D")ecc..
    Il problema nasce quando incontro celle vuote che mi restituisce errore mentre io vorrei che fossero conteggiate come un semplice 0. Se c'Ŕ bisogno potrei allegare il mio file esempio. grazie della Vs disponibilitÓ:)

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Problema nel sommare don DATA.DIFF

    per fare la differenza in giorni, basta la differenza fra le date. Se pubblichi un esempio ne usciamo prima. volendo fare un esempio al buio:
    =MATR.SOMMA.PRODOTTO(--((A1:E1)-(B1:F1)))
    o qualcosa di simile

    questa Ŕ pi¨ promettente:
    =MATR.SOMMA.PRODOTTO(((B1:F1)*VAL.PARI(RIF.COLONNA(B1:F1))-(A1:E1)*VAL.DISPARI(RIF.COLONNA(A1:E1))))
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed Ŕ un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3
    L'avatar di alessioje
    Clicca e Apri
    Data Registrazione
    Apr 2016
    LocalitÓ
    roma
    EtÓ
    37
    Messaggi
    22
    Versione Office
    Excel 2007,
    Likes ricevuti
    0
    Likes dati
    0

    Re: Problema nel sommare don DATA.DIFF

    ho creato un file prova.. spero sia chiaro.
    il mio errore non voluto Ŕ quello evidenziato in giallo!
    File Allegati File Allegati

  4. #4
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Problema nel sommare don DATA.DIFF

    Ciao Nel frattempo che ninai tira fuori qualcosa da cilindro magico, io do libero sfogo alla mia soluzione

    In H2 metti questa formula e tirala in basso:

    EDIT

    =SOMMA(DATA.DIFF(A2-1;B2;"D");SE.ERRORE(DATA.DIFF(C2-1;D2;"D");0);SE.ERRORE(DATA.DIFF(E2-1;F2;"D");0))


    EDIT..2

    oppure cosi

    =SOMMA((B3-A3)+1;SE(C3="";0;(D3-C3)+1);SE(E3="";0;(F3-E3)+1))

    Ciao e fai sapere!

  5. I seguenti utenti hanno dato un "Like"


  6. #5
    L'avatar di alessioje
    Clicca e Apri
    Data Registrazione
    Apr 2016
    LocalitÓ
    roma
    EtÓ
    37
    Messaggi
    22
    Versione Office
    Excel 2007,
    Likes ricevuti
    0
    Likes dati
    0

    Re: Problema nel sommare don DATA.DIFF

    la prima Ŕ perfetta!
    grazie mille della vostra disponibilitÓ nei miei confronti!

  7. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Como
    EtÓ
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Problema nel sommare don DATA.DIFF

    Ciao a tutti,
    sula falsariga della formula di Gerardo, perfezionerei anche la prima somma nel caso le prime due celle dovessero essere vuote:

    =SOMMA(SE.ERRORE(DATA.DIFF(A2-1;B2;"D");0);SE.ERRORE(DATA.DIFF(C2-1;D2;"D");0);SE.ERRORE(DATA.DIFF(E2-1;F2;"D");0))

    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se pu˛ sembrare improbabile, non pu˛ che essere quella giusta!

  8. #7
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Problema nel sommare don DATA.DIFF

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao a tutti,
    sula falsariga della formula di Gerardo, perfezionerei anche la prima somma nel caso le prime due celle dovessero essere vuote:

    =SOMMA(SE.ERRORE(DATA.DIFF(A2-1;B2;"D");0);SE.ERRORE(DATA.DIFF(C2-1;D2;"D");0);SE.ERRORE(DATA.DIFF(E2-1;F2;"D");0))
    Ciao Ges, effettivamente non avevo pensato che tutta la riga potrebbe essere vuota...

    @Alessio se la tua domanda Ŕ stata risolta segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menu “Strumenti Discussione” quindi scegliere “Segna questo Thread come risolto”

  9. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Como
    EtÓ
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Problema nel sommare don DATA.DIFF

    Una modalitÓ pi¨ corta:

    =SOMMA((B2-A2);(D2-C2);(F2-E2))+CONTA.VALORI(A2:F2)/2
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se pu˛ sembrare improbabile, non pu˛ che essere quella giusta!

  10. I seguenti utenti hanno dato un "Like"


  11. #9
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Problema nel sommare don DATA.DIFF

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Una modalitÓ pi¨ corta:

    =SOMMA((B2-A2);(D2-C2);(F2-E2))+CONTA.VALORI(A2:F2)/2
    O cosi senza mettere il + ma ; visto che continua col 4 argomento del somma
    (piccolezza)

    =SOMMA((B2-A2);(D2-C2);(F2-E2);CONTA.VALORI(A2:F2)/2)

  12. I seguenti 2 utenti hanno dato un "Like" a Gerardo ZuccalÓ per questo post:


  13. #10

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Como
    EtÓ
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Problema nel sommare don DATA.DIFF

    Ciao Gerado,
    anche un + (in meno) conta!!! :261:
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se pu˛ sembrare improbabile, non pu˛ che essere quella giusta!

  14. #11
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Problema nel sommare don DATA.DIFF

    ciao
    l'avevo giÓ tirata dl cilindro, solo che non sapevo di dover comprendere sia giorno inizio che giorno fine (+1).

    Per poche colonne conviene quella di Gerardo ma per una serie di 300 colonne conviene la mia (consumereste i tasti "S" ed "E"):
    :90::90:

    =MATR.SOMMA.PRODOTTO(((B2:F2)*VAL.PARI(RIF.COLONNA(B2:F2))-(A2:E2)*VAL.DISPARI(RIF.COLONNA(A2:E2))))+CONTA.VALORI(A2:F2)/2
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed Ŕ un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

Discussioni Simili

  1. [Risolto] Inserire formula DATA.DIFF e SE nella stessa cella
    Di Arianna nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 12/01/17, 16:20
  2. Come ottenere la data di nascita partendo dall'anno. Una DATA.DIFF inversa ?
    Di ProgrammD69 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 03/07/16, 20:14
  3. Problema formattazione data e filtro
    Di morpheus1976 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 06/06/16, 17:58
  4. Sommare numeri che hanno la stessa data
    Di G.Bove nel forum Domande su Excel in generale
    Risposte: 27
    Ultimo Messaggio: 04/02/16, 01:09
  5. Sommare numeri che hanno la stessa data di fattura
    Di Francesco Brocca nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 23/01/16, 15:22

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •