Risultati da 1 a 8 di 8

Discussione: Criterio data



  1. #1
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Criterio data

    Ciao a tutti

    a questa formula devo aggiungere il terzo criterio che è quella della data cioè in questa formula
    '=SOMMA.PIÙ.SE(Tabella3[Kg. materiale];Tabella3[Codice];$H$4;Tabella3[Carico/scarico];"carico";Tabella3[Data];........
    al posto dei puntni ad esempio voglio trovare tutte le date che contengono ad esempio 2015

    Come devo formattare la formula
    grazie
    windows 10
    Excel 2016

  2. #2

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Criterio data

    Meglio usare matr.somma.prodotto e nel criterio dell'anno scrivere anno([data])=2015

    Inviato dal mio GT-I9301I utilizzando Tapatalk

  3. #3
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Re: Criterio data

    Ciao Rubik

    in P6 e Q6 ci vorrei aggiungere anche intervallo delle date comprese tra la cella P2 e la cella Q3
    File Allegati File Allegati
    windows 10
    Excel 2016

  4. #4

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Criterio data

    L'intervallo però è da considerare come data e non come mese.
    In questo caso va bene la tua formula con l'aggiunta di:
    [...] Tabella3[data];">=" & $p$2;Tabella3[data];"<=" & $q$2)

    Sono con il cellulare potrei aver fatto qualche errore di sintassi

    Inviato dal mio GT-I9301I utilizzando Tapatalk

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7142
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Criterio data

    Ciao,
    te ne ho fatte due con matr.somma.prodotto e le altre due te li ho lasciate con somma.più.se

    =MATR.SOMMA.PRODOTTO((Tabella3[Codice]=$H$4)*(Tabella3[Carico/scarico]=P$3)*(Tabella3[Data]>=P$2)*(Tabella3[Data]<=$Q$2))
    =MATR.SOMMA.PRODOTTO((Tabella3[Codice]=$H$4)*(Tabella3[Carico/scarico]=$Q$3)*(Tabella3[Data]>=$P$2)*(Tabella3[Data]<=$Q$2))

    =SOMMA.PIÙ.SE(Tabella3[Kg. materiale];Tabella3[Codice];$H$4;Tabella3[Carico/scarico];$P$3;K4:$K$500;">="&$P$2;Tabella3[Data];"<"&$Q$2)
    =SOMMA.PIÙ.SE(Tabella3[Kg. materiale];Tabella3[Codice];$H$4;Tabella3[Carico/scarico];$Q$3;K4:$K$500;">="&$P$2;Tabella3[Data];"<"&$Q$2)

    Ciao Rubik: con il cellulare anch'io mi sento un po' impedito! :288:
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. I seguenti utenti hanno dato un "Like"


  7. #6
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Re: Criterio data

    Grazie funzionano tutte

    ma come mai >= vanno messe tra virgolette???
    windows 10
    Excel 2016

  8. #7

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7142
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Criterio data

    Citazione Originariamente Scritto da nick0573 Visualizza Messaggio
    Grazie funzionano tutte

    ma come mai >= vanno messe tra virgolette???
    Nelle formule i "criteri" se messi come condizione "a se stante" equivalgono a testo e quindi vanno virgolettate.

    Per esempio, mettiamo che nell'intervallo A1:A10 ci siano dei numeri: 1,2,3,0,4,0,0,5,4,7 e vogliamo sapere quanti sono maggiori di zero (7)

    Se usiamo il >0 come criterio per contarli allora dobbiamo scrivere

    =CONTA.SE($A$1:$A$10;">"&0)

    e a questo se il numero viene posto fuori del criterio per "unirlo" c'è bisogno del segnao di concatenamento: &

    in alternativa si può scrivere così:

    =CONTA.SE($A$1:$A$10;">0")

    Diversamente se il >0 fa parte di un'operazione allora -ovviamente - le virgolette non servono

    =SOMMA(SE($A$1:$A$10>0;1)) - matriciale

    Entrambe le formule danno come risultato 7, cioè i numeri >0

    Infine, se per esempio, vogliamo contare le celle piene - sia che contengano numero o testo - possiamo scrivere così:

    =CONTA.SE($A$1:$A$10;"<>")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  9. I seguenti 2 utenti hanno dato un "Like" a ges per questo post:


  10. #8
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Re: Criterio data

    il concetto delle virgolette come testo lo sapevo

    ma non le avevo mai usate con i segni maggiori uguale o minore

    Mille grazie Ges
    windows 10
    Excel 2016

Discussioni Simili

  1. Ricerca con criterio
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 24/06/16, 12:26
  2. [Risolto] criterio per query
    Di Stefano nel forum Domande su Microsoft Access
    Risposte: 5
    Ultimo Messaggio: 22/11/15, 23:32
  3. lista di valori con criterio
    Di Stefano nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 04/11/15, 01:37
  4. conta.più.se con criterio di data
    Di matteo nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 18/08/15, 15:10
  5. Calcolo ore con criterio
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 13/07/15, 00:44

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •