Risultati da 1 a 12 di 12

Discussione: Somma con intervalli dinamici



  1. #1
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342

    Somma con intervalli dinamici

    Domandina del giorno
    giusto per mantenerci in forma
    Vorrei fare la somma dall'inizio dell'anno fino ad un mese che scelgo come criterio nella cella A2
    e anche in base al nome che lo scelgo con un menu a tendina nella cella A1
    Buon divertimento



    A
    B
    C
    D
    E
    F
    G
    H
    I
    1
    ANNA
    2
    APRILE
    3
    4
    GENNAIO FEBBRAIO MARZO APRILE MAGGIO GIUGNO LUGLIO AGOSTO
    5
    LUISA
    16
    36
    28
    16
    33
    20
    27
    18
    6
    GIORGIA
    25
    22
    34
    15
    26
    14
    25
    12
    7
    GIULIA
    30
    27
    13
    18
    14
    15
    13
    35
    8
    ANGELO
    24
    35
    15
    23
    30
    23
    16
    20
    9
    LUCIA
    13
    13
    34
    15
    12
    23
    21
    16
    10
    ANNA
    24
    32
    12
    31
    33
    34
    18
    12
    11
    MARIA
    35
    23
    36
    33
    31
    24
    30
    14
    12
    CAMILLA
    30
    17
    15
    17
    12
    25
    15
    18
    13
    GIOVANNI
    32
    30
    13
    21
    33
    12
    23
    28
    14
    LUIGI
    15
    20
    30
    20
    35
    22
    33
    22
    Ultima modifica fatta da:Gerardo ZuccalÓ; 15/07/15 alle 19:06
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Barcellona P.G.
    EtÓ
    55
    Messaggi
    2143
    Versione Office
    2010 PC
    Likes ricevuti
    1183
    Likes dati
    239
    ciao
    Anche questa problematica ha molteplici tipi di soluzione, una meno comune, anche se ingarbuglata:
    Codice: 
    =MATR.SOMMA.PRODOTTO(INDICE(B5:I14;CONFRONTA(A1;A5:A14;0);)*(RIF.COLONNA(A:H)<=MESE(1&A2)))
    edit
    e visto che Ŕ tempo di SCARTO():
    =SOMMA(SCARTO($B$4;CONFRONTA(A1;A5:A14;0);;1;CONFRONTA(A2;B4:I4;0)))
    Ultima modifica fatta da:ninai; 15/07/15 alle 21:31

  3. #3
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Turbigo (MI)
    EtÓ
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    io ho provato con questa Gerardo Ŕ volatile ma con questo caldo un po' d'aria ci vuole :166:
    =SOMMA(SCARTO(A4;CONFRONTA(A1;A5:A14;0);1;1;CONFRONTA(A2;B4:I4;0)))

  4. #4
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Turbigo (MI)
    EtÓ
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    ops, non avevo visto sopra, sono arrivato secondo

  5. #5
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Firenze
    Messaggi
    1126
    Versione Office
    2010 su Win
    Likes ricevuti
    642
    Likes dati
    226
    Ciao a tutti,

    un altro modo potrebbe essere:

    Codice: 
    =SOMMA(INDICE(B5:B14;CONFRONTA(A1;A5:A14;0)):INDICE(B5:I14;CONFRONTA(A1;A5:A14;0);CONFRONTA(A2;B4:I4;0)))

    Saluti

  6. #6
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Milano
    EtÓ
    54
    Messaggi
    1009
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    401
    Likes dati
    1
    Buon Giorno



    =MATR.SOMMA.PRODOTTO(--(A5:A14=A1)*(B4:I4=A2)*(B5:I14))


    Saluti
    Window 8.1 Excel 2013/2016

  7. #7
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Turbigo (MI)
    EtÓ
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    pitagora, l'ho provata per˛ a me da solamente la somma del mese selezionato e non da gennaio

  8. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Como
    EtÓ
    54
    Messaggi
    10153
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2598
    Likes dati
    1558
    Neanche a me funziona l'ultima di Pitagora ... l'ultima di Canapone Ŕ un capolavoro nella semplicitÓ!

  9. #9
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    LocalitÓ
    Firenze
    Messaggi
    1126
    Versione Office
    2010 su Win
    Likes ricevuti
    642
    Likes dati
    226
    Ciao a tutti,

    grazie Ges, asciugo un po' la formula: uso per ottenere il numero cardinale del mese MESE(A2&0).

    E' lo stesso sistema usato da Ninai nella MATR.SOMMA.PRODOTTO

    Codice: 
    =SOMMA(INDICE(B5:B14;CONFRONTA(A1;A5:A14;0)):INDICE(B5:I14;CONFRONTA(A1;A5:A14;0);MESE(A2&0)))
    Meglio ancora sarebbe approfittare di SE.ERRORE

    =SE.ERRORE(formula;0)

    Saluti

  10. #10
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342
    Video tutorial

    Wooow @Canapone @Ninai @Stefano tutte belle formule!!
    Per chi volesse approfondire queste formule io tempo fa ho creato un video con qualcosa di simile e qui vedremo in particolare le formule con la funzione SCARTO e INDICE:INDICE
    buona visione

    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  11. #11
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    LocalitÓ
    Milano
    EtÓ
    54
    Messaggi
    1009
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    401
    Likes dati
    1
    Buona Sera

    Mi scuso per l'errore questo caldo mi ha fuso il cervello.


    Saluti
    Window 8.1 Excel 2013/2016

  12. #12
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342
    Tranquillo No problem:261:
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

Discussioni Simili

  1. [Risolto] Men¨ a tendina dinamici
    Di vittorio dit nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 10/03/17, 10:30
  2. [Risolto] estrarre dati con filtri dinamici e operatori logici dinamici
    Di demmas nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 20/02/17, 06:09
  3. Excel 2003 e EP6 Lo strumento TABELLA per intervalli dinamici di excel
    Di AiaceT nel forum Domande su Excel in generale
    Risposte: 0
    Ultimo Messaggio: 22/01/17, 23:06
  4. intervalli dinamici e aggiornamento in automatico di una tavola dati
    Di Enrico C. nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 14/03/16, 12:13
  5. Somma di intervalli dinamici
    Di Gerardo ZuccalÓ nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 18/06/15, 00:54

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •