Risultati da 1 a 12 di 12

Discussione: Calcolo ranking community online



  1. #1
    L'avatar di frankuaku
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Cagliari
    Età
    20
    Messaggi
    12
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2

    Calcolo ranking community online

    Salve a tutti!
    Ho iniziato a predisporre il calcolo del ranking. Il mio problema sta nel fatto che, dopo aver applicato la formula, vorrei trasferire la somma dei punti accumulati da un determinato player nella classifica. Inoltre, dalla 2^ giornata in poi, vorrei che la formula per calcolare il punteggio del match riconoscesse in automatico la posizione nella classifica del player in questione (ma forse chiedo troppo... :D)

    Buona giornata e grazie in anticipo!
    File Allegati File Allegati
    Ultima modifica fatta da:Gerardo Zuccalà; 27/04/16 alle 14:04 Motivo: No riferire ai video

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Calcolo ranking community online

    Ciao frankuaku, benvenuto in forumexcel.it

    Quando fai le domande non dire che è riferito ad un video altrimenti molti possono pensare che la domanda è rivolta solo a me, invece deve essere estesa a tutti gli esperti di questo forum, oltretutto molti non hano visto il video (ho modificato il rif.video)
    Comunque ho visto il file e la classifica mi sembra ben fatta, vorrei sapere esattamente cosa vorresti, prova a fare una simulazione con il risultato scritto a mano e specificare perchè di quel risultato, cosi da capire esattamente cosa vorresti e dove...
    ciao

  3. #3
    L'avatar di frankuaku
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Cagliari
    Età
    20
    Messaggi
    12
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2

    Re: Calcolo ranking community online

    In sostanza, al posto della "normale" classifica con partite vinte, pareggiate e perse, vorrei una classifica in cui ci sia il punteggio ottenuto da quella partita, che ho inserito nelle colonne PUNT_CASA e PUNT_FUORI nel foglio Risultati. Ho già modificato la classifica con le squadre (i giocatori) ma non riesco ad andare oltre, perché appunto rimango alla questione delle partite vinte/pari/perse.

  4. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Calcolo ranking community online

    Ciao a tutti,

    io continuo a non capire cosa si vuole ottenere :250:

    @frankuaku
    lascia perdere i riferimenti come "ranking", "player", etc... e cerca di spiegare piuttosto riferendoti alle celle del foglio che hai allegato.

    Quindi, riepilogando... dove vuoi fare cosa?
    Cioè, il risultato che vuoi ottenere dove lo vuoi avere (che celle) e dove devono essere presi i valori (che celle) per ottenere questo risultato?

    P.S.
    Le formule che hai usato nelle colonne G e H del foglio "Risultati + calcolo punteggio" sono giuste o sono delle prove?

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  5. #5
    L'avatar di frankuaku
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Cagliari
    Età
    20
    Messaggi
    12
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2

    Re: Calcolo ranking community online

    Citazione Originariamente Scritto da cromagno Visualizza Messaggio
    Quindi, riepilogando... dove vuoi fare cosa?
    Cioè, il risultato che vuoi ottenere dove lo vuoi avere (che celle) e dove devono essere presi i valori (che celle) per ottenere questo risultato?

    P.S.
    Le formule che hai usato nelle colonne G e H del foglio "Risultati + calcolo punteggio" sono giuste o sono delle prove?
    Scusami, in effetti dovrei andare dritto al punto... Allora, io vorrei avere la classifica con però non le partite vinte ecc., ma la somma dei punteggi accumulati (quelli delle colonne G ed H). Le formule son giuste, dopo vari tentativi sono riuscito a farla corretta :D

  6. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Calcolo ranking community online

    Ciao a tutti,

    @frankuaku
    premetto che riservo ancora qualche dubbio in quanto se hai fatto l'altra classifica, questa è praticamente uguale...

    Ho usato una tabella d'appoggio in quanto servono i punti incolonnati per non incasinarsi con formule troppo complesse (si potrebbe cercare di fare a meno delle colonne G e H).



    Le formule (da copiare poi in basso)....

    cella K3 :
    =SE.ERRORE(SE.ERRORE(CERCA.VERT(J3;$B$2:$G$12;6;FALSO);CERCA.VERT(J3;$E$2:$H$12;4;FALSO));0)

    cella N3 :
    =GRANDE($K$3:$K$25;RIF.RIGA(A1))

    cella O3 :
    =INDICE($J$1:$J$25;AGGREGA(15;6;RIF.RIGA($K$3:$K$25)/($K$3:$K$25=N3);CONTA.SE($N$3:N3;N3)))

    P.S.
    "Davide Mosti" non è presente nella prima giornata....
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  7. I seguenti 3 utenti hanno dato un "Like" a cromagno per questo post:


  8. #7
    L'avatar di frankuaku
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Cagliari
    Età
    20
    Messaggi
    12
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2

    Re: Calcolo ranking community online

    @cromagno: Grazie mille, l'altra classifica era già "pronta" dal file che avevo in origine in sostanza, quindi non l'ho fatta io :D

    Comunque, questo era proprio quello che mi serviva per iniziare; ora volevo capire se è possibile, integrando la formula delle celle G3 e H3, che sono specularmente:

    =SE(RI_CASA>RI_FUORI;SE(RI_CASA=RI_FUORI;2;4);SE(RI_CASA<RI_FUORI;0;2))*3*(23-1)*(RI_CASA-RI_FUORI+1)
    =SE(RI_FUORI>RI_CASA;SE(RI_FUORI=RI_CASA;2;4);SE(RI_FUORI<RI_CASA;0;2))*3*(23-1)*(RI_FUORI-RI_CASA+1)

    far sì che la formula legga la posizione del giocatore avversario e la sottragga al posto dell'1 evidenziato. Questa prima formula è infatti utilizzata per calcolare il punteggio iniziale (poiché tutti iniziavano da 0), ma ovviamente una volta iniziato avendo già dei punteggi cambiano anche le posizioni.

    P.S.: Davide Mosti alla prima giornata riposava, per questo non era inserito.

  9. #8
    L'avatar di frankuaku
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Cagliari
    Età
    20
    Messaggi
    12
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2

    Re: Calcolo ranking community online

    Scusate se "riesumo" il post, ma ora che ho un po' di tempo libero sono tornato su questo file.

    Ho notato due cose: se cambio la formula nella cella K3, prendendo in considerazione tutte le celle utilizzate del foglio (fino alla riga 507) alcuni punteggi vanno a 0 (come quello di Christian Boccone, per esempio). Come potrei risolvere?

  10. #9
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2302
    Versione Office
    Excel 2010
    Likes ricevuti
    913
    Likes dati
    451

    Re: Calcolo ranking community online

    Un saluto a tutti,

    Ho notato due cose: se cambio la formula nella cella K3, prendendo in considerazione tutte le celle utilizzate del foglio (fino alla riga 507) alcuni punteggi vanno a 0 (come quello di Christian Boccone, per esempio).

    d
    a quello che ho capito vorresti cercare il valore nella colonna G e se a 0 cercarlo anche in colonna H?
    prova con:


    =SE(CERCA.VERT(J3;$B$2:$G$507;6;FALSO)=0;CERCA.VERT(J3;$E$2:$H$507;4;FALSO);0)

  11. #10
    L'avatar di frankuaku
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Cagliari
    Età
    20
    Messaggi
    12
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2

    Re: Calcolo ranking community online

    Ho risolto! Ho modificato alcune formule e ce l'ho fatta! Grazie a tutti per l'aiuto!

  12. #11
    L'avatar di Powerwin
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Milano
    Messaggi
    1404
    Versione Office
    2016 - 2010
    Likes ricevuti
    194
    Likes dati
    71

    Re: Calcolo ranking community online

    Citazione Originariamente Scritto da frankuaku Visualizza Messaggio
    Ho risolto! Ho modificato alcune formule e ce l'ho fatta! Grazie a tutti per l'aiuto!
    Sarebbe bello se tu condividessi col Forum la soluzione del problema postando le formule corrette

  13. I seguenti 2 utenti hanno dato un "Like" a Powerwin per questo post:


  14. #12
    L'avatar di frankuaku
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Cagliari
    Età
    20
    Messaggi
    12
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2

    Re: Calcolo ranking community online

    Citazione Originariamente Scritto da Powerwin Visualizza Messaggio
    Sarebbe bello se tu condividessi col Forum la soluzione del problema postando le formule corrette
    Scusate questa assenza lunghissima... mi sono proprio scordato di rispondere alla discussione.

    Comunque, ho leggermente modificato la formula del ranking in sé, visto che penalizzava i punteggi fatti con i primi in classifica premiando invece le "goleade" contro chi era nelle ultime posizioni, cambiando (RI_CASA-RI_FUORI+1) in(((RI_FUORI-RI_CASA)/2)+2).

    Quindi:
    • nella cella G2, la formula risulta =SE(RI_CASA>RI_FUORI;SE(RI_CASA=RI_FUORI;2;4);SE(RI_CASA<RI_FUORI;0;2))*3*(23-1)*(((RI_CASA-RI_FUORI)/2)+2);
    • nella cella H2, la formula risulta =SE(RI_FUORI>RI_CASA;SE(RI_FUORI=RI_CASA;2;4);SE(RI_FUORI<RI_CASA;0;2))*3*(23-1)*(((RI_FUORI-RI_CASA)/2)+2).


    Oltre a queste modifiche, sorgeva poi il problema di determinare automaticamente la posizione nel rank dell'altra squadra al momento dell'inserimento del risultato. Per far ciò, ho leggermente modificato la tabella d'appoggio delle colonne J-N inserendo sia una distinzione fra punti casa e punti fuori e la funzione RANGO nella colonna N che mi determinasse la posizione.
    La formula risultava quindi:
    • per le celle in casa =SE(RI_CASA>RI_FUORI;SE(RI_CASA=RI_FUORI;2;4);SE(RI_CASA<RI_FUORI;0;2))*3*(23-(CERCA.VERT(SQ_CASA;$J$3:$N$25;5;FALSO)))*(((RI_CASA-RI_FUORI)/2)+2);
    • per le celle in trasferta =SE(RI_CASA>RI_FUORI;SE(RI_CASA=RI_FUORI;2;4);SE(RI_CASA<RI_FUORI;0;2))*3*(23-(CERCA.VERT(SQ_FUORI;$J$3:$N$25;5;FALSO)))*(((RI_CASA-RI_FUORI)/2)+2).


    Per poter inserire il risultato, tutte le formule erano bloccate dall'apostrofo pre-uguale, in modo tale che una volta inserito lo andassi a cancellare e andassi a premere F9 sulla parte del CERCA.VERT, tale che mi restituisse la posizione data dalla formula RANGO nella colonna N.

    Spero di essermi spiegato bene :D

    P.S.: chiedo eventualmente se ci fosse una possibilità di inserire i risultati senza dover premere F9 per determinare la posizione.
    File Allegati File Allegati

Discussioni Simili

  1. Plugin utenti online 24h
    Di Max nel forum Problemi, suggerimenti e Novità del forum
    Risposte: 10
    Ultimo Messaggio: 22/08/16, 21:17
  2. Excel Online
    Di Jackmeda nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 24/09/15, 16:36
  3. Excel online - One drive
    Di Luisa88 nel forum Foglio di calcolo su altre Piattaforme
    Risposte: 6
    Ultimo Messaggio: 10/09/15, 17:24

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •