Risultati da 1 a 5 di 5

Discussione: Confronto tra una formula e un test



  1. #1
    L'avatar di claudiorossini
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Età
    47
    Messaggi
    1
    Versione Office
    Office2013
    Likes ricevuti
    0
    Likes dati
    0

    Confronto tra una formula e un test

    Nel Foglio1 ho una tabella come questa:

    id | nome | cognome | codice | nazione

    1 | giorgio| rossi | a01 | GB
    2 | mario | verdi | a02 | DE
    ...

    Nel Foglio2 ho una tabella come questa:

    id | codice GB | codice DE
    1 |
    5 |
    7 |

    nella colonna id del Foglio2 vengono inseriti tutta una serie di codici id (che possono esistere o meno nella colonna id del foglio1) e ho bisogno di completare la colonna "codice GB" e "codice DE" con la seguente regola:
    Se il codice id del Foglio2 esiste nel Foglio1, e se il campo nazione corrispondente = GB, allora metti il valore corrispondente del campo "codice" del Foglio1 all'interno del campo "codice GB" del Foglio2

    Ho pensato di usare la seguente formula all'interno della cella della colonna "codice GB" del Foglio2 ma non funzione e ottengo come risultato #NOME?

    =SE(CERCA.VERT(A1;Foglio1!A1:E156;5;FALSO))="GB";CERCA.VERT(A1;Foglio1!A1:E156;4;FALSO);"")

    Cosa sto sbagliando? Grazie

    ciao

  2. #2

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2809
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Confronto tra una formula e un test

    prova così:
    =SE(CERCA.VERT(Foglio2!$A2;Foglio1!$A$2:$E$10;5;0)=DESTRA(Foglio2!B$1;2);DESTRA(Foglio2!B$1;2);"")

  3. I seguenti 2 utenti hanno dato un "Like" a Rubik72 per questo post:


  4. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Confronto tra una formula e un test

    Ciao Claudio Benvenuto in forumexcel.it
    Sono sicuro che la soluzione di Rubik sia quella giusta, tuttavia per capire meglio la tua domanda e quindi estenderla a tutti coloro (me compreso) che non l'hanno capita, se vuoi potresti allegare un file di excel, e sono sicuro che si possono trovare anche altre soluzioni
    Tutto Qua!
    Saluto

  5. I seguenti utenti hanno dato un "Like"


  6. #4
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Confronto tra una formula e un test

    Un ciao a tutti, nell'ipotesi che abbia capito bene, un'alternativa alla formula proposta da Rubik72, che saluto, potrebbe essere la seguente:

    Foglio2 In B1:
    =SE.ERRORE(INDICE(Foglio1!$D$3:$D$4;AGGREGA(15;6;(RIF.RIGA(Foglio1!$A$3:$A$4)-RIF.RIGA(Foglio1!$A$3)+1)/(Foglio1!$A$3:$A$4=Foglio2!A2);1)*(CONFRONTA(DESTRA($B$1;2);Foglio1!$A3:$E3;0))/5);"")

    Foglio2 In C1:
    =SE.ERRORE(INDICE(Foglio1!$D$3:$D$4;AGGREGA(15;6;(RIF.RIGA(Foglio1!$A$3:$A$4)-RIF.RIGA(Foglio1!$A$3)+1)/(Foglio1!$A$3:$A$4=Foglio2!A2);1)*(CONFRONTA(DESTRA($C$1;2);Foglio1!$A3:$E3;0))/6);"")

    entrambe da tirare giù alla bisogna, dopo aver adeguato gli intervalli.
    Allego il file di prova.
    Ciao,
    File Allegati File Allegati

  7. I seguenti 2 utenti hanno dato un "Like" a pkrome59 per questo post:


  8. #5
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Confronto tra una formula e un test

    Ciao Claudiorossini, chiedo scusa a te e a tutti gli amici del forum, le formule postate al post#5, a seguito di un attento controllo sono risultate errate e vanno corrette con le seguenti:

    Se interessa estrapolare i codici:
    In B2:
    =SE.ERRORE(INDICE(Foglio1!$A$2:$E$3;AGGREGA(15;6;(RIF.RIGA(Foglio1!$A$2:$A$3)-RIF.RIGA(Foglio1!$A$2)+1)/(Foglio1!$A$2:$A$3=Foglio2!$A2);1);CONFRONTA(B$1;Foglio1!$A$1:$E$1&" "&Foglio1!$E2;0));"")

    da tirare a destra e giù alla bisogna, dopo averla attivata con CTRL+MAIUSCOLO+INVIO.

    Se invece interessa estrapolare le sigle delle nazioni:
    In F2:
    =SE.ERRORE(INDICE(Foglio1!$A$2:$E$3;AGGREGA(15;6;(RIF.RIGA(Foglio1!$A$2:$A$3)-RIF.RIGA(Foglio1!$A$2)+1)/(Foglio1!$A$2:$A$3=Foglio2!$A2);1);CONFRONTA(DESTRA(B$1;2);Foglio1!$A2:$E2;0));"")

    da tirare a destra e giù alla bisogna. Quest'ultima non necessita essere attivata.
    Allego il file di prova.
    Ciao.
    File Allegati File Allegati

Discussioni Simili

  1. [Risolto] cerco formula per confronto tra 2 file
    Di stardust978 nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 21/11/16, 17:32
  2. [Risolto] Confronto tra due DB
    Di sergiogranero nel forum Domande su Microsoft Access
    Risposte: 16
    Ultimo Messaggio: 03/11/16, 15:25
  3. Paranetro Test nella formula SE
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 25/05/16, 07:39
  4. Formula confronto link
    Di maximo890 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 08/11/15, 20:21
  5. test formula
    Di Gerardo Zuccalà nel forum Test dei vostri post
    Risposte: 5
    Ultimo Messaggio: 15/07/15, 13:11

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •