Risultati da 1 a 25 di 25

Discussione: Formattazione errata



  1. #1
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    LocalitÓ
    Milano
    EtÓ
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Formattazione errata

    Ciao a tutti,
    ho provato e riprovato (anche seguendo i consigli di alcuni amici del forum) ma c'Ŕ qualcosa nella formattazione del foglio prova che non mi permette di far funzionare la formula in R15 del foglio dashboard.:292:.Non ottengo risultato anche by-passando la problematica cella unita (escamotage: dargli come riferimento la cella unica della causale presente in legenda)

    https://www.dropbox.com/s/w4kqe9xzm0..._V6F.xlsm?dl=0

    Grazie in anticipo
    Gene

    PS Solita annotazione: il file prova Ŕ in realtÓ un file esterno su NAS aziendale.

  2. #2
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Formattazione errata

    Ciao G.Bove
    apprezzo che tu ci abbia provato ma in questo caso una formula errata non Ŕ di aiuto, perchŔ non provi a scrivere che tipo di risultato vorresti in R15, cerca di essere pi¨ descrittivo, conciso e magari scrivere qualche risultato a mano cosi da capire esattamente cosa vorresti ottenere, comunque forse ho capito quello che vuoi, una conteggio con tre criteri
    1) criterio impianti
    2)criterio il Motivo dell' interuzione
    3) criterio la data della ComboBox

    se Ŕ corretto ci posso provare

  3. #3
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Formattazione errata

    Eccomi qui
    credo di aver capito
    prima di tutto per˛ volevo farti notare l'utilizzo sbagliato delle celle unite, il pi¨ delle volte sono di intralcio per le formule, ed in questo caso potevi farne a meno semplicemente spostando quello che hai sopra magari verticalmente, ricordati che excel vede le celle unite come fumo negli occhi (citazione marius44).

    Poi ho utilizzato la definizione dei nomi per evitare di saltare da un foglio all'altro per selezionare degli intervalli "assoluti" e mi riferisco al data-base che c'Ŕ nel foglio "prova" (ovviamente puoi cambiare il range in qualsiasi momento richiamando il tool Nomi con il tasto CTRL+F3)

    Nomi definiti
    DateDB riferito a =prova!$G$2:$G$28723
    MotivoRottura riferito a =prova!$H$2:$H$28723
    ImpiantiDB riferito a =prova!$K$2:$K$28723

    Adesso metti questa formula nel foglio "dashboard" nella cella R9 e trascinala a destra ed in basso

    =MATR.SOMMA.PRODOTTO(--(ImpiantiDB=$B9);--(MotivoRottura=R$8);--(DateDB=INDICE(giorni_combinata;$A$8)))


    https://www.dropbox.com/s/vzpkadegt2sx4iy/Analisi_aggregata_V6F.xlsm?dl=0

  4. #4
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    LocalitÓ
    Milano
    EtÓ
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Formattazione errata

    Ciao Gerardo,
    grazie per il tuo intervento mi ti chiedo un ulteriore sforzo.
    Ho provato a portare la tua indicazione nel file master ma tenuto conto che non ottengo il risultato, ipotizzo, che il file prova esterno sia per excel un'ostacolo nell'utilizzo dei nomi definiti.



    Hai una dritta per risolvere il tutto?

    PS I valori funzionanti che vedi su altri impianti hanno come fonte altro file excel che non mi ha dato problemi.

    Gene

  5. #5
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    LocalitÓ
    Binasco
    EtÓ
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Formattazione errata

    Ciao a tutti
    Un NOME collegato ad un foglio esterno (aperto non dovrebbe; chiuso sicuramente)
    La formula in R15=MATR.SOMMA.PRODOTTO((prova!$K$1:$K$70000=B15)*(prova!$H$1:$H$70000=R$8)*(prova!$G$1:$G$70000=INDICE(giorni_combinata;$A$8)))

    Ps. (=+Legenda!F12) Non capisco perchŔ tanti utenti mettono il segno + davanti alla formula (forse versioni superiori?).
    Pps. Comunque celle unite danno fastidio solo al VBA, in un DB anche alle formule se fossero (unite in verticali/orizzontale, perchŔ ogni riga/colonna un dato diverso)

  6. #6
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    LocalitÓ
    Milano
    EtÓ
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Formattazione errata

    Ciao Raffaele_53,
    nell'applicare la tua formula ottengo un risultato strano: la presenza della barra colorata indica giustamente la presenta di valori ma il dato numerico riportato Ŕ 00:00 ?

    https://www.dropbox.com/s/ml5enezhre...F%2B.xlsm?dl=0

    Gene

  7. #7
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    LocalitÓ
    Vicenza
    EtÓ
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Formattazione errata

    Ciao
    devi formattare la colonna in " GENERALE"
    anche se tra le due formule noto una discrepanza tra i totali:92:

  8. #8
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    LocalitÓ
    Vicenza
    EtÓ
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Formattazione errata

    ciao
    la discrepanza Ŕ la data Sorry:186:
    per il resto penso che tu voglia la somma dei tempi
    mentre le formule riportano il numero degli interventi per causale.
    ecco perchÚ la formattazione hh:mm non ti funziona

  9. #9
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    LocalitÓ
    Vicenza
    EtÓ
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Formattazione errata

    La formula che tu cerchi dovrebbe essere questa
    Codice: 
    =SOMMA.PI┘.SE(prova!$J$2:$J$50000;prova!$H$2:$H$50000;Dashboard!R$8;prova!$K$2:$K$50000;$B15;prova!$F$2:$F$50000;INDICE(giorni_combinata;$A$8))
    https://www.dropbox.com/s/vd2c3ejhhl...1%29.xlsm?dl=0

    le formule proposte da Raffaele e da Gerardo
    variandole puoi utilizzarle per il conteggio del ripasso ( R1-R2-R3 )

  10. I seguenti utenti hanno dato un "Like"


  11. #10
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Formattazione errata

    Ciao GBove
    Non ho capito cosa non funzionava nella risposta del post #2?
    a me funzionava bene, hai aperto l'allegato?

    Ciao Gianfranco ottimo intuito con il SOMMA.PIU.SE

  12. #11
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    LocalitÓ
    Vicenza
    EtÓ
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Formattazione errata

    Ciao Gerardo
    non funziona perchÚ il Ns amico formattava la colonna in hh:mm
    mentre la formula riporta un numero:17:

    la tua formula va benissimo per la ricerca del numero degli eventi (R1-R2-R3)

    ma non per la somma dei tempi

    vedrai che GBove utilizzerÓ la formula per completare la tabella che ha nelle prime colonne

    buona domenica

  13. #12
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    LocalitÓ
    Binasco
    EtÓ
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Formattazione errata

    Ciao a tutti
    Allegato nel primo post non esiste piu. Colpa di dropbox
    Mi baso sul post 1/5/2015 06:52

    Mi ero dimenticato se volevi (interventi/Generale= N░ eseguiti), oppure somma dei totali (interventi = Ore/tipo 37:50:55). MAI formatti/personalizzati

    Una cosa non sono d'accordo. Formattazione Condizionale
    Se faccio una FC, poi copio/incollo la FC si riscrive da sola appesantendo il foglio excel.
    Vedo la FC in R15 e non capisco (prova togliere $ se fosse riga, oppure $ in colonna).

    =$R$9:$T$15;$V$9:$X$15;$Z$9:$AB$15;$AD$9:$AF$15;$AH$9:$AJ$15;$AH$17:$AJ$17;$AD$17:$AF$17;$Z$17:$AB$17;$V$17:$X$17;$R$17:$T$17;$R$19:$T$19;$V$19:$X$19;$Z$19:$AB$19;$AD$19:$AF$19;$AH$19:$AJ$19;$AH$21:$AJ$21;$AD$21:$AF$21;$Z$21:$AB$21;$V$21:$X$21;$R$21:$T$21;$R$23:$T$23;$V$23:$X$23;$Z$23:$AB$23;$AD$23:$AF$23;$AH$23:$AJ$23;$AH$25:$AJ$25;$AD$25:$AF$25;$Z$25:$AB$25;$V$25:$X$25;$R$25:$T$25;$R$27:$T$28

  14. #13
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    LocalitÓ
    Milano
    EtÓ
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Formattazione errata

    Ciao a tutti, di seguito feedback.
    @Gianfranco55
    Ovviamente la tua formula funziona ma purtroppo il SOMMA.PIU.SE pretende di avere "sotto" il file aperto e quindi si scontra con una costante dei miei thread ossia i file sorgenti in partizioni esterne al file master. Infatti per questo motivo si era arrivati ad usare =MATR.SOMMA.PRODOTTO.
    E precisamente nei collegamenti che funzionano agganciati ad altro file, la formula Ŕ la seguente:
    =MATR.SOMMA.PRODOTTO(('M:\DrPI\[ADA.xls]Foglio1'!$O$2:$O$70000=$B14)*('M:\DrPI\[ADA.xls]Foglio1'!$J$2:$J$70000=INDICE(giorni_combinata;$A$8))*('M:\DrPI\[ADA.xls]Foglio1'!$E$2:$E$70000=R$8)*'M:\DrPI\[ADA.xls]Foglio1'!$N$2:$N$70000)

    Di seguito comportamento di SOMMA.PIU.SE con File chiuso:


    E con file Aperto:



    @Raffaele_53
    Il tuo "italo-excel" Ŕ troppo ermetico per un dummies come lo scrivente quindi non riesco a capire come e cosa modificare per poi poterti dare un corretto riscontro.

    Attendo vostre
    Gene
    Ultima modifica fatta da:G.Bove; 02/05/16 alle 11:34 Motivo: comprensione testo

  15. #14
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    LocalitÓ
    Vicenza
    EtÓ
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Formattazione errata

    ciao
    non avevo visto he era in un secondo file
    cambia i parametri alla formula.

    scusa se ti serve la somma dei tempi che te ne fai del numero degli eventi

  16. #15
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    LocalitÓ
    Milano
    EtÓ
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Formattazione errata

    Ciao Gianfranco in realtÓ sono informazioni differenti che mi arrivano giornalmente da impianti diversi.
    Quello che non capisco Ŕ quale formattazione presente nel foglio 'prova' non mi permette di "portare a casa il risultato" come succede con l'altro file che ti citavo al mio post #13.
    Volendo modificare la formula di Gerardo dovrei prima capire dove Ŕ il riferimento alla colonna dei tempi (ossia J).:252:

    Gene

  17. #16
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    LocalitÓ
    Vicenza
    EtÓ
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Formattazione errata

    Ciao

    mi provi questa formula sul tuo file

    Codice: 
    =SOMMA.PI┘.SE('M:\DrPI\[ADA.xls]Foglio1'!$N$2:$N$70000;'M:\DrPI\[ADA.xls]Foglio1'!$E$2:$E$70000;Dashboard!R$8;'M:\DrPI\[ADA.xls]Foglio1'!$O$2:$O$70000;$B15;'M:\DrPI\[ADA.xls]Foglio1'!$J$2:$J$70000;INDICE(giorni_combinata;$A$8))
    non sono sicuro dei'parametri
    per la formattazione vedo pi¨ tardi

    se ho sbagliato a scrivere correggi

  18. #17
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    LocalitÓ
    Vicenza
    EtÓ
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Formattazione errata

    =INT((RIF.COLONNA(#RIF!)-RIF.COLONNA(#RIF!))/3)+1=valSortColNumber

    questa non funziona di certo

  19. I seguenti utenti hanno dato un "Like"


  20. #18
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    LocalitÓ
    Binasco
    EtÓ
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Formattazione errata

    Dall'allegato di Gianfranco55 Ieri, 11:10
    in prova J26240 c'Ŕ un errore, ho messo =(G26240+E26240)-(F26240+D26240)
    Formattato colonna J come ORE/formatto 37:30:55

    In Dashboard range R9:AK28 Formattato come ORE/formatto 37:30:55
    In R15=MATR.SOMMA.PRODOTTO((prova!$K$1:$K$70000=$B15)*(prova!$H$1:$H$70000=R$8)*(prova!$G$1:$G$70000=INDICE(giorni_combinata;$A$8))*(prova!$J$1:$J$70000))
    FÓ la somma della colonna J, per prova fatto su file chiuso e funziona
    =MATR.SOMMA.PRODOTTO(('C:\Users\Lello\Documents\[Cartel11111.xlsx]Foglio1'!$K1:$K70000=$B20)*('C:\Users\Lello\Documents\[Cartel11111.xlsx]Foglio1'!$H1:$H70000=R$8)*('C:\Users\Lello\Documents\[Cartel11111.xlsx]Foglio1'!$G1:$G70000=INDICE(giorni_combinata;$A$8))*('C:\Users\Lello\Documents\[Cartel11111.xlsx]Foglio1'!$J1:$J70000))

    Nello stesso allegato vedo che FC e stata messa a posto. Se volete sposto allegato

  21. #19
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    LocalitÓ
    Vicenza
    EtÓ
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Formattazione errata

    https://www.dropbox.com/s/vd2c3ejhhl...1%29.xlsm?dl=0


    ti h messo la formattazione in una cella

    ma dove li andate a prendere tutti quei file?

  22. #20
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    LocalitÓ
    Milano
    EtÓ
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Formattazione errata

    Ciao a tutti,
    ammetto la mia sconfitta dopo quasi due giorni di tentativi non sono arrivato a nulla...in breve:
    1) la formula di Gianfranco come scritto si aggiorna solo se l'altro file Ŕ aperto
    2) la formula di Raffaele mi da errore.

    https://www.dropbox.com/s/ql5sv3ykjd70uoh/mdp.rar?dl=0
    A questo punto vi allego i files sorgente e il file master, mi dite dove cavolo sbaglio!!!:237:

    Grazie
    Gene
    @Gianfranco: Diciamo che i dati mi arrivano da molto vicino a casa tua....:166:

  23. #21
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    LocalitÓ
    Vicenza
    EtÓ
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Formattazione errata

    ciao
    ho visto ora il msg ora verifico
    intanto guarda se questo stragiro ti piace
    https://www.dropbox.com/s/aug8l536wl7e45y/mdp.rar?dl=0

    i riferimenti dovrebbero aggiornarsi da soli altrimenti cambiali.
    cambia data e vedi

    se nel tessile.....confezioni ?
    Codice: 
    Sub Adiscesa9_Cambia()
    Application.DisplayAlerts = False
    Application.ScreenUpdating = False
        Workbooks.Open Filename:="C:\Users\Gianfranco\Downloads\mdp\DrPI\PCS.xls"
       Windows("PCS.xls").Activate
       ActiveWindow.Close
       Application.DisplayAlerts = True
       Application.ScreenUpdating = True
    Set Target = Nothing
    End Sub
    cambia i filename con il tuo

  24. #22
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    LocalitÓ
    Vicenza
    EtÓ
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Formattazione errata


  25. I seguenti 2 utenti hanno dato un "Like" a Gianfranco55 per questo post:


  26. #23
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    LocalitÓ
    Milano
    EtÓ
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Formattazione errata

    Ciao Gianfranco,
    sperando che Gerardo non mi banni non posso che usare:
    :97::285::274::18:

    Grazie ancora.

  27. #24
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    LocalitÓ
    Binasco
    EtÓ
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Formattazione errata

    Se non sbaglio, il problema era far funzionare una formula su un file chiuso.

    Tornando alla formula =MATR.SOMMA.PRODOTTO()
    Se apro ADA.xls (estenzione del 2003, dovrebbe avere solo 65.536 record, pertanto la formula $O$2:$O$70000 sarebbe in errore), invece dice "formatto differente....". GiÓ qui mi chiedo da dove arriva (questo file), che ha 1.048.000 record.

    Parlando invece di PCS.XLS
    Forse non ha letto errore in riga 2640 e formatto celle, modificando i range funziona
    R9=MATR.SOMMA.PRODOTTO(([PCS.xls]prova!$K:$K=Dashboard!$B9)*([PCS.xls]prova!$H:$H=Dashboard!R$8)*([PCS.xls]prova!$G:$G=INDICE(giorni_combinata;Dashboard!$A$8))*([PCS.xls]prova!$J:$J))

    Non so come mettere allegato 1,7 mg

  28. #25
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    LocalitÓ
    Milano
    EtÓ
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Formattazione errata

    Ciao Raffaele,
    un sentito grazie anche alla tua disponibilitÓ.

    Gene

Discussioni Simili

  1. Messaggi di errore per errata scelta nei menu a tendina collegati
    Di ProgrammD69 nel forum Domande su Excel in generale
    Risposte: 23
    Ultimo Messaggio: 04/09/16, 13:13
  2. Importare dati da file HTML scaricata nel pc, formattazione errata
    Di Fabio1972 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 28/09/15, 11:03

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •