Pagina 1 di 2 12 UltimaUltima
Risultati da 1 a 30 di 32

Discussione: problema con cerca.vert



  1. #1
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    problema con cerca.vert

    Ciao a tutti, ho un piccolo problema con una funzione che mi fa un po i capricci. Lo scenario è il seguente: nel foglio SCHEDA non mi vengono visualizzati alcuni dati che si trovano nel foglio ANAMNESI METABOLICA (le celle sono J32 e J34) i quali poi vanno a posizionarsi nelle colonne R ed S del foglio PAZIENTI.

    Le celle in questione si trovano nel foglio SCHEDA e sono: E32, L35 e N37. Con la funzione CERCA.VERT mi carica solo tutta l'anagrafica ma non quei dati di cui sopra.

    Per semplificazione allego file.

    Uso excel 2013 Windows 7 ultimate
    Excel 2010 MAC
    File Allegati File Allegati
    Ultima modifica fatta da:Canapone; 03/05/16 alle 20:01

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183

    Re: formula birichina

    ciao
    per quel che capisco:
    1) il nome anagrafica attualmente NON comprende le colonne dove risiedono i dati che si vuole estrarre (Q,R,S)
    2) il numeri colonna da mettere nelle tre formule sono: il 15, il 16 e il 17
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: formula birichina

    Infatti, come dice ninai Anagrafica non è compresa.

    Se ho ben capito il tuo lavoro, per semplificare potresti usare queste formule:

    =INDICE(PAZIENTI!$Q$2:$Q$38;CONFRONTA(SCHEDA!$B$4;PAZIENTI!$C$2:$C$38;0))

    =INDICE(PAZIENTI!$R$2:$R$38;CONFRONTA(SCHEDA!$B$4;PAZIENTI!$C$2:$C$38;0))

    =INDICE(PAZIENTI!$S$2:$S$38;CONFRONTA(SCHEDA!$B$4;PAZIENTI!$C$2:$C$38;0))
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: formula birichina

    Ciao, si tratta di un problema di riferimento, nel cercavert.
    Copia:
    In E32:
    =CERCA.VERT($B$4;PAZIENTI!$C$1:$S$38;15;FALSO)

    In L35:
    =CERCA.VERT($B$4;PAZIENTI!$C$1:$S$38;16;FALSO)

    In N37:
    =CERCA.VERT($B$4;PAZIENTI!$C$1:$S$38;17;FALSO)
    Ciao fa sapere se va bene.

  5. #5
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    ottimo pkrome59!!!!! grazie anche a ges

  6. #6
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    grazie ges!!!!

  7. #7
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    ...come faccio invece, a collegare un determinato PAZIENTE alla sua anamnesi metabolica?

  8. #8
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    Ottimo funziona! Grazie

    ...come faccio invece, a collegare un determinato PAZIENTE alla sua anamnesi metabolica?
    Ultima modifica fatta da:Canapone; 11/05/17 alle 15:56

  9. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: formula birichina

    Citazione Originariamente Scritto da ceskonet13 Visualizza Messaggio
    ..

    ...come faccio invece, a collegare un determinato PAZIENTE alla sua anamnesi metabolica?
    Non mi è chiara quest'ultima richiesta, cerca di spiegarti meglio ... magari allegando un esempio del risultato che vuoi avere.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  10. #10
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Infatti, come dice ninai Anagrafica non è compresa.

    Se ho ben capito il tuo lavoro, per semplificare potresti usare queste formule:

    =INDICE(PAZIENTI!$Q$2:$Q$38;CONFRONTA(SCHEDA!$B$4;PAZIENTI!$C$2:$C$38;0))

    =INDICE(PAZIENTI!$R$2:$R$38;CONFRONTA(SCHEDA!$B$4;PAZIENTI!$C$2:$C$38;0))

    =INDICE(PAZIENTI!$S$2:$S$38;CONFRONTA(SCHEDA!$B$4;PAZIENTI!$C$2:$C$38;0))
    Grazie ges!!!! secondo te è un problema se si usano due differenti formule? CERCA.VERT per una parte e INDICE per un altra parte

  11. #11

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: formula birichina

    Nessun problema ceskonet, le due formule sono intercambiabili ... io preferisco INDICE/CONFRONTA che è più flessibile rispetto a CERCA.VERT che invece incontra dei limiti nel cercare a sinistra.
    Puoi usare l'una o l'altra o in parte l'una e in parte l'altra a tua scelta.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  12. I seguenti utenti hanno dato un "Like"


  13. #12
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Non mi è chiara quest'ultima richiesta, cerca di spiegarti meglio ... magari allegando un esempio del risultato che vuoi avere.



    Scusa, lo so che spiegare cosa si ha in testa è sempre difficile ma.... ci provo.
    Nel foglio Anamnesi Metabolica, vorrei che al completamento delle risposte (da parte del paziente) ed ottenuto il totale del punteggio il quale determina la frequenza cardiaca di riferimento per poter lavorare in sicurazza. Ecco quella scheda venisse attribuita a quel determinato paziente che si trova nel foglio PAZIENTI.
    Esempio:
    Mario Rossi, dopo aver risposto alle 25 domande ottiene un punteggio di 43
    frequenza cardiaca di riferimento 100 batti al minuto.
    Questi due valori devono apparire nel foglio PAZIENTI
    File Allegati File Allegati

  14. #13
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1

    Re: formula birichina

    Buona Sera

    Hai escluso la possibilita' che due pazienti abbiano lo stesso punteggio e frequenza cardiaca ?

    Saluti
    Window 8.1 Excel 2013/2016

  15. #14
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Nessun problema ceskonet, le due formule sono intercambiabili ... io preferisco INDICE/CONFRONTA che è più flessibile rispetto a CERCA.VERT che invece incontra dei limiti nel cercare a sinistra.
    Puoi usare l'una o l'altra o in parte l'una e in parte l'altra a tua scelta.
    Grazie!!!!:97:

  16. #15
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    Citazione Originariamente Scritto da Pitagora Visualizza Messaggio
    Buona Sera

    Hai escluso la possibilita' che due pazienti abbiano lo stesso punteggio e frequenza cardiaca ?

    Saluti

    ...sapevo di andare inconto ad una situazione simile. a questo punto mi devo affidare e fidare al numero di passaporto metabolico che è univoco e alla data di nascita

  17. #16

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: formula birichina

    In alternativa c'è il vba.

    Vedi se può interessarti

    Codice: 
    Sub inserisci()
    	Dim wks1 As Worksheet, wks2 As Worksheet, wks3 As Worksheet
    	Set wks1 = Worksheets("PAZIENTI")
    	Set wks2 = Worksheets("SCHEDA")
    	Set wks3 = Worksheets("Anamesi Metabolica")
    	wks3.Range("B36") = wks2.Range("B4")
    	For y = 1 To 100
    		If wks1.Range("C" & y) = wks3.Range("B36") Then
    			wks1.Range("R" & y) = wks3.Range("J32")
    			wks1.Range("S" & y) = wks3.Range("J34")
    		End If
    	Next
    	Set wks1 = Nothing
    	Set wks2 = Nothing
    	Set wks3 = Nothing
    End Sub
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  18. #17
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    In alternativa c'è il vba.

    Vedi se può interessarti

    Codice: 
    Sub inserisci()
        Dim wks1 As Worksheet, wks2 As Worksheet, wks3 As Worksheet
        Set wks1 = Worksheets("PAZIENTI")
        Set wks2 = Worksheets("SCHEDA")
        Set wks3 = Worksheets("Anamesi Metabolica")
        wks3.Range("B36") = wks2.Range("B4")
        For y = 1 To 100
            If wks1.Range("C" & y) = wks3.Range("B36") Then
                wks1.Range("R" & y) = wks3.Range("J32")
                wks1.Range("S" & y) = wks3.Range("J34")
            End If
        Next
        Set wks1 = Nothing
        Set wks2 = Nothing
        Set wks3 = Nothing
    End Sub


    Ciao ges, la macro che hai inserito, può essere implementata affinché attribuisca in automatico le celle P21, H28, H42, G45, W40 e Z40 del foglio “SCHEDA” al foglio “PAZIENTI” o in un altro foglio magari da strutturare ad hoc?
    Quello che vorrei ottenere è l’archiviazione di tutti i dati contenuti nel foglio “SCHEDA” (che verrà stampato) al rispettivo paziente così da poterlo ripescare al momento di una seconda verifica.
    Riallego il file.


    grazie!!!

    P.S. scusa se rispondo solo ora ma il lavoro mi ha impedito di farlo prima ;-)
    File Allegati File Allegati

  19. #18

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: formula birichina

    Ciao,
    ho aggiunto le opzioni che hai chiesto.
    Se hai altri suggerimenti o vuoi i dati organizzati in modo diverso fammi sapere.

    P.S. - Ho anche eliminato tutte le formule.

    Codice: 
    Sub inserisci()
        Dim wks1 As Worksheet, wks2 As Worksheet, wks3 As Worksheet
        Set wks1 = Worksheets("PAZIENTI")
        Set wks2 = Worksheets("SCHEDA")
        Set wks3 = Worksheets("Anamesi Metabolica")
        wks3.Range("B36") = wks2.Range("B4")
         For y = 1 To 100
          With wks1
            If .Range("C" & y) = wks3.Range("B36") Then
                    .Range("R" & y) = wks3.Range("J32")
                    .Range("S" & y) = wks3.Range("J34")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("U" & y) = wks2.Range("H28")
                    .Range("V" & y) = wks2.Range("G45")
                    .Range("W" & y) = wks2.Range("V40")
                     wks2.Range("E32") = wks1.Range("Q" & y)
                     wks2.Range("L35") = wks1.Range("R" & y)
                     wks2.Range("N37") = wks1.Range("S" & y)
            End If
          End With
          Next
        Set wks1 = Nothing
        Set wks2 = Nothing
        Set wks3 = Nothing
    End Sub
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  20. #19
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao,
    ho aggiunto le opzioni che hai chiesto.
    Se hai altri suggerimenti o vuoi i dati organizzati in modo diverso fammi sapere.

    P.S. - Ho anche eliminato tutte le formule.

    Codice: 
    Sub inserisci()
        Dim wks1 As Worksheet, wks2 As Worksheet, wks3 As Worksheet
        Set wks1 = Worksheets("PAZIENTI")
        Set wks2 = Worksheets("SCHEDA")
        Set wks3 = Worksheets("Anamesi Metabolica")
        wks3.Range("B36") = wks2.Range("B4")
         For y = 1 To 100
          With wks1
            If .Range("C" & y) = wks3.Range("B36") Then
                    .Range("R" & y) = wks3.Range("J32")
                    .Range("S" & y) = wks3.Range("J34")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("U" & y) = wks2.Range("H28")
                    .Range("V" & y) = wks2.Range("G45")
                    .Range("W" & y) = wks2.Range("V40")
                     wks2.Range("E32") = wks1.Range("Q" & y)
                     wks2.Range("L35") = wks1.Range("R" & y)
                     wks2.Range("N37") = wks1.Range("S" & y)
            End If
          End With
          Next
        Set wks1 = Nothing
        Set wks2 = Nothing
        Set wks3 = Nothing
    End Sub

    Ciao ges,
    succede una cosa strana...! nel foglio "SCHEDA", quando seleziono il nome di un paziente i campi dell'anagrafica si popolano (con i dati giusti del paziente) ma non si aggiornano tutti gli altri dati. Eppure nel foglio "PAZIENTI" sono collocati in maniera corretta. Se riapri il file ti accorgi subito di cosa sto parlando.
    Quali formule hai eliminato?

  21. #20

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: formula birichina

    Quando cambio il nome vedo cambiare i dati del foglio scheda (nascita, indirizzo, ecc.) li vedo cambiare ... non capisco cosa intendi ... quali celle non si modificano e invece dovrebbero farlo?
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  22. #21

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: formula birichina

    Ho capito.
    Avevo cancellato delle formule nel foglio scheda, per inserire i dati col vba invece ti servivano prima dell'inserimento ... ora le ho rimesse.
    Prova col file allegato qui.

    Codice: 
    Sub inserisci()
        Dim wks1 As Worksheet, wks2 As Worksheet, wks3 As Worksheet
        Set wks1 = Worksheets("PAZIENTI")
        Set wks2 = Worksheets("SCHEDA")
        Set wks3 = Worksheets("Anamesi Metabolica")
        wks3.Range("B36") = wks2.Range("B4")
         For y = 1 To 100
          With wks1
            If .Range("C" & y) = wks3.Range("B36") Then
                    .Range("R" & y) = wks3.Range("J32")
                    .Range("S" & y) = wks3.Range("J34")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("U" & y) = wks2.Range("H28")
                    .Range("V" & y) = wks2.Range("G45")
                    .Range("W" & y) = wks2.Range("V40")
                    
            End If
          End With
          Next
        Set wks1 = Nothing
        Set wks2 = Nothing
        Set wks3 = Nothing
    End Sub
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  23. I seguenti utenti hanno dato un "Like"


  24. #22
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ho capito.
    Avevo cancellato delle formule nel foglio scheda, per inserire i dati col vba invece ti servivano prima dell'inserimento ... ora le ho rimesse.
    Prova col file allegato qui.

    Codice: 
    Sub inserisci()
        Dim wks1 As Worksheet, wks2 As Worksheet, wks3 As Worksheet
        Set wks1 = Worksheets("PAZIENTI")
        Set wks2 = Worksheets("SCHEDA")
        Set wks3 = Worksheets("Anamesi Metabolica")
        wks3.Range("B36") = wks2.Range("B4")
         For y = 1 To 100
          With wks1
            If .Range("C" & y) = wks3.Range("B36") Then
                    .Range("R" & y) = wks3.Range("J32")
                    .Range("S" & y) = wks3.Range("J34")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("U" & y) = wks2.Range("H28")
                    .Range("V" & y) = wks2.Range("G45")
                    .Range("W" & y) = wks2.Range("V40")
                    
            End If
          End With
          Next
        Set wks1 = Nothing
        Set wks2 = Nothing
        Set wks3 = Nothing
    End Sub
    ...purtroppo non funziona ancora.
    Guarda il nuovo file in allegato, ti ho segnato con dei cerchi rossi i campi che non cambiano al variare del paziente. Per rendere meglio l'idea, dal foglio SCHEDA, ho popolato tutti i campi con testo diverso per ogni paziente (infatti, nel foglio PAZIENTI si vedono in maniera corretta). Mentre, nel foglio ANAMNESI METABOLICA, temo di aver inserito una formula che non funziona come dovrebbe. Ti ho messo delle note in rosso.
    File Allegati File Allegati

  25. #23

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: formula birichina

    Quindi non è il codice che non funziona ma le formule del foglio "Anamesi Metabolica" .. ma io qui non ho toccato nulla.
    Mi evidenzi la formula nella cella J35 =INDICE($C$31:$C$33;CONFRONTA(1;FREQUENZA(J32;{35.45.56});0);0) per correggerla dovrei capire che risultato dovrebbe dare in base a quale condizione (non so neanche cosa sia il FC di Riferimento (bpm) :)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  26. #24
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Quindi non è il codice che non funziona ma le formule del foglio "Anamesi Metabolica" .. ma io qui non ho toccato nulla.
    Mi evidenzi la formula nella cella J35 =INDICE($C$31:$C$33;CONFRONTA(1;FREQUENZA(J32;{35.45.56});0);0) per correggerla dovrei capire che risultato dovrebbe dare in base a quale condizione (non so neanche cosa sia il FC di Riferimento (bpm) :)
    ...allora, provo a spiegarmi con un esempio.
    Siamo nel foglio "Anamnesi Metabolica", la colonna (J) contiene i punti da attribuire ad ogni domanda, la cella J32 contiene il totale dei punti della colonna (J) utilizzando questa formula: =SOMMA(J4:J28). La cella J34, invece, mi restituisce attraverso questa formula: =INDICE($C$31:$C$33;CONFRONTA(1;FREQUENZA(J32;{35;45;56});0);0) a quale frequenza cardiaca il soggetto deve lavorare.

    Questo dato (frequenza cardiaca di riferimento) lo si ricava da questa tabella:
    fino a 35 punti la frequenza di riferimento è 110 bpm
    da 36 a 45 punti la frequenza di riferimento è 100 bpm
    oltre 46 punti la frequenza di riferimento è 90 bpm

    Spero di essermi spiegato :-(

  27. #25

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: formula birichina

    Ho capito, la formula non funzione perchè c'è un errore.

    =INDICE($C$31:$C$33;CONFRONTA(1;FREQUENZA(J32;{35;45;56});0);0) c'è lo zero che sta a significare "corrispondenza esatta" cioè confronta il primo valore esattamente uguale a "valore" mentre se è omesso (o è 1) cerca il valore più grande minore o uguale a "valore", fermo restando che la sequenza sia in ordine ascendente.

    Nel tuo caso la formula giusta è:

    =INDICE($C$31:$C$33;CONFRONTA(1;FREQUENZA(J32;{35.45.56}););0)

    Tuttavia, ne potresti usare una più semplice che non ha bisogno di riferimenti ad altre celle e fa altrettanto bene il suo lavoro:

    =SE(J32<=35;110;SE(E(J32>35;J32<=45);100;SE(J32>46;90)))


    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  28. #26
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ho capito, la formula non funzione perchè c'è un errore.

    =INDICE($C$31:$C$33;CONFRONTA(1;FREQUENZA(J32;{35;45;56});0);0) c'è lo zero che sta a significare "corrispondenza esatta" cioè confronta il primo valore esattamente uguale a "valore" mentre se è omesso (o è 1) cerca il valore più grande minore o uguale a "valore", fermo restando che la sequenza sia in ordine ascendente.

    Nel tuo caso la formula giusta è:

    =INDICE($C$31:$C$33;CONFRONTA(1;FREQUENZA(J32;{35.45.56}););0)

    Tuttavia, ne potresti usare una più semplice che non ha bisogno di riferimenti ad altre celle e fa altrettanto bene il suo lavoro:

    =SE(J32<=35;110;SE(E(J32>35;J32<=45);100;SE(J32>46;90)))


    Ciao ges,
    perfetto, con la formula corretta i dati del foglio "ANAMNESI METABOLICA" funziona.
    Continuano invece, a non funzionare nel foglio "SCHEDA" le celle P21, H28, V40, H41, G45 e C51. Non riesco a capire il perchè. Boh!!!! Non è che nella macro non ci sono i riferimenti corretti?
    Ti riallego il file.
    File Allegati File Allegati

  29. #27

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: formula birichina

    Ho capito, in quelle celle te li ho cancellato io le formule ecco perchè non funzionano, perchè avevo capito che tu riempivi a mano nei rispettivi campi del foglio SCHEDA quei dati che poi con la macro facevo si che si archiviavano nel foglio PAZIENTI.
    Posso rimetterle senza problemi, però ho questo dubbio:
    - se inserisco le formule nel foglio SCHEDA questi dati devo ricavarli dal foglio PAZIENTI ma tu in quale foglio e celle li inserisci manualmente?

    Ti faccio un esempio pratico: nel foglio SCHEDA la risposta in H41 da dova la prendi?
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  30. #28
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ho capito, in quelle celle te li ho cancellato io le formule ecco perchè non funzionano, perchè avevo capito che tu riempivi a mano nei rispettivi campi del foglio SCHEDA quei dati che poi con la macro facevo si che si archiviavano nel foglio PAZIENTI.
    Posso rimetterle senza problemi, però ho questo dubbio:
    - se inserisco le formule nel foglio SCHEDA questi dati devo ricavarli dal foglio PAZIENTI ma tu in quale foglio e celle li inserisci manualmente?

    Ti faccio un esempio pratico: nel foglio SCHEDA la risposta in H41 da dova la prendi?

    Ciao,
    compilo quei dati -a mano- nel foglio SCHEDA, e poi da li devono essere archiviati nel foglio PAZIENTI. così quando li vado a richiamare per la verifica o per una stampa mi ritrovo con i dati corretti e non con l'anagrafica corretta e una parte della scheda con dati di un altra persona.
    La risposta in H41 la inserisco a mano.
    Buona giornata

  31. #29

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: formula birichina

    Ciao,
    per ora ti sistemo il foglio in modo che le formula si inseriscono in automatico, quando ho più tempo vedrò di migliorarlo.

    Codice: 
    Sub inserisci()
        Dim wks1 As Worksheet, wks2 As Worksheet, wks3 As Worksheet, y As Integer
        Set wks1 = Worksheets("PAZIENTI")
        Set wks2 = Worksheets("SCHEDA")
        Set wks3 = Worksheets("Anamesi Metabolica")
        wks3.Range("B36") = wks2.Range("B4")
        For y = 1 To 100
            With wks1
                If .Range("C" & y) = wks3.Range("B36") Then
                    .Range("A" & y) = wks2.Range("X4")
                    .Range("D" & y) = wks2.Range("G7")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("R" & y) = wks3.Range("J32")
                    .Range("S" & y) = wks3.Range("J34")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("F" & y) = wks2.Range("V7")
                    .Range("G" & y) = wks2.Range("G60")
                    .Range("J" & y) = wks2.Range("G10")
                    .Range("H" & y) = wks2.Range("G11")
                    .Range("I" & y) = wks2.Range("T11")
                    .Range("L" & y) = wks2.Range("S13")
                    .Range("M" & y) = wks2.Range("G14")
                    .Range("N" & y) = wks2.Range("G15")
                    .Range("O" & y) = wks2.Range("G17")
                    .Range("U" & y) = wks2.Range("H28")
                    .Range("R" & y) = wks2.Range("L35")
                    .Range("S" & y) = wks2.Range("N37")
                    .Range("W" & y) = wks2.Range("V40")
                    .Range("X" & y) = wks2.Range("H41")
                    .Range("V" & y) = wks2.Range("G45")
                    .Range("B" & y) = wks2.Range("E49")
                End If
            End With
        Next
        With wks2
            .Range("P21").FormulaLocal = "=INDICE(PAZIENTI!T2:T10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("H28").FormulaLocal = "=INDICE(PAZIENTI!U2:U10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("V40").FormulaLocal = "=INDICE(PAZIENTI!W2:W10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("H41").FormulaLocal = "=INDICE(PAZIENTI!X2:X10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G45").FormulaLocal = "=INDICE(PAZIENTI!V2:V10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G7").FormulaLocal = "=INDICE(PAZIENTI!D2:D100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("X4").FormulaLocal = "=INDICE(PAZIENTI!A2:A100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("O7").FormulaLocal = "=INDICE(PAZIENTI!E2:E100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("V7").FormulaLocal = "=INDICE(PAZIENTI!F2:F100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G9").FormulaLocal = "=INDICE(PAZIENTI!G2:G100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G10").FormulaLocal = "=INDICE(PAZIENTI!J2:J100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G11").FormulaLocal = "=INDICE(PAZIENTI!H2:H100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("T11").FormulaLocal = "=INDICE(PAZIENTI!I2:I100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G13").FormulaLocal = "=INDICE(PAZIENTI!K2:K100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("S13").FormulaLocal = "=INDICE(PAZIENTI!L2:L100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G14").FormulaLocal = "=INDICE(PAZIENTI!M2:M100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G15").FormulaLocal = "=INDICE(PAZIENTI!N2:N100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G17").FormulaLocal = "=INDICE(PAZIENTI!O2:O100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("E32").FormulaLocal = "=INDICE(PAZIENTI!Q2:Q10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("L35").FormulaLocal = "=INDICE(PAZIENTI!r2:r10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("N37").FormulaLocal = "=INDICE(PAZIENTI!S2:S10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("E49").FormulaLocal = "=INDICE(PAZIENTI!B2:B10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
        End With
        Set wks1 = Nothing
        Set wks2 = Nothing
        Set wks3 = Nothing
    End Sub
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  32. #30
    L'avatar di ceskonet13
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Milano
    Messaggi
    132
    Versione Office
    Excel 2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: formula birichina

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao,
    per ora ti sistemo il foglio in modo che le formula si inseriscono in automatico, quando ho più tempo vedrò di migliorarlo.

    Codice: 
    Sub inserisci()
        Dim wks1 As Worksheet, wks2 As Worksheet, wks3 As Worksheet, y As Integer
        Set wks1 = Worksheets("PAZIENTI")
        Set wks2 = Worksheets("SCHEDA")
        Set wks3 = Worksheets("Anamesi Metabolica")
        wks3.Range("B36") = wks2.Range("B4")
        For y = 1 To 100
            With wks1
                If .Range("C" & y) = wks3.Range("B36") Then
                    .Range("A" & y) = wks2.Range("X4")
                    .Range("D" & y) = wks2.Range("G7")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("R" & y) = wks3.Range("J32")
                    .Range("S" & y) = wks3.Range("J34")
                    .Range("T" & y) = wks2.Range("P21")
                    .Range("F" & y) = wks2.Range("V7")
                    .Range("G" & y) = wks2.Range("G60")
                    .Range("J" & y) = wks2.Range("G10")
                    .Range("H" & y) = wks2.Range("G11")
                    .Range("I" & y) = wks2.Range("T11")
                    .Range("L" & y) = wks2.Range("S13")
                    .Range("M" & y) = wks2.Range("G14")
                    .Range("N" & y) = wks2.Range("G15")
                    .Range("O" & y) = wks2.Range("G17")
                    .Range("U" & y) = wks2.Range("H28")
                    .Range("R" & y) = wks2.Range("L35")
                    .Range("S" & y) = wks2.Range("N37")
                    .Range("W" & y) = wks2.Range("V40")
                    .Range("X" & y) = wks2.Range("H41")
                    .Range("V" & y) = wks2.Range("G45")
                    .Range("B" & y) = wks2.Range("E49")
                End If
            End With
        Next
        With wks2
            .Range("P21").FormulaLocal = "=INDICE(PAZIENTI!T2:T10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("H28").FormulaLocal = "=INDICE(PAZIENTI!U2:U10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("V40").FormulaLocal = "=INDICE(PAZIENTI!W2:W10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("H41").FormulaLocal = "=INDICE(PAZIENTI!X2:X10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G45").FormulaLocal = "=INDICE(PAZIENTI!V2:V10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G7").FormulaLocal = "=INDICE(PAZIENTI!D2:D100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("X4").FormulaLocal = "=INDICE(PAZIENTI!A2:A100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("O7").FormulaLocal = "=INDICE(PAZIENTI!E2:E100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("V7").FormulaLocal = "=INDICE(PAZIENTI!F2:F100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G9").FormulaLocal = "=INDICE(PAZIENTI!G2:G100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G10").FormulaLocal = "=INDICE(PAZIENTI!J2:J100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G11").FormulaLocal = "=INDICE(PAZIENTI!H2:H100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("T11").FormulaLocal = "=INDICE(PAZIENTI!I2:I100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G13").FormulaLocal = "=INDICE(PAZIENTI!K2:K100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("S13").FormulaLocal = "=INDICE(PAZIENTI!L2:L100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G14").FormulaLocal = "=INDICE(PAZIENTI!M2:M100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G15").FormulaLocal = "=INDICE(PAZIENTI!N2:N100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("G17").FormulaLocal = "=INDICE(PAZIENTI!O2:O100;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("E32").FormulaLocal = "=INDICE(PAZIENTI!Q2:Q10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("L35").FormulaLocal = "=INDICE(PAZIENTI!r2:r10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("N37").FormulaLocal = "=INDICE(PAZIENTI!S2:S10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
            .Range("E49").FormulaLocal = "=INDICE(PAZIENTI!B2:B10;CONFRONTA(SCHEDA!B4;PAZIENTI!C2:C100;0))"
        End With
        Set wks1 = Nothing
        Set wks2 = Nothing
        Set wks3 = Nothing
    End Sub

    ...grazie ges.
    In che modo vorresti migliorarlo?

Discussioni Simili

  1. [Risolto] Problema formula cerca.vert con utilizzo funzione valore
    Di Ale64 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 02/01/17, 20:11
  2. [Risolto] Cerca valori che si ripetono in tabella. Formula per arrivare dove il cerca.vert non può
    Di Gatt88 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 02/12/16, 11:45
  3. [Risolto] Ho un problema con CERCA.VERT
    Di Florence nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 22/05/16, 13:47
  4. problema con funzione CERCA.VERT
    Di Michele P. nel forum Domande su Excel in generale
    Risposte: 18
    Ultimo Messaggio: 07/05/16, 22:04
  5. problema con cerca.vert
    Di Stefano nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 29/12/15, 23:39

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •