Risultati da 1 a 7 di 7

Discussione: Riepilogo Giornaliero da Prima nota



  1. #1
    L'avatar di Ephemera
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    La Spezia
    Messaggi
    4
    Versione Office
    Libre Office
    Likes ricevuti
    0
    Likes dati
    2

    Riepilogo Giornaliero da Prima nota

    Salve

    Ho un problema che non riesco a risolvere: non so come ottenere un riepilogo giornaliero da un foglio dove ci sono piu referenze relative ad una giornata.
    Allego un file d'esempio.
    File Allegati File Allegati

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Riepilogo Giornaliero da Prima nota

    Ciao
    hai Provato con il SOMMA.SE?

    Prova questa

    =SOMMA.SE($A$6:$A$11;D6;$B$6:$B$11)

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Riepilogo Giornaliero da Prima nota

    Ciao,
    usa questa formula in E6 da trascinare in basso:

    =MATR.SOMMA.PRODOTTO(($A$6:$A$11=D6)*($B$6:$B$11))




    Edit: Ciao Gerardo, mi hai anticipato.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4
    L'avatar di Ephemera
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    La Spezia
    Messaggi
    4
    Versione Office
    Libre Office
    Likes ricevuti
    0
    Likes dati
    2

    Re: Riepilogo Giornaliero da Prima nota

    Grazie ragazzi la imposto subito!

  5. #5
    L'avatar di Silvio65
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Milano
    Messaggi
    134
    Versione Office
    2013 WIN
    Likes ricevuti
    9
    Likes dati
    28

    Re: Riepilogo Giornaliero da Prima nota

    Buonasera, scusate se m'inesrisco nella discussione con una domanda forse banale e stupida.
    Ho provato la formula di Ges e funziona benissimo, la mia domanda è:
    perche' dopo MATR.SOMMA.PRODOTTO devo inserire due parentesi ((. ?
    Inserendo solo una parentesi la formula non funziona.

    Grazie mille

  6. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Riepilogo Giornaliero da Prima nota

    Citazione Originariamente Scritto da Silvio65 Visualizza Messaggio
    .. la mia domanda è:
    perche' dopo MATR.SOMMA.PRODOTTO devo inserire due parentesi ((. ?
    Inserendo solo una parentesi la formula non funziona.

    ..
    Ciao,
    cerco di risponderti in modo più semplice possibile.

    La funzione MATR.SOMMA.PRODOTTO moltiplica i valori nelle matrici e ne somma il risultato.

    Nella formula sopra riportata si hanno due singole matrici :

    1) -
    ($A$6:$A$11=D6)


    2) - $B$6:$B$11

    La formula "vuota" è così
    =MATR.SOMMA.PRODOTTO(...................)

    Riempiendo la formula così =MATR.SOMMA.PRODOTTO($A$6:$A$11=D6*$B$6:$B$11) per il principio dell'ordine delle operazioni si svolgono prima le moltiplicazioni e divisioni da sinistra verso destra, ciò comporterebbe

    che D6 verrebbe
    moltiplicato con l'intervallo $B$6:$B$11, che non è quello che vogliamo perchè D6 rappresenta la condizione dell'intervallo $A$6:$A$11, dunque per far eseguire le operazioni raggruppate tra parentesi bisogna

    metter tra parentesi la matrice con la sua condizione (
    $A$6:$A$11=D6).

    Per questo vanno messe le due parentesi all'inizio; al limite si potrebbe anche lasciare così =MATR.SOMMA.PRODOTTO(($A$6:$A$11=D6)*$B$6:$B$11) - le parentesi rosse appartengono alla formula - e sempre per il

    principio dell'ordine delle operazioni la prima matrice tra parentesi verrebbe moltiplicata per la seconda ottenendo il medesimo risultato, tuttavia - a mio avviso - è buona abitudine - anche se non è indispensabile -

    racchiudere anche la seconda matrice tra parentesi così non si rischia nel caso anche per questa si è utilizzati una condizione di generare un errore e in questo caso ci troviamo le due parentesi anche alla fine poichè una

    appartiene alla formula e una racchiude la matrice.

    Se non ci fossero condizioni ma solo valori numerici e si vorrebbe ottenere la loro somma (non è questo il caso) si potrebbe anche lasciare così: =MATR.SOMMA.PRODOTTO($A$6:$A$11*$B$6:$B$11)

    Spero di essere stato chiaro.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  7. #7
    L'avatar di Silvio65
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Milano
    Messaggi
    134
    Versione Office
    2013 WIN
    Likes ricevuti
    9
    Likes dati
    28

    Re: Riepilogo Giornaliero da Prima nota

    Sei stato chiarissimo.
    Grazie mille Ges

Discussioni Simili

  1. Nota spese
    Di simone. nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 10/09/16, 00:06
  2. riepilogo
    Di seba nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 05/09/16, 10:34
  3. incasso giornaliero con codici articolo
    Di pinnighi nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 18/05/16, 18:37
  4. Excel 16 - prima impressione negativa
    Di FrancoR nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 23/12/15, 23:52
  5. Riepilogo attivita'
    Di klaudios nel forum Domande su Excel in generale
    Risposte: 21
    Ultimo Messaggio: 28/11/15, 09:14

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •