Risultati da 1 a 5 di 5

Discussione: Analisi e Estrazione dati dinamica



  1. #1
    L'avatar di iea76
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Milano
    Messaggi
    2
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Analisi e Estrazione dati dinamica

    buongiorno a tutti,
    chiedo il vostro aiuto per impostare un semplice cruscotto per l'analisi dei dati di vendita su base mensile e ytd.
    il cruscotto dovrebbe avere un template pre impostato ed estrarre i dati sulla base dei criteri di scelta imputati dall'utente (criterio 1: mercato di riferimento; criterio 2: mese; criterio 3 tipologia confronto: su base mensile oppure su base ytd),

    Allego un semplice file di excel con pochi dati per farvi capire meglio le esigenze. Grazie mille per il vs aiuto.
    Andrea
    File Allegati File Allegati

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7140
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Analisi e Estrazione dati dinamica

    Ciao,
    ho messo le formule nei tuoi esempi per trovare i dati voluti:

    In C23: =MATR.SOMMA.PRODOTTO($F$4:$F$9*($D$4:$D$9=B23))

    In G23: =MATR.SOMMA.PRODOTTO((E4:F9)*($D$4:$D$9=D4))

    In L23:=MATR.SOMMA.PRODOTTO(($F$4:$F$9)*($D$4:$D$9=K23))

    In P23: =MATR.SOMMA.PRODOTTO(($E$4:$F$9)*($D$4:$D$9=O23))

    da trascinare in basso.

    Ma non mi è chiaro dove vuoi il menu a tendina.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di iea76
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Milano
    Messaggi
    2
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Analisi e Estrazione dati dinamica

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao,
    ho messo le formule nei tuoi esempi per trovare i dati voluti:

    In C23: =MATR.SOMMA.PRODOTTO($F$4:$F$9*($D$4:$D$9=B23))

    In G23: =MATR.SOMMA.PRODOTTO((E4:F9)*($D$4:$D$9=D4))

    In L23:=MATR.SOMMA.PRODOTTO(($F$4:$F$9)*($D$4:$D$9=K23))

    In P23: =MATR.SOMMA.PRODOTTO(($E$4:$F$9)*($D$4:$D$9=O23))

    da trascinare in basso.

    Ma non mi è chiaro dove vuoi il menu a tendina.
    Grazie mille GES, ma non sembra funzionare, o meglio non risolvo pienamente quello che sto cercando: rendere dinamico il risultato sulla base dei criteri che scelto.
    Una volta scelti i criteri, dando all'utente la possibilità di scelta tra valori pre impostati (menù a tendina in D12, D13 e D14 per scegliere mercato, mese e confronto), il report dovrebbe in automatico estrarmi i dati sulla base di quei criteri.

    Applicando ad esempio in C23 la formula MATR.SOMMA.PRODOTTO($F$4:$F$9*($D$4:$D$9=B23)) do per scontato che il mese di febbraio sia assoluto e non relativo e quindi il report non estragga i valori sulla base del criterio in questione. Stesso discorso per il caso del report ytd.

    Potreste pf provare a lavorare direttamente sul file excel ? Grazie mille a tutti!
    Andrea

  5. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Analisi e Estrazione dati dinamica

    Ciao Iea76, benvenuto in forumexcel.it

    prova questa formula nella cella C23 e trascinala in basso:

    =SOMMA.PIÙ.SE(INDICE($E$4:$G$9;;CONFRONTA("feb";$E$3:$G$3;0));$D$4:$D$9;B23;$C$4:$C$9;"ita")

    ovviamente adesso sarai tu ad adattare la stessa formula per le celle G23 e L23

    @Iea76 ti consiglio di mettere sempre i criteri in una cella esterna cosi che al cambiare del criterio si cambiano anche i dati senza dover necessariamente rimodificare la formula, esempio "feb"
    o "ita" tra virgolette (vedi in rosso)

    fai sapere se va bene
    Un saluto!



  6. #5
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2293
    Versione Office
    Excel 2010
    Likes ricevuti
    910
    Likes dati
    451

    Re: Analisi e Estrazione dati dinamica

    Salve a tutti, oltre a quanto detto da Ges e Gerardo (che saluto) ti allego il file con qualche modifica sulla formula di Gerardo (solo 2 delle 4 tabelle quelle in giallo) che tiene conto del menu a tendina per la scelta.
    Per le altre tabelle non mi è tanto chiaro il calcolo se devi tener conto di tutti i mesi precedenti alla scelta in D13 o cosa altro.
    File Allegati File Allegati

Discussioni Simili

  1. Procedura analisi dati
    Di Saymon nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 12/12/16, 20:13
  2. Analisi dati
    Di ziolardo nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 06/09/16, 01:25
  3. Analisi dei dati
    Di undiva nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 12/07/16, 09:59
  4. Importazione file ed analisi dati
    Di G.Bove nel forum Domande su Excel in generale
    Risposte: 20
    Ultimo Messaggio: 13/12/15, 07:42
  5. Analisi dati
    Di Emanuele nel forum Domande su Excel in generale
    Risposte: 18
    Ultimo Messaggio: 18/08/15, 13:24

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •