Risultati da 1 a 7 di 7

Discussione: Copiare dati senza lasciare spazi vuoti



  1. #1
    L'avatar di lala10
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    N/D
    Messaggi
    68
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    16

    Copiare dati senza lasciare spazi vuoti

    Ciao a tutti, nel "foglio 2" del file allegato devo riportare solo i CARTELLINI che nella colonna B del foglio 1 presentano la parola "MANOV.A", ho bisogno quindi di una formula e non dell'utilizzo dei filtri perchè ho moltissimi dati e voglio rendere tutto autonomo.
    E' importante che non vengano lasciate righe vuote nel foglio 2.
    Vi ringrazio tutti e spero in un vostro riscontro!
    File Allegati File Allegati

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: Copiare dati senza lasciare spazi vuoti

    Ciao,

    =SE.ERRORE(INDICE(Foglio1!$A$2:$A$21;AGGREGA(15;6;(RIF.RIGA($A$2:$A$21)-RIF.RIGA($A$2)+1)/(Foglio1!$B$2:$B$21="MANOV.A");RIGHE($A$1:A1)));"")


    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3

    L'avatar di alfrimpa
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Napoli
    Età
    64
    Messaggi
    6747
    Versione Office
    2013
    Likes ricevuti
    711
    Likes dati
    162

    Re: Copiare dati senza lasciare spazi vuoti

    Oppure una soluzione in VBA

    Codice: 
    Sub copiaSenzaSpazi()
    Dim ur As Long
    Dim lr As Long
    Dim rng As Range
    Dim cel As Range
    lr = Worksheets("Foglio1").Cells(Rows.Count, 1).End(xlUp).Row
    Set rng = Worksheets("Foglio1").Range("a1:a" & lr)
    For Each cel In rng
    ur = Worksheets("Foglio2").Cells(Rows.Count, 1).End(xlUp).Row
        If cel.Offset(0, 1) = "MANOV.A" Then
            cel.Copy Destination:=Worksheets("Foglio2").Range("a" & ur + 1)
        End If
    Next cel
    End Sub
    Alfredo

  4. #4
    L'avatar di lala10
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    N/D
    Messaggi
    68
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    16

    Re: Copiare dati senza lasciare spazi vuoti

    Ciao il file precedente conteneva cartellini ripetuti più volte, ti allego il file giusto. Qui ho applicato la formula da te scritta ma non mi restituisce tutti i cartellini e soprattutto ne ripete alcuni...perchè?:223:
    File Allegati File Allegati

  5. #5
    L'avatar di lala10
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    N/D
    Messaggi
    68
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    16

    Re: Copiare dati senza lasciare spazi vuoti

    Ti ringrazio molto alfrimpa ma se riesco preferisco una formula per questo tipo di lavoro dato che non sono molto pratica con le vba! Se non dovessi trovare una formula adatta seguirò il tuo consiglio grazie mille ancora :)

  6. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: Copiare dati senza lasciare spazi vuoti

    Citazione Originariamente Scritto da lala10 Visualizza Messaggio
    Ciao il file precedente conteneva cartellini ripetuti più volte, ti allego il file giusto. Qui ho applicato la formula da te scritta ma non mi restituisce tutti i cartellini e soprattutto ne ripete alcuni...perchè?:223:
    Perchè nella formula che hai inserito è sfuggito il riferimento assoluto

    =SE.ERRORE(INDICE(Foglio1!$A$2:$A$21;AGGREGA(15;6;(RIF.RIGA($A$2:$A$21)-RIF.RIGA($A$2)+1)/(Foglio1!$B$2:$B$21="MANOV.A");RIGHE($A$1:A1)));"")

    L'ho sistemato, ti riallego il file.
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  7. #7
    L'avatar di lala10
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    N/D
    Messaggi
    68
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    16

    Re: Copiare dati senza lasciare spazi vuoti

    Hai ragione :166: ti ringrazio moltissimo!!

Discussioni Simili

  1. [Risolto] copiare da una tabella solo le celle piene senza lasciare spazzi aggiuntivi
    Di Eddie18 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 22/10/16, 12:52
  2. [Risolto] Copiare una tabella da un altro file excel senza alterare le formule
    Di Roker1 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 11/10/16, 20:44
  3. Inserie spazi vuoti automaticamente in serie di numeri in una colonna
    Di tigertaffa nel forum Domande su Excel VBA e MACRO
    Risposte: 10
    Ultimo Messaggio: 29/09/16, 01:53
  4. Macro per Archiviare i dati che però deve lasciare le formule attive
    Di Gerardo Zuccalà nel forum Domande su Excel VBA e MACRO
    Risposte: 10
    Ultimo Messaggio: 14/06/16, 14:17
  5. Annulla spazi vuoti
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 20/07/15, 18:06

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •