Risultati da 1 a 7 di 7

Discussione: restituire il primo valore maggiore o minore di



  1. #1
    L'avatar di Tequila
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Cittadella
    Età
    42
    Messaggi
    54
    Versione Office
    2010 e 2016
    Likes ricevuti
    0
    Likes dati
    9

    restituire il primo valore maggiore o minore di

    Ho fatto una ricerca sul forum con "maggiore e minore" ma nelle varie discussioni lette non sono riuscito a trovare quello che fa per me.

    Su una tabella ho un elenco di valori numerici. Ho la necessità di eseguire una ricerca in modo tale che mi venga restituito su una cella il primo valore maggiore della mia ricerca e in un'altra cella il primo valore minore/uguale rispetto a quello ricercato. Ho provato a spulciare su excel e sull'help qualcosa che potesse fare al caso mio ma non trovo con quale logica inserire la formula che mi cerchi e restituisca il valore desiderato.

    Qualcuno ha già affrontato qualcosa di analogo che mi può aiutare?
    File Allegati File Allegati
    Non confondere mancanza di talento per genialità.

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7153
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2064
    Likes dati
    1300

    Re: restituire il primo valore maggiore o minore di

    Per trovare il minore dovrebbe andare questa formula (matriciale):

    =INDICE($A$2:$A$17;CONFRONTA(PICCOLO(ASS($D$2-$A$2:$A$17);1);ASS($D$2-$A$2:$A$17);0))

    o questa:

    =MIN(SE(ASS($A$2:$A$17-D2)=MIN(ASS($A$2:$A$170-D2));$A$2:$A$17;""))

    Per il maggiore questa:

    =INDICE($A$2:$A$17;CONFRONTA(PICCOLO(ASS(($D$2)-$A$2:$A$17);2);ASS(($D$2)-$A$2:$A$17);0))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. I seguenti 2 utenti hanno dato un "Like" a ges per questo post:


  4. #3
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: restituire il primo valore maggiore o minore di

    Ciao Tequila, se ho capito bene, copia le seguenti:

    In D5:
    =INDICE($A$2:$A$17;AGGREGA(15;6;(RIF.RIGA($A$2:$A$17)-RIF.RIGA($A$2)+1)/($A$2:$A$17>$D$2);1))

    In D6:
    =INDICE($A$2:$A$17;AGGREGA(14;6;(RIF.RIGA($A$2:$A$17)-RIF.RIGA($A$2)+1)/($A$2:$A$17<=$D$2);1))

    Fa sapere se vanno bene.
    Allego il file di prova.
    Ciao.

    P.S. Scusa Ges, se mi sono sovrapposto, come al solito mi bruci sul tempo, sei un fulmine oltre che bravo. colgo l'occasione per salutarti.
    Ciao a tutti.
    File Allegati File Allegati

  5. I seguenti 2 utenti hanno dato un "Like" a pkrome59 per questo post:


  6. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7153
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2064
    Likes dati
    1300

    Re: restituire il primo valore maggiore o minore di

    Tequila ora non ha che l'imbarazzo della scelta! :286:

    Ciao pkrome, le tue formule sono tanto semplici quanto geniali!:98:
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  7. I seguenti utenti hanno dato un "Like"


  8. #5
    L'avatar di Tequila
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Cittadella
    Età
    42
    Messaggi
    54
    Versione Office
    2010 e 2016
    Likes ricevuti
    0
    Likes dati
    9

    Re: restituire il primo valore maggiore o minore di

    Come al solito siete fenomenali, grazie a tutti e due ges e pkrome59.
    A questa formula non ci sarei mai arrivato... ancora troppo acerbe le mie conoscenze su ricerche come queste.

    Grazie!!!
    Non confondere mancanza di talento per genialità.

  9. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: restituire il primo valore maggiore o minore di

    Giusto per accorciarla un pochettino
    Scopiazzando dalla formula di Proke da confermare con CTRL+SHIFT+ENTER

    =INDICE($A$2:$A$17;MIN(SE($A$2:$A$17>$D$2;RIF.RIGA($A$2:$A$17)-RIF.RIGA($A$2)+1)))

    =INDICE($A$2:$A$17;MAX(SE($A$2:$A$17<=$D$2;RIF.RIGA($A$2:$A$17)-RIF.RIGA($A$2)+1)))

    Saluti a tutti

  10. I seguenti 3 utenti hanno dato un "Like" a Gerardo Zuccalà per questo post:


  11. #7
    L'avatar di Tequila
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    Cittadella
    Età
    42
    Messaggi
    54
    Versione Office
    2010 e 2016
    Likes ricevuti
    0
    Likes dati
    9

    Re: restituire il primo valore maggiore o minore di

    ho appena provato e tutte le soluzioni funzionano correttamente, non mi resta che l'imbarazzo della scelta :166:

    grazie!!!
    Non confondere mancanza di talento per genialità.

Discussioni Simili

  1. [Risolto] ricerca in matrice con più condizioni (con MAGGIORE & MINORE)
    Di nemoclipru nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 14/01/17, 11:44
  2. [Risolto] Maggiore minore
    Di nicocaporale nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 03/11/16, 11:28
  3. [Risolto] Aumentare il valore di un numero verificando con maggiore / minore
    Di Samuela nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 31/10/16, 13:51
  4. Risposte: 3
    Ultimo Messaggio: 07/07/16, 20:45
  5. se minore di , se maggiore di, mostra
    Di Andrea_Ra nel forum Domande su Excel in generale
    Risposte: 17
    Ultimo Messaggio: 29/01/16, 23:39

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •