Risultati da 1 a 5 di 5

Discussione: Calcolare data in presenza di diverse condizioni



  1. #1
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Calcolare data in presenza di diverse condizioni

    Ciao a tutti,
    infiocchettando, in realtà, sfruttando a mani basse il lavoro di Rubik e Nick (:98:) a seguito della richiesta di Pabexcel:
    1) vorrei calcolare la data di scadenza del documento tenendo conto delle condizioni presenti in legenda.
    2) che la verifica con la formattazione condizionale avvenisse solo in presenza di celle non vuote

    https://www.dropbox.com/s/v29pwalkfn...ente.xlsx?dl=0

    PS Il risultato atteso è quello presente nell'unica riga compilata.

    Grazie
    Gene

  2. #2
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2076
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Calcolare data in presenza di diverse condizioni

    Ciao
    per la formattazione
    Codice: 
    =E($A$11=VERO;$G4<OGGI();$G4<>"")
    per il resto devi rivedere la formula del conteggio in base all'età

    +10 non è che sia sempre valido:32:

  3. #3
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2076
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Calcolare data in presenza di diverse condizioni

    in W3
    Codice: 
    =SE(O(V3=A4;V3=A5);SE(U3<=50;B4;SE(E(U3>50;U3<=70);C4;SE(E(U3>70;U3<=80);D4)));SE(U3>80;2;SE(E(V3=G4;U3<=65);5;SE(E(V3=G4;U3>65);2;SE(E(V3=K4;U3<=60);5;2)))))
    In X3

    =DATA(ANNO(T3)+W3;MESE(S3);GIORNO(E4))

    e tira in giù

    dopo non capisco come vuoi i dati in foglio1
    visto l'esiguità delle righe
    non ti basta
    = cella

  4. I seguenti utenti hanno dato un "Like"


  5. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7160
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Calcolare data in presenza di diverse condizioni

    Ciao a tutti, propongo una formula in stile dell'amico pkrome, che cordialmente saluto:

    =SE(E(E4*G4>0;F4="B";ANNO(OGGI())-ANNO(E4)<=50);DATA(ANNO(G4)+10;MESE(E4);GIORNO(E4));SE(E(E4*G4>0;F4="B";ANNO(OGGI())-ANNO(E4)>50;ANNO(OGGI())-ANNO(E4)<=70);DATA(ANNO(G4)+5;MESE(E4);GIORNO(E4));SE(E(E4*G4>0;F4="B";ANNO(OGGI())-ANNO(E4)>70);DATA(ANNO(G4)+3;MESE(E4);GIORNO(E4));SE(E(E4*G4>0;F4="C";ANNO(OGGI())-ANNO(E4)<=65);DATA(ANNO(G4)+5;MESE(E4);GIORNO(E4));SE(E(E4*G4>0;F4="C";ANNO(OGGI())-ANNO(E4)>65);DATA(ANNO(G4)+3;MESE(E4);GIORNO(E4));SE(E(E4*G4>0;F4="D";ANNO(OGGI())-ANNO(E4)<=65);DATA(ANNO(G4)+5;MESE(E4);GIORNO(E4));SE(E(E4*G4>0;F4="D";ANNO(OGGI())-ANNO(E4)>65);DATA(ANNO(G4)+2;MESE(E4);GIORNO(E4));"")))))))

    Ho anche aggiunto altre formule per la formattazione condizionale, a Gene l'ardua sentenza! :90:
    P.S. - La formula l'ho solo scritta senza verificarla, è tardi e ho sonno.
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. I seguenti 2 utenti hanno dato un "Like" a ges per questo post:


  7. #5
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Calcolare data in presenza di diverse condizioni

    Ciao a tutti,
    siete grandi entrambi e mi dispiace ma scegliere tra ostriche e caviale non è possibile :243: !!

    Ora proverò a scrivere una macro (Rubix, Ges & Marius avvisati..mezzi salvati) che quando flaggo la check-box "rinnovato" prenda il dato della prossima scadenza lo copi nella cella dell'attuale e tolga il flag alla casella stessa. Mi viene da ridere al solo pensiero quindi penso che ci risentiremo in settimana in una sezione diversa del forum :242:.

    Buona domenica a tutti.

    Gene

  8. I seguenti 2 utenti hanno dato un "Like" a G.Bove per questo post:


Discussioni Simili

  1. POP-UP con differenza tra data x e data corrrente a determinate condizioni
    Di TommyPuffo89 nel forum Domande su Excel VBA e MACRO
    Risposte: 1
    Ultimo Messaggio: 08/01/17, 16:04
  2. SOMMA sotto diverse condizioni
    Di Zakkino nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 17/06/16, 18:57
  3. Calcolare orario tra diverse celle
    Di maxcerba nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 24/05/16, 16:28
  4. Ricerca valore max sotto diverse condizioni
    Di Zakkino nel forum Domande su Excel in generale
    Risposte: 33
    Ultimo Messaggio: 09/02/16, 20:37
  5. [Risolto] Filtrare SALDI (da calcolare) in un database in base a più condizioni
    Di MarcoM nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 03/10/15, 09:48

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •