Risultati da 1 a 6 di 6

Discussione: 2007-forum-tabella ore-conta presenze-filtro



  1. #1
    L'avatar di tk71
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Svizzera
    Messaggi
    108
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    59

    2007-forum-tabella ore-conta presenze-filtro

    Ciao a tutti, scusate la domanda un po`astrusa e banale ma ho un problema di applicazione tipo....

    ho un elenco simile di DATE e vorrei ( esempio ) estrappolare TUTTO il mese di Febbraio e di conseguenza inviarlo in PDF.

    DOMANDE ( 2 )

    >Li x li ho pensato al filtro selezionando appunto FEBBRAIO , ma non mi da`piu ne`il TOTALE ORE NUOVO delle ore ne`il CONTA PRESENZE NUOVO.
    >Per poi riavere la tabella completa come prima.

    Non so`bene come tirarmi fuori dall`errore e ringrazio tutti voi a chi mi vuol aiutare a capirci meglio .

    Salutoni TK

    Il testo e`anche all`interno del FILE
    File Allegati File Allegati

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: 2007-forum-tabella ore-conta presenze-filtro

    Ciao,
    non so se ho capito bene ma ho estratto tutto il mese di febbraio con i relativi dati usando questa formula, che ho messo nel secondo foglio:

    =SE.ERRORE(INDICE(ELENCO!$B$6:$B$370; AGGREGA(15;6;(RIF.RIGA($D$6:$D$370)-RIF.RIGA(ELENCO!$D$6)+1)/(MESE(ELENCO!$B$6:$B$370)=2);RIGHE(A1:$A$1)));"")


    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di tk71
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Svizzera
    Messaggi
    108
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    59

    Re: 2007-forum-tabella ore-conta presenze-filtro

    Grazie 1000 Ges x la risposta.

    In effetti la tabella originale ha la stessa impostazione.

    Ho una piccola domanda da aggiungere....


    > cosa debbo modificare all`interno della formula quando seleziono i altri mesi ? Che so`Maggio o Agosto e cosi via...

    Grazie ancora

    TK

  4. #4
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    781
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1

    Re: 2007-forum-tabella ore-conta presenze-filtro

    Buona Sera

    Filtri anche le celle vuote?

    Saluti
    Window 8.1 Excel 2013/2016

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: 2007-forum-tabella ore-conta presenze-filtro

    Citazione Originariamente Scritto da tk71 Visualizza Messaggio
    ...

    Ho una piccola domanda da aggiungere....


    > cosa debbo modificare all`interno della formula quando seleziono i altri mesi ? Che so`Maggio o Agosto e cosi via...

    ...

    .
    Nella formula il 2 (in rosso) corrisponde a febbraio, quindi basta che cambi questo numero (3=marzo, 4=aprile, 5 = maggio ecc.ecc.)

    =SE.ERRORE(INDICE(ELENCO!$B$6:$B$370; AGGREGA(15;6;(RIF.RIGA($D$6:$D$370)-RIF.RIGA(ELENCO!$D$6)+1)/(MESE(ELENCO!$B$6:$B$370)=2);RIGHE(A1:$A$1)));"")

    Potresti scrivere il numero in una cella (esempio in A1) quindi basta che cambi il numero del mese e si aggiorna il nuovo elenco estratto.

    Ti allego file



    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. #6
    L'avatar di tk71
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Svizzera
    Messaggi
    108
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    59

    Re: 2007-forum-tabella ore-conta presenze-filtro

    Citazione Originariamente Scritto da Pitagora Visualizza Messaggio
    Buona Sera

    Filtri anche le celle vuote?

    Saluti
    Ciao Pitagora, rispondo con ritardo e ringrazio il tuo intervento.

    CELLE VUOTE: Il problema che mi trovo e`che qualsiasi giorno/cella che NON scrivo mi DEVE rimanere VUOTO.
    Perche a fondo della colonna P debbo fare il conta presenze.
    E se solo aggiungo il 00:00 nelle vuote mi conta tutto quanto, e mi sfalsa il conteggio.

    Spero di esserti stato abb. chiaro. Aspetto tuoi commenti.


    Saluti TK

Discussioni Simili

  1. Conta presenze effettive da elenco
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 23/05/16, 22:00
  2. [Risolto] Tabella ore Presenze
    Di antosime nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 18/03/16, 13:21
  3. Excel 2007 - FORUM-CALCOLO ORE IN TESTO
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 09/01/16, 10:35
  4. Forum Excel-Calendario-calcolo settimana a fine anno - Exel 2007
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 04/01/16, 16:31
  5. Filtro su subtotali Tabella Pivot
    Di MarcoM nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 30/09/15, 19:06

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •