Risultati da 1 a 6 di 6

Discussione: Annulla spazi vuoti



  1. #1
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Annulla spazi vuoti

    Ciao a tutti gli amici del forum

    Vorrei levare nelle celle B7:AF14 degli spazzi vuoti che impediscono il corretto funzionamento delle somme delle ore in fondo

    Come posso fare????

    Scusate e il secondo allegato!!!!!!!!!!!!!!!!!!!!

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao,

    in B26 da copiare a destra in C26:AF26

    Codice: 
    =SE.ERRORE(B8-B7;0)+SE.ERRORE(B10-B9;0)+SE.ERRORE(B12-B11;0)+SE.ERRORE(B14-B13;0)
    E' un primo tentativo per evitare che le formule restituiscano errore quando le sottrazioni leggono spazi vuoti.

    In attesa di migliori soluzioni.

  3. #3
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15
    Qualcosa di buono ha fatto

    Ora faccio delle verifiche di funzionamento

    Per ora mille grazie

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao Nick 0573 bentornato!!
    In B26 ho provato diverse formule e nessuna funzionava perchè le celle erano formattate con la parentesi quadra
    in questo modo [h]:mm:ss, questo tipo di formattazione serve per fare delle semplici somme di intervalli di numeri che però sono trattati come se fossero frazioni di 24 ore
    (0.1248+0.2587+ ecc +ecc)
    Esempio se io volessi sapere la somma 1+5+6+23=35
    pero se abbiamo messo i due punti tra le ore e i minuti in questo modo (
    1:00+5:00+6:00+23:00) excel vede delle frazioni di 24 ore (0.1248+0.2587+ ecc +ecc) per cui per avere un risultato simile a questo dobbiamo mettere la questa formattazione [h]:mm:ss cosi se le ore sono superiori alle 24 ore lui continua a sommare
    1:00+5:00+6:00+23:00=35
    nel tuo caso devi semplicemente formattare cosi hh:mm:ss oppure puoi anche non preformattarle perche excel quando tu metti i 2 punti lui di da in automatico il formato h:mm:ss

    Comunque in B26 ho fatto una formula che ha al suo interno la funzione RESTO ottiama per sciogliere il nodo in caso che abbiamo le ore a cavallo delle 00:00 (es. dalle 23:00 alle 3:00)

    fammi sapere!

    in B26 e copia a destra:


    =SE.ERRORE(SOMMA(RESTO(B8-B7;1);RESTO(B10-B9;1);RESTO(B12-B11;1);RESTO(B14-B13;1));"")


  5. #5
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15
    ciao e grazie


    Ho guardato il file ma ce tutta una serie di errori e mi sono saltate le formule

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da nick0573 Visualizza Messaggio
    ciao e grazie


    Ho guardato il file ma ce tutta una serie di errori e mi sono saltate le formule
    pensavo fossi interessato solo alla formula nella 26a riga.
    infatti non ho toccato altre righe ho solo toccato la riga 26...

    dimmi dove vuoi le altre formule (numero riga) e che risultato vuoi ottenere

Discussioni Simili

  1. Moduli vuoti si possono eliminare
    Di svizzera nel forum Domande su Excel VBA e MACRO
    Risposte: 10
    Ultimo Messaggio: 03/02/17, 17:41
  2. Risposte: 5
    Ultimo Messaggio: 28/11/16, 08:53
  3. Inserie spazi vuoti automaticamente in serie di numeri in una colonna
    Di tigertaffa nel forum Domande su Excel VBA e MACRO
    Risposte: 10
    Ultimo Messaggio: 29/09/16, 01:53
  4. Copiare dati senza lasciare spazi vuoti
    Di lala10 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 03/05/16, 14:07
  5. Annulla spazi col vba
    Di ges nel forum Domande su Excel VBA e MACRO
    Risposte: 9
    Ultimo Messaggio: 17/02/16, 20:17

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •