Risultati da 1 a 7 di 7

Discussione: Somma e media di tabella a doppia entrata



  1. #1
    L'avatar di LucaS
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    bernareggio
    Messaggi
    3
    Versione Office
    excel 2010
    Likes ricevuti
    0
    Likes dati
    2

    Somma e media di tabella a doppia entrata

    Ciao a tutti,

    mi chiamo Luca e sono nuovo del forum.
    Chiedo gentilmente il vostro supporto per il calcolo di media e somma di valori in tabella con campi riga duplicati e campi colonna con valori data.

    Ho provato diverse strade con somma.se/indice/confronta o la funzione scarto ma mi blocco sempre al calcolo di una singola riga o di una singola colonna. :171:

    Per semplicità allego file che dovrebbe essere esplicativo.

    Spero sia chiaro, in alternativa provvederò ad integrare.

    grazie e tutti in anticipo :286:
    File Allegati File Allegati

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    54
    Messaggi
    9963
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2566
    Likes dati
    1546

    Re: Somma e media di tabella a doppia entrata

    Ciao,
    per la somma in B20 da trascinare in basso:

    =MATR.SOMMA.PRODOTTO(($B$3:$B$13)*($A$3:$A$13=A3))

    Per la media in C20 da trascinare in basso:

    =MEDIA.PIÙ.SE($B$3:$B$13;$A$3:$A$13;A20)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di LucaS
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    bernareggio
    Messaggi
    3
    Versione Office
    excel 2010
    Likes ricevuti
    0
    Likes dati
    2

    Re: Somma e media di tabella a doppia entrata

    Ciao Ges,

    grazie mille del pronto e utile riscontro.:286:

    Ovviamente mi sono spiegato male io.

    la formula deve considerare anche il campo data (cella di convalida dati), come intervallo dinamico. Faccio un esempio:

    se la data nella cella B16 fosse 22/01/2016, la somma e la media ante data dovrebbe prendere in considerazione il periodo 01/01/2016 - 22/01/2016 (compreso) mentre la somma e la media post data 22/01/2016 (non compreso) - 31/01/2016.

    Spero di essermi spiegato bene :186::92:

    grazie ancora

  5. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    2139
    Versione Office
    2010 PC
    Likes ricevuti
    1180
    Likes dati
    238

    Re: Somma e media di tabella a doppia entrata

    ciao
    se ho capito bene e parafrasando la formula di ges:

    B20:
    =MATR.SOMMA.PRODOTTO(($B$2:$AF$2<=$B$16)*($A$3:$A$13=$A20)*$B$3:$AF$13)

    C20:
    =MATR.SOMMA.PRODOTTO(($B$2:$AF$2<=$B$16)*($A$3:$A$13=$A20)*$B$3:$AF$13)/MATR.SOMMA.PRODOTTO(($B$2:$AF$2<=$B$16)*($A$3:$A$13=$A20)*($B$3:$AF$13)^0)
    D20:
    =MATR.SOMMA.PRODOTTO(($B$2:$AF$2>$B$16)*($A$3:$A$13=$A20)*$B$3:$AF$13)
    E20:
    =MATR.SOMMA.PRODOTTO(($B$2:$AF$2>$B$16)*($A$3:$A$13=$A20)*$B$3:$AF$13)/MATR.SOMMA.PRODOTTO(($B$2:$AF$2>$B$16)*($A$3:$A$13=$A20)*($B$3:$AF$13)^0)
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  6. I seguenti 4 utenti hanno dato un "Like" a ninai per questo post:


  7. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5386
    Versione Office
    office 365/2016
    Likes ricevuti
    1272
    Likes dati
    1339

    Re: Somma e media di tabella a doppia entrata

    Ciao amici del forum
    Mi sono divertito a scopiazzare la formula di ninai :23: ed è venuto fuori questo

    in C20
    =MATR.SOMMA.PRODOTTO((SCARTO($A$2;1;1;11;CONFRONTA($B$16;$B$2:$AF$2;0)))*($A$3:$A$13=A20))

    D20

    =MATR.SOMMA.PRODOTTO((SCARTO($A$2;1;1;11;CONFRONTA($B$16;$B$2:$AF$2;0)))*($A$3:$A$13=A20))/MATR.SOMMA.PRODOTTO(($B$3:$AF$13^0)*($A$3:$A$13=A20)*($B$2:$AF$2<=$B$16))

    Anche se nella seconda formula il dividendo è rimasto uguale a quello di ninai

    Un saluto a tutti
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  8. I seguenti 2 utenti hanno dato un "Like" a Gerardo Zuccalà per questo post:


  9. #6
    L'avatar di LucaS
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    bernareggio
    Messaggi
    3
    Versione Office
    excel 2010
    Likes ricevuti
    0
    Likes dati
    2

    Re: Somma e media di tabella a doppia entrata

    Siete stati grandi..

    grazie mille del supporto!!! :255:

  10. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5386
    Versione Office
    office 365/2016
    Likes ricevuti
    1272
    Likes dati
    1339

    Re: Somma e media di tabella a doppia entrata

    Grazie per il tuo riscontro positivo

    e se la tua domanda è stata risolta segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menu “Strumenti Discussione” quindi scegliere “Segna questo Thread come risolto”
    ciao e alla prossima
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

Discussioni Simili

  1. doppia tabella su un unico grafico
    Di nick0573 nel forum Domande sui Grafici di Excel
    Risposte: 16
    Ultimo Messaggio: 09/01/17, 23:21
  2. [Risolto] Doppia scelta con funzione SE
    Di LUCA83 nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 11/11/16, 10:53
  3. [Risolto] Somma dei valori di altra tabella = zero
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 08/11/16, 17:31
  4. [Risolto] conta.se con doppia condizione
    Di Rero57 nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 28/09/16, 19:06
  5. Risposte: 30
    Ultimo Messaggio: 02/06/16, 17:49

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •