Risultati da 1 a 6 di 6

Discussione: contare quante volte un valore ricorre in un range di celle



  1. #1
    L'avatar di nessi
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Milano
    Età
    53
    Messaggi
    159
    Versione Office
    2013/2016
    Likes ricevuti
    3
    Likes dati
    35

    contare quante volte un valore ricorre in un range di celle

    Ciao a tutti. il quesito che pongo è il seguente. Nel file allegato in B2 ho usato la canonica formula CONTA.SE che mi conta quante celle contengono il valore "utente_PippoP". Fin qui tutto bene. Ho però bisogno di sapere quante volte ricorre in generale. il risultato della formula, nell'esempio allegato, ho necessità che sia= 6. Potete aiutarmi? anche con VBA. Come sempre, grazie in anticipo.
    File Allegati File Allegati

  2. #2
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: contare quante volte un valore ricorre in un range di celle

    Ciao

    Codice: 
    =SOMMA((LUNGHEZZA(A1:A100)-LUNGHEZZA(SOSTITUISCI(MINUSC(A1:A100);"pippo";"")))/LUNGHEZZA("pippo"))
    matriciale

    ctrl+maiuscolo+invio

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di nessi
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Milano
    Età
    53
    Messaggi
    159
    Versione Office
    2013/2016
    Likes ricevuti
    3
    Likes dati
    35

    Re: contare quante volte un valore ricorre in un range di celle

    Grazie mille Gianfranco, avevo già trovato questa soluzione, un po' diversa ma mi sono confuso su maiuscole/minuscole.
    Codice: 
    =SOMMA((LUNGHEZZA(A1:A100)-LUNGHEZZA(SOSTITUISCI(MINUSC(A1:A100);"utente_pippop";"")))/LUNGHEZZA("utente_pippop"))
    Grazie ancora.

  5. #4
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: contare quante volte un valore ricorre in un range di celle

    Ciao Gianfranco55, la formula è perfetta, però se vuoi evitare l'attivazione in quanto formula matrice, basta sostituire la funzione somma, con matr.somma.prodotto,
    per cui si ha:

    =MATR.SOMMA.PRODOTTO((LUNGHEZZA(A1:A100)-LUNGHEZZA(SOSTITUISCI(MINUSC(A1:A100);"pippo";"")))/LUNGHEZZA("pippo")).

    Ciao e scusa per l'intromissione.

  6. I seguenti 2 utenti hanno dato un "Like" a pkrome59 per questo post:


  7. #5
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: contare quante volte un valore ricorre in un range di celle

    Ciao
    pkrome

    scusarti di che
    sono qui per imparare
    ben venga poter eliminare una matriciale

    ( grazie

  8. #6
    L'avatar di nessi
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Milano
    Età
    53
    Messaggi
    159
    Versione Office
    2013/2016
    Likes ricevuti
    3
    Likes dati
    35

    Re: contare quante volte un valore ricorre in un range di celle

    grazie pkrome!

Discussioni Simili

  1. [Risolto] Aiuto - dopo quante righe si presenta un valore
    Di Aura76 nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 01/02/17, 11:46
  2. [Risolto] Macro per ordinare in base a quante volte è presente un carattere specifico.
    Di Lety88 nel forum Domande su Excel VBA e MACRO
    Risposte: 8
    Ultimo Messaggio: 01/11/16, 22:00
  3. Quante volte la mattina e quante al pomeriggio?
    Di Dilly nel forum Domande su Excel in generale
    Risposte: 39
    Ultimo Messaggio: 03/08/16, 10:31
  4. Contare celle consecutive scartando un determinato valore
    Di Davide nel forum Domande su Excel VBA e MACRO
    Risposte: 22
    Ultimo Messaggio: 09/01/16, 10:46
  5. Valore numerico ripetuto 3 volte
    Di Pollosud nel forum Domande su Excel in generale
    Risposte: 18
    Ultimo Messaggio: 27/10/15, 00:27

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •