Risultati da 1 a 10 di 10

Discussione: Contare parole intere incluse in una frase



  1. #1
    ProgrammD69
    Ospite L'avatar di ProgrammD69

    Contare parole intere incluse in una frase

    Buongiorno !
    In un foglio di lavoro di Excel ho:

    da A1 a A20 la data estesa

    da B1 a B20 ho la scritta: spremuta di 2 limoni che si alterna a: spremuta di 3 arance

    da C1 a C20 ho la scritta: spremuta di 3 arance che si alterna a: spremuta di 3 limoni

    in D1 ho inserito la funzione =Cerca.Vert("Limone";$B$1:$C$20;1;Falso) ma mi da errore #N/D in quanto Cerca.Vert non riesce a trovare la parola "Limone" all'interno di una frase. In questo caso che si può fare ?

    in E1 voglio contare quanti limoni sono stati spremuti nei 20 giorni considerati.

    Quale funzione mi conta le parole "limoni" o "arance" che si trovano all'interno di una frase ?
    Ultima modifica fatta da:Canapone; 16/05/16 alle 20:17

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Contare parole intere incluse in una frase

    Ciao,
    allega il file per capire meglio e soprattutto per non far creare il file da zero a chi volesse aiutarti (visto che ce l'hai già pronto).

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7160
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Contare parole intere incluse in una frase

    Ciao a tutti,
    forse, cromagno, stavolta ho capito anche senza vedere il file (almeno credo).

    Se come indica nelle celle da B1:B20 ha la scritta: "spremuta di 2 limoni" alternata a "spremuta di 3 arance" e in C1:C20 la scritta "spremuta di 3 arance" alternata a "spremuta di 3 limoni" basta usare le seguenti formule:

    Per calcolare i limoni usati nella colonna B:

    =MATR.SOMMA.PRODOTTO((STRINGA.ESTRAI($B$1:$B$20;TROVA("di";$B$1:$B$20)+3;1)+0)*(STRINGA.ESTRAI($B$1:$B$20;TROVA("di";$B$1:$B$20)+5;6)="limoni"))

    Per calcolare le arance nella colonna B:

    =MATR.SOMMA.PRODOTTO((STRINGA.ESTRAI($B$1:$B$20;TROVA("di";$B$1:$B$20)+3;1)+0)*(STRINGA.ESTRAI($B$1:$B$20;TROVA("di";$B$1:$B$20)+5;6)="arance"))

    Per calcolare i limoni nella colonna C:

    =MATR.SOMMA.PRODOTTO((STRINGA.ESTRAI($C$1:$C$20;TROVA("di";$C$1:$C$20)+3;1)+0)*(STRINGA.ESTRAI($C$1:$C$20;TROVA("di";$C$1:$C$20)+5;6)="limoni"))


    Per calcolare le arance nella colonna C:

    =MATR.SOMMA.PRODOTTO((STRINGA.ESTRAI($C$1:$C$20;TROVA("di";$C$1:$C$20)+3;1)+0)*(STRINGA.ESTRAI($C$1:$C$20;TROVA("di";$C$1:$C$20)+5;6)="arance"))

    Per trovare tutti i limoni di entrambe le colonne B e C:

    =MATR.SOMMA.PRODOTTO((STRINGA.ESTRAI($B$1:$B$20;TROVA("di";$B$1:$B$20)+3;1)+0)*(STRINGA.ESTRAI($B$1:$B$20;TROVA("di";$B$1:$B$20)+5;6)="limoni"))+MATR.SOMMA.PRODOTTO((STRINGA.ESTRAI($C$1:$C$20;TROVA("di";$C$1:$C$20)+3;1)+0)*(STRINGA.ESTRAI($C$1:$C$20;TROVA("di";$C$1:$C$20)+5;6)="limoni"))

    Per trovare le arance di entrambe le colonne B e C:

    =MATR.SOMMA.PRODOTTO((STRINGA.ESTRAI($B$1:$B$20;TROVA("di";$B$1:$B$20)+3;1)+0)*(STRINGA.ESTRAI($B$1:$B$20;TROVA("di";$B$1:$B$20)+5;6)="arance"))+MATR.SOMMA.PRODOTTO((STRINGA.ESTRAI($C$1:$C$20;TROVA("di";$C$1:$C$20)+3;1)+0)*(STRINGA.ESTRAI($C$1:$C$20;TROVA("di";$C$1:$C$20)+5;6)="arance"))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. I seguenti 4 utenti hanno dato un "Like" a ges per questo post:


  5. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Contare parole intere incluse in una frase

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao a tutti,
    forse, cromagno, stavolta ho capito anche senza vedere il file (almeno credo).
    Ciao ges,
    probabilmente è così, ma preferisco provare a scrivere delle formule su dei dati certi, perchè come ben sai, spesso la realtà del file non è quella descritta nella spiegazione del problema...e quindi le formule da utilizzare cambiano :32:

    Comunque, spero che tu abbia ragione, se non altro non avrai sprecato tempo a scrivere tutte quelle formule :246:

    Un saluto
    Tore

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  6. #5
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204

    Re: Contare parole intere incluse in una frase

    Ciao a tutti,

    proposta un po' campata per aria, in H1 "limoni", in H2 "arance".

    In I2 da confermare con control+maiusc+invio

    =SOMMA(SE(VAL.NUMERO(RICERCA(H1;$B$1:$C$100));SE.ERRORE(SOSTITUISCI(SOSTITUISCI(SOSTITUISCI($B$1:$C$100;"spremuta di";"");"limoni";"");"arance";"")+0;0));0)


    Saluti

  7. I seguenti 3 utenti hanno dato un "Like" a Canapone per questo post:


  8. #6
    ProgrammD69
    Ospite L'avatar di ProgrammD69

    Re: Contare parole intere incluse in una frase

    ...
    La formula restituisce zero.

    Comunque, concettualmente, come si fa ad estrarre un nome da una frase e su quel nome fare il conteggio ?
    Se mi dite le funzioni, poi ci voglio arrivare da solo.
    Ultima modifica fatta da:Canapone; 18/05/16 alle 12:22

  9. #7
    ProgrammD69
    Ospite L'avatar di ProgrammD69

    Re: Contare parole intere incluse in una frase

    Nella formula "di" a cosa si riferisce ?
    Ultima modifica fatta da:Canapone; 18/05/16 alle 12:23 Motivo: [quote] inutile

  10. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7160
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Contare parole intere incluse in una frase

    Citazione Originariamente Scritto da ProgrammD69 Visualizza Messaggio
    Nella formula "di" a cosa si riferisce ?
    Ciao,
    il "di" è una delle parole contenuta in tutte le frasi, che sono "spremuta di 2 limoni" "spremuta di 3 arance"; in pratica la formula trova la collocazione "di" nella frase e da lì aggiungendo tre caratteri ricava il numero TROVA("di";$B$1:$B$20)+3;1) ... e aggiungendo 5 caratteri ricava il nome TROVA("di";$C$1:$C$20)+5;6)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  11. #9
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204

    Re: Contare parole intere incluse in una frase

    Ciao a tutti

    allego il file con un esempio della formula.

    Avessi problemi ad adattare la formula, prova ad allegare un piccolo estratto del file sul quale lavori.

    Saluti
    File Allegati File Allegati

  12. I seguenti utenti hanno dato un "Like"


  13. #10
    ProgrammD69
    Ospite L'avatar di ProgrammD69

    Re: Contare parole intere incluse in una frase

    La formula funziona, Grazie !!
    Questo forum è eccezionale !

Discussioni Simili

  1. Estrarre frase sensata
    Di Samuela nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 31/01/17, 10:22
  2. [Risolto] Applicare il grassetto ad una frase
    Di dautattmaui nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 25/01/17, 20:09
  3. [Risolto] Inserire frase all'interno di un altra
    Di Samuela nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 02/10/16, 14:17
  4. Frase tradotta Mi Piace
    Di scossa nel forum Problemi, suggerimenti e Novità del forum
    Risposte: 8
    Ultimo Messaggio: 25/08/16, 02:26
  5. Rimuovere intere righe duplicate
    Di Ste911 nel forum Domande su Excel VBA e MACRO
    Risposte: 12
    Ultimo Messaggio: 06/07/16, 13:08

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •