Risultati da 1 a 5 di 5

Discussione: richiesta alternativa a una formula



  1. #1
    L'avatar di fireman80
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    italia
    Età
    37
    Messaggi
    55
    Versione Office
    office 2016
    Likes ricevuti
    0
    Likes dati
    5

    richiesta alternativa a una formula

    come da oggetto cerco di poter avere altra soluzione per poter far "capire" ad Excel che al posto di una singola parola che in questo esempio e' "S.V." debba restituire il valore specificato con qualsiasi testo, visto che di solito c'è un numero in quanto è il voto della giornata.

    =SE(A3="";"";SE(G2="s.v.";"T";"P"))

    Questo perchè alcuni file che scarico da internet per i voti, invece di avere S . (PUNTO) V . (PUNTO), hanno la virgola e quindi a quel punto la formula non riconosce il valore e quindi non funziona più.

    N.B. S.V.= SENZA VOTO
    File Allegati File Allegati

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923

    Re: richiesta alternativa a una formula

    Ciao fireman,
    tralasciando l'allegato (visto che mi fa sorgere dei dubbi più che chiarirmi il problema), potresti modificare la tua formula:

    =SE(A3="";"";SE(G2="s.v.";"T";"P"))

    in questo modo:

    =SE(A3="";"";SE(SOSTITUISCI(G2;",";".")="s.v.";"T";"P"))

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3
    L'avatar di fireman80
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    italia
    Età
    37
    Messaggi
    55
    Versione Office
    office 2016
    Likes ricevuti
    0
    Likes dati
    5

    Re: richiesta alternativa a una formula

    Ciao Cromagno e grazie per la pronta risposta, l'allegato è alquanto spartano però a me sembra chiaro (ovviamente ho tolto dei riferimenti che non servivano alla causa e dove è scritto portieri in questo caso sarebbe giusto sostituirlo con GIOCATORI), comunque la tua soluzione può essere buona ma se si potesse far in modo che al posto di SV potrebbe starci qualsiasi testo al di fuori di un numero, ovviamente, sarebbe il TOP.

  4. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923

    Re: richiesta alternativa a una formula

    Prova così:

    =SE(A3="";"";SE(VAL.ERRORE(G2*1);"T";"P"))

    [EDIT]

    o in alternativa:

    =SE(A3="";"";SE(VAL.TESTO(G2);"T";"P"))

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  5. #5
    L'avatar di fireman80
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    italia
    Età
    37
    Messaggi
    55
    Versione Office
    office 2016
    Likes ricevuti
    0
    Likes dati
    5

    Re: richiesta alternativa a una formula

    :246:......risolto!
    Citazione Originariamente Scritto da cromagno Visualizza Messaggio
    prova così:

    =se(a3="";"";se(val.errore(g2*1);"t";"p"))

    [edit]

    o in alternativa:

    =se(a3="";"";se(val.testo(g2);"t";"p"))

Discussioni Simili

  1. [Risolto] Richiesta formula
    Di g8trading nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 16/03/17, 13:37
  2. [Risolto] Richiesta Formula di Riepilogo su 1° Tabella da più Tabelle
    Di Bauhaus nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 19/02/17, 19:29
  3. [Risolto] richiesta formula
    Di danyp2002 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 30/01/17, 20:01
  4. Richiesta supporto formula.
    Di Antonio Malizia nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 24/07/16, 14:37
  5. Risposte: 10
    Ultimo Messaggio: 08/04/16, 21:09

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •