Risultati da 1 a 9 di 9

Discussione: SE(A1 contiene "ant" o se contiene "con";"vero";"falso")



  1. #1
    L'avatar di aldomattana
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Modena
    Età
    46
    Messaggi
    184
    Versione Office
    Office 2007
    Likes ricevuti
    9
    Likes dati
    33

    SE(A1 contiene "ant" o se contiene "con";"vero";"falso")

    Ciao ragazzi, avrei necessità di fare un doppio controllo su una cella contenente un testo concatenato e, nel caso quella concatenazione contenga una parte o un altra parte di testo (che siano all'inizio, in mezzo o alla fine del testo concatenato) deve darmi VERO altrimenti FALSO.

    Come ottengo la funzione "CONTIENE O CONTIENE" ?
    Grazie, Aldo.
    PS: Se la "cosa" ti ha aiutato, mi piace se mi dai un "mi piace" - Se mi hai aiutato tu, ti ringrazio 2 volte ;-)

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1683
    Versione Office
    2010 PC
    Likes ricevuti
    896
    Likes dati
    185

    Re: SE(A1 contiene "ant" o se contiene "con";"vero";"falso")

    ciao
    sarebbe meglio un file di esempio, potrebbe andare qualcosa di simile:
    =VAL.NUMERO(TROVA(testo da cercare;testo dove cercare))
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7165
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1304

    Re: SE(A1 contiene "ant" o se contiene "con";"vero";"falso")

    Ciao,
    quello che hai scritto tu in formula si scrive così:

    =SE(O(A1="ant";A1= "con");"vero";"falso")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204

    Re: SE(A1 contiene "ant" o se contiene "con";"vero";"falso")

    Ciao a tutti

    pensavo anche a qualcosa di simile


    =SE(CONTA.SE(A1;"*ANT*")+CONTA.SE(A1;"*CON*");VERO;FALSO)

    Saluti

  5. I seguenti 3 utenti hanno dato un "Like" a Canapone per questo post:


  6. #5

    L'avatar di alfrimpa
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Napoli
    Età
    64
    Messaggi
    6812
    Versione Office
    2013
    Likes ricevuti
    721
    Likes dati
    165

    Re: SE(A1 contiene "ant" o se contiene "con";"vero";"falso")

    Ciao Aldo

    Puoi usare questa formula

    Codice: 
    =SE(O(A1="ant";A1="con");"vero";"falso")
    Alfredo

  7. #6

    L'avatar di alfrimpa
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Napoli
    Età
    64
    Messaggi
    6812
    Versione Office
    2013
    Likes ricevuti
    721
    Likes dati
    165

    Re: SE(A1 contiene "ant" o se contiene "con";"vero";"falso")

    Qui ci vuole il cronometro al centesimo di secondo.....:166:

    Alfredo

  8. #7
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2076
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: SE(A1 contiene "ant" o se contiene "con";"vero";"falso")

    Non avevo visto il doppio controllo:223:

  9. #8
    L'avatar di aldomattana
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Modena
    Età
    46
    Messaggi
    184
    Versione Office
    Office 2007
    Likes ricevuti
    9
    Likes dati
    33

    Re: SE(A1 contiene "ant" o se contiene "con";"vero";"falso")

    Citazione Originariamente Scritto da alfrimpa Visualizza Messaggio
    Qui ci vuole il cronometro al centesimo di secondo.....
    Sì è vero, siete dei "mostri" di velocità e bravura ...

    La prossima richiesta lascio il post vuoto senza spiegazione, sono sicuro che qualcuno darà ugualmente la risposta corretta :)
    Scherzi a parte, mi stò preparando per una superdomandona con i controfiocchi che spero avrete la pazienza di leggere e seguire.

    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    =SE(CONTA.SE(A1;"*ANT*")+CONTA.SE(A1;"*CON*");VERO;FALSO)
    è perfetta perchè tiene conto di
    Citazione Originariamente Scritto da aldomattana Visualizza Messaggio
    contenga una parte o un altra parte di testo (che siano all'inizio, in mezzo o alla fine del testo concatenato)
    invece
    =SE(O(A1="*avv*";A1= "*con*");"vero";"falso")
    =VAL.NUMERO(TROVA("*AVV*";A1))
    non funzionano, ne con nè senza * ... chissà perchè? :(
    Grazie, Aldo.
    PS: Se la "cosa" ti ha aiutato, mi piace se mi dai un "mi piace" - Se mi hai aiutato tu, ti ringrazio 2 volte ;-)

  10. #9
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1683
    Versione Office
    2010 PC
    Likes ricevuti
    896
    Likes dati
    185

    Re: SE(A1 contiene "ant" o se contiene "con";"vero";"falso")

    ciao
    alla luce delle altre proposte, fermo restando che per me la più "snella" resta quella di canapone, la mia sarebbe:
    =SE(VAL.NUMERO(TROVA("ant";A1))+VAL.NUMERO(TROVA("con";A1));0=0;0>0)
    tiene conto anche delle maiuscole
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

Discussioni Simili

  1. [Risolto] Ordinare con la funzione "piccolo"..ma "portandosi dietro" anche altri dati affiancati
    Di mauri73 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 05/02/17, 14:57
  2. [Risolto] Come leggere la seguente formula =SE.ERRORE(INDIRETTO("'"&A1&"'!K1";1);""))
    Di sitolofi nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 20/12/16, 14:54
  3. >Come estrappolare la somma "automatica" di un DB con funzione "FILTRO"<
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 11/06/16, 11:44
  4. [Risolto] Codice non funzionante dopo il passaggio da "Windows" a "Mac"...
    Di joondeep nel forum Foglio di calcolo su altre Piattaforme
    Risposte: 13
    Ultimo Messaggio: 12/03/16, 21:09
  5. Collegamento "foglio elenco" e "fogli singoli"
    Di Maurizio76 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 23/11/15, 10:14

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •