Risultati da 1 a 12 di 12

Discussione: Problema con i duplicati - Assenze studenti



  1. #1
    L'avatar di Francesco92
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Agrigento
    Messaggi
    4
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Problema con i duplicati - Assenze studenti

    Ciao, ho un problema con i duplicati. Ho realizzato uno schema con excel 2010, che evidenzia chi degli studenti fa il minor numero di assenze a scuola. Ho utilizzato le funzioni INDICE e CONFRONTA (nella colonna "ALUNNO") e la funzione PICCOLO (nella colonna "ASSENZE"). In pratica in questo foglio di excel ho inserito a sinistra l'elenco degli studenti (Studente 1, Studente2, ecc ecc...), mentre a destra ho inserito il calcolo automatico di chi fa meno assenze. Il problema nasce per A7 e A8, ovvero per Studente 3 e Studente 4, poichè hanno lo stesso numero di assenze. Come risolvo in modo che nella colonna "ALUNNO" non compaiano studenti con lo stesso nome?
    Spero che capiate il mio problema.

    Grazie
    Francesco

    P.S. in allegato il mio file excel
    File Allegati File Allegati
    Ultima modifica fatta da:Berna11; 06/05/17 alle 11:51 Motivo: [Risolto]

  2. #2
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Re: Problema con i duplicati - Assenze studenti

    Ciao francesco
    In J5 ti ho incollato la formula guarda se può andare........
    File Allegati File Allegati
    windows 10
    Excel 2016

  3. #3
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183

    Re: Problema con i duplicati - Assenze studenti

    ciao
    qualcosa di simile a quella di nick, in F5:
    =SE.ERRORE(INDICE($A$5:$A$24;PICCOLO(SE($B$5:$B$24=E5;RIF.RIGA($E$5:$E$24)-RIF.RIGA($E$5)+1);CONTA.SE($E$4:E4;E5)+1));"")

    matriciale


    Nick0573
    sarebbe meglio che nei post, pubblicassi anche le formule adottate. A parte la migliore leggibilità, se per qualche motivo non fosse più scaricabile il file, la soluzione resterebbe occulta.
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  4. I seguenti utenti hanno dato un "Like"


  5. #4
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Re: Problema con i duplicati - Assenze studenti

    Ciao Ninai ...

    giusto...ottima considerazione...
    windows 10
    Excel 2016

  6. #5

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2807
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    978

    Re: Problema con i duplicati - Assenze studenti

    Visto che Francesco92 ha Excel 2010 propongo la mia senza l'ausilio CTRL+SHIFT+ENTER

    =SE.ERRORE(INDICE($A$5:$A$24;AGGREGA(15;6;(RIF.RIGA($A$5:$A$24)-RIF.RIGA($A$5)+1)/($B$5:$B$24=PICCOLO($B$5:$B$24;RIGHE($1:1)));CONTA.SE($E$5:E5;E5)));"")

    EDIT: aggiunto SE.ERRORE

  7. I seguenti utenti hanno dato un "Like"


  8. #6
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199

    Re: Problema con i duplicati - Assenze studenti

    Ciao a tutti

    sempre usando AGGREGA in F5 ed in basso

    =SE(E5;INDICE(A$5:A$24;AGGREGA(15;6;RIF.RIGA($5:$24)-4/(B$5:B$24=E5);CONTA.SE(E$5:E5;E5)));"")

    Saluti

  9. I seguenti utenti hanno dato un "Like"


  10. #7
    L'avatar di Francesco92
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Agrigento
    Messaggi
    4
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Problema con i duplicati - Assenze studenti

    Grazie a tutti, ho risolto!!! :286:

  11. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7118
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1298

    Re: Problema con i duplicati - Assenze studenti

    Giusto per partecipare ... matriciale, usando anche la funzione RANGO:

    =INDICE($A$5:$A$24;CONFRONTA(PICCOLO(RANGO($B$5:$B$24;$B$5:$B$24;1)+RIF.RIGA($A$5:$A$24)/1000;RIF.RIGA(A1));RANGO($B$5:$B$24;$B$5:$B$24;1)+RIF.RIGA($A$5:$A$24)/1000;0))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  12. I seguenti utenti hanno dato un "Like"


  13. #9
    L'avatar di Francesco92
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Agrigento
    Messaggi
    4
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Problema con i duplicati - Assenze studenti

    Ciao "ges", ho utilizzato la tua formula per risolvere quel problema che ho avuto l'anno scorso riguardo i duplicati per le assenze degli studenti. E' una formula adatta sia con Excel 2007 che con Excel 2010. Adesso ho un altro problema che non riesco a risolvere. Allego il file qui sotto. Gli alunni in "E8" e in "E9" hanno lo stesso numero di assenze. Il problema sta che si ordinano in modo decrescente. Premetto che ho utilizzato la funzione "GRANDE" anzichè "PICCOLO", come puoi vedere nella formula. Con la funzione "PICCOLO" il problema non si pone.
    Ti ringrazio anticipatamente e complimenti a te e a tutti per le formule pubblicate precedentemente.

    Ciao
    Francesco
    File Allegati File Allegati

  14. #10
    L'avatar di paolodig
    Clicca e Apri
    Data Registrazione
    Nov 2016
    Località
    Roma
    Età
    50
    Messaggi
    204
    Versione Office
    Excel 2007
    Likes ricevuti
    120
    Likes dati
    47

    Re: Problema con i duplicati - Assenze studenti

    Per quanto ne so io, non credo si possa risolvere in una unica formula il problema del sotto-ordinamento invertito dei duplicati.

    Io suggerisco una semplicissima colonna "C" di appoggio (che si puo' tranquillamente nascondere) con questa formula in "C4", da trascinarsi giu':

    =CONTA.SE(B$4:B4;B4)/10000


    Va inoltre inserita questa mia formula matriciale in "E4", da trascinarsi giu' :

    =SCARTO(INDIRETTO(INDIRIZZO(CONFRONTA(F4+CONTA.SE(F$4:F4;F4)/10000;$B$1:$B$13+$C$1:$C$13;0);2));0;-1)

    (da attivarsi ovviamente con CTRL+SHIFT+ENTER)

    Ovviamente il tutto funziona anche con piu' dei 2 duplicati da te proposti.
    Allego comunque il tuo file da me rielaborato e rinominato.

    Paolo
    File Allegati File Allegati

  15. I seguenti utenti hanno dato un "Like"


  16. #11
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199

    Re: Problema con i duplicati - Assenze studenti

    Ciao a tutti,

    potresti sfruttare i numeri della colonna F (non uso AGGREGA per sfruttare la formula anche su Excel 2007)

    In E4

    =INDICE(A$4:A$13;PICCOLO(SE(B$4:B$13=F4;RIF.RIGA($4:$13)-3);CONTA.SE(F$4:F4;F4)))

    sempre matriciale control+maiusc+invio

    Più o meno si ragiona con la stesse formule.


    Un saluto agli amici del Forum


    Saluti

  17. I seguenti 3 utenti hanno dato un "Like" a Canapone per questo post:


  18. #12
    L'avatar di Francesco92
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Agrigento
    Messaggi
    4
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Problema con i duplicati - Assenze studenti

    Ciao a tutti, grazie per le risposte, molto interessanti e funzionano. Io comunque ho risolto pure il problema sotituendo il "+RIF.RIGA" con il "-RIF.RIGA" nella formula che già avevo inserito. Non so se vi può interessare, ecco la nuova formula quindi modificata in "E4":

    =INDICE($A$4:$A$13;CONFRONTA(GRANDE(RANGO($B$4:$B$13;$B$4:$B$13;1)-RIF.RIGA($A$4:$A$13)/1000;RIF.RIGA(A1));RANGO($B$4:$B$13;$B$4:$B$13;1)-RIF.RIGA($A$4:$A$13)/1000;0))

Discussioni Simili

  1. [Risolto] Cerca duplicati in matrice e somma duplicati
    Di alleiram87 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 27/03/17, 21:51
  2. Duplicati id
    Di RUGANT54 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 30/12/16, 13:41
  3. [Excel 2010] Gestione presenze/assenze corsisti.....
    Di Daniele.Caso nel forum Domande su Excel VBA e MACRO
    Risposte: 7
    Ultimo Messaggio: 27/11/16, 12:20
  4. Classifica con duplicati
    Di Ste nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 15/11/15, 22:51
  5. VBA elimina i duplicati
    Di Gerardo Zuccalà nel forum Domande su Excel VBA e MACRO
    Risposte: 17
    Ultimo Messaggio: 17/07/15, 20:32

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •